abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 0
    dnes 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 3
    dnes 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 6
    dnes 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    dnes 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 11
    dnes 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    dnes 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    dnes 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 1
    včera 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    včera 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 8
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2820 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: zoneminder nestreamuje video - vše ostatní funguje!

    20.2.2013 14:13 raptor320d
    zoneminder nestreamuje video - vše ostatní funguje!
    Přečteno: 1719×
    Zdravím,

    reaguji z vlákna: http://www.abclinuxu.cz/poradna/linux/show/356510 který můj problém nevyřešilo.

    Jsem laik, prosím o shovívavost, nedaří se mi najít řešení už 3. týden. systém ubuntu 12.10

    Zoneminder mi jel úplně. 4 kamery, modect, eventy, prostě vše. Potom jsem se rejpal v apache2 a vytvořil 4 virtualhosty. Zároveň jsem provedel restart serveru a dokončili se nové aktualizuace které čekali na restart. Přičemž Firefox hlásil porušení bezpečnosti, a na to zřejmě záplatu.

    Od tohoto dne mi nejede přehrávání videa z kamer nikde. Nejede přímo na stroji kde je zm na firefox, nejede v ek$ploreru ani firefox vně ani venku sítě. Ale. Kamery jsou zm vidět (monitor i modect). Eventy se zaznamenávají. když je exportuji firefox mi je přehraje! Jede i stream přes vlc na stroji i vně sítě.

    v syslogu žádné hlášky nejsou

    Zkoušel jsem přeinstalovat zm, ffmpeg. Doinstaloval jsem cambozolu. Měnil uživatele mySql, přes phpMyAdmin zálohoval a obnovil databázi. 2x update/upgrade systému

    zkušel jsem na čisté mašině doinstalovat zm a vše jede

    předpokládám že jsem pouze přejmenoval práva k nějakému adresáři Díky za jakékoli nasměrování co s tím

    Odpovědi

    20.2.2013 21:54 Adamec | skóre: 32
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    Pus to v chromu ci chromiu a pouzij klav. CRTL+SHIFT+J pro konzoli ...
    This is not a bug it's a feature
    21.2.2013 08:21 raptor320d
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    trefa, píše to toto:

    Failed to load resource: the server responded with a status of 404 (Not Found) http://raptor.co.cz/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&rand=1361431132

    Failed to load resource: the server responded with a status of 404 (Not Found) http://raptor.co.cz/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&rand=1361431132&1361431150114
    21.2.2013 08:22 raptor320d
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    a pokračuje to v 10s intervalech:

    GET http://raptor.co.cz/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&rand=1361431132&1361431165115 404 (Not Found) mootools-core-nc.js:3622 Element.implement.setProperty mootools-core-nc.js:3622 fetchImage watch.js:620 (anonymous function) mootools-core-nc.js:906 (anonymous function) mootools-core-nc.js:906
    21.2.2013 09:32 oldsam
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    Vypadá to, že nenajde cgi skript. Podíval bych se na ScriptAlias v konfigu Apache:

    U mě na Fedoře je:
    ScriptAlias /cgi-bin/zm "/usr/libexec/zoneminder/cgi-bin"
    <Directory "/usr/libexec/zoneminder/cgi-bin">
        AllowOverride All
        Options ExecCGI
        Order allow,deny
        Allow from all
    </Directory>
    
    21.2.2013 13:42 raptor320d
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    v /etc/apache2/sites-availible/default je následující:
    ServerName raptor.co.cz
    
    <>VirtualHost *:80>
            ServerAdmin webmaster@localhost
    
            DocumentRoot /var/www
            <>Directory />
                    Options FollowSymLinks
                    AllowOverride None
            <>/Directory>
            <>Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            <>/Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <>Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            <>/Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    
        Alias /doc/ "/usr/share/doc/"
        <>Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        <>/Directory>
    
    <>/VirtualHost>
    
    
    doházel jsem tady to ">" jelikož mi to nechtělo vzít toto forum to "ServerName raptor.co.cz" jsem tam dopisoval aby apache nehlásil "neznám výchozí jméno serveru" nebo tak něco v logu zkoušel jsem to i smazat, nic se nestalo

    21.2.2013 13:50 raptor320d
    Rozbalit Rozbalit vše Re: zoneminder nestreamuje video - vše ostatní funguje!
    wordpress?

    zkoušel jsem před měsícem nainstalovat wordpress. rozjel se, něco jsem na něm zkoušel ale neměl jsem čas a teď TAKY nejede nepokakal jsem to tím wp?

    předpokládám že mi nejedou pouze ty CGI..
    21.2.2013 14:28 raptor320d
    Rozbalit Rozbalit vše CGI nejedou
    doplnil jsem si do /etc/apache2/httpd.conf následující
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/exa-z.cz
    ServerName exa-z.cz
    ServerAlias *.exa-z.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/rylich.eu
    ServerName rylich.eu
    ServerAlias *.rylich.eu
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/raptor.co.cz
    ServerName raptor.co.cz
    ServerAlias www.raptor.co.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/harnach-brno.cz
    ServerName harnach-brno.cz
    ServerAlias *.harnach-brno.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /usr/share/zoneminder
    ServerName zm.raptor.co.cz
    ServerAlias zm.raptor.co.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/wordpress
    ServerName wordpress.raptor.co.cz
    ServerAlias wordpress.raptor.co.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    
    a wordpress už mi jede ale bez CGI!!! nejedou mi CGI, nepříjdete na to proč? kde najdu proč se nespustí, co přeinstalovat

    díky kluci
    21.2.2013 14:32 raptor320d
    Rozbalit Rozbalit vše Re: CGI nejedou
    wordpress.raptor.co.cz hlási toto:
    Failed to load resource: the server responded with a status of 404 (Not Found) http://wordpress.raptor.co.cz/wordpress/wp-content/themes/twentyeleven/style.css
    
    Failed to load resource: the server responded with a status of 404 (Not Found) http://wordpress.raptor.co.cz/wordpress/wp-content/themes/twentyeleven/images/headers/wheel.jpg
    
    21.2.2013 15:12 raptor320d
    Rozbalit Rozbalit vše Re: CGI nejedou
    wordpress jede, zbývá zoneminder stále hlásí
    GET http://raptor.co.cz/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&rand=1361455493&1361455947712 404 (Not Found) 
    
    mootools-core-nc.js:3622
    21.2.2013 21:27 Adamec | skóre: 32
    Rozbalit Rozbalit vše Re: CGI nejedou
    kukni http://library.linode.com/web-servers/apache/php-cgi/ubuntu-10.04-lucid pro inspiracku
    This is not a bug it's a feature
    21.2.2013 21:48 Adamec | skóre: 32
    Rozbalit Rozbalit vše Re: CGI nejedou
    a taky bych asi kukl pomoci na php info
    http://php.net/manual/en/function.phpinfo.php
    co ti vyleze :)
    This is not a bug it's a feature
    21.2.2013 21:41 Adamec | skóre: 32
    Rozbalit Rozbalit vše Re: CGI nejedou
    co rika apachectl configtest ??
    This is not a bug it's a feature
    22.2.2013 20:07 raptor
    Rozbalit Rozbalit vše CGI jedou - chyba mezi klávesnicí a židlou!!!!!!
    skryptuje, děkuji za rady kluci.

    mám to, su debil, mám blbě nastavenej /etc/apache2/httpd.conf

    když konfiguraci vymažu, zoneminder se rozjede (ale nejedou 2 stránky napojené na moji IP"

    prosím o radu s konfigurací: mám tam:
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/exa-z.cz
    ServerName exa-z.cz
    ServerAlias *.exa-z.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    <>VirtualHost *:80>
    ServerAdmin petr@valmont.cz
    DocumentRoot /var/www/raptor.co.cz
    ServerName raptor.co.cz
    ServerAlias www.raptor.co.cz
    ErrorLog /var/log/servery/error.log
    <>/VirtualHost>
    
    díky chlapy
    23.2.2013 22:50 Adamec | skóre: 32
    Rozbalit Rozbalit vše Re: CGI jedou - chyba mezi klávesnicí a židlou!!!!!!

    </VirtualHost>

    This is not a bug it's a feature
    1.3.2013 16:23 raptor320d
    Rozbalit Rozbalit vše Re: CGI jedou - chyba mezi klávesnicí a židlou!!!!!!
    chtělo to opravdu konfiguraci přesunout z httpd.conf do sites-availible a spustit a2ensite díky za rady

    už to valí obojí

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.