abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 06:00 | Komunita

    Vydání Debianu 11 s kódovým jménem Bullseye je naplánováno na sobotu 14. srpna.

    Ladislav Hagara | Komentářů: 3
    včera 23:55 | Nová verze

    Google Chrome 92, konkrétně verze 92.0.4515.107, byl v úterý prohlášen za stabilní. Opraveno bylo 35 bezpečnostních chyb. Pete LePage doteď nepublikoval oficiální přehled novinek (New in Chrome, YouTube). Publikován byl jenom seznam novinek v nástrojích pro vývojáře (YouTube). Sundar Pichai dnes na Twitteru oznámil vylepšení integrované hry chrome://dino/.

    Ladislav Hagara | Komentářů: 6
    včera 08:00 | Nová verze

    Firewall firewalld (Wikipedie, GitHub) dospěl do verze 1.0.0. Upozornit je nutno na nekompatibilní změny. Zrušena byla podpora Pythonu 2.

    Ladislav Hagara | Komentářů: 0
    včera 01:11 | Komunita

    Milí priatelia Mozilly, tím Mozilla.sk hľadá pomoc v radoch dobrovoľníkov, ktorí sú ochotní pomáhať nám s týmto projektom. Vítaná je akákoľvek pomoc, no aktuálne hľadáme hlavne ľudí, ktorí by sa starali o aktuálnosť lokalizovaných článkov na stránkach podpory SUMO. Projekt je doteraz veľmi sviežo udržiavaný, no naše kapacity prekročili všetky limity a už nestíhame. Ak sa nám v najbližšej dobe nepodarí rozšíriť tím, bude nutné zo stránok

    … více »
    Ladislav Hagara | Komentářů: 19
    22.7. 12:00 | Nová verze

    PeerTube (Wikipedie), svobodná decentralizovaná platforma pro pro sdílení a přehrávání videí, byla vydána ve verzi 3.3. Z novinek lze zmínit možnost snadné úpravy úvodní stránky, vyhledávání v seznamech videí nebo kratší odkazy na videa.

    Ladislav Hagara | Komentářů: 28
    22.7. 09:00 | Komunita

    Vývojáři svobodného (GPLv3) šachového enginu Stockfish (Wikipedie) na svém blogu informují, že podali žalobu na společnost ChessBase (Wikipedie): ChessBase prodává šachový engine Fat Fritz 2 vycházející z enginu Stockfish a své uživatele neinformuje o GPL licenci a neposkytuje jim zdrojové kódy.

    Ladislav Hagara | Komentářů: 12
    22.7. 08:00 | Komunita

    Alyssa Rosenzweig se v příspěvku na blogu společnosti Collabora věnuje reverznímu inženýrství GPU Mali G78 s mikroarchitekturou a instrukční sadou Valhall. Po měsíci práce byla vydána referenční instrukční sada (pdf).

    Ladislav Hagara | Komentářů: 2
    22.7. 07:00 | Zajímavý software

    LiveKit je nedávno uvolněna open source platforma pro realtimovou komunikaci. Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 0
    21.7. 13:11 | Nová verze

    Po čtyřech měsících vývoje od vydání verze 5.7 byla vydána nová verze 5.8 svobodného open source redakčního systému WordPress. Kódové označení Tatum bylo vybráno na počest amerického jazzového klavíristy Arta Tatuma (Yesterdays).

    Ladislav Hagara | Komentářů: 25
    21.7. 08:00 | Bezpečnostní upozornění

    Společnost Qualys zveřejnila na svém blogu informace o v upstreamu již opravených bezpečnostních chybách CVE-2021-33909 v Linuxu (txt) a CVE-2021-33910 v systemd (txt). Chyba v Linuxu (fs/seq_file.c) je zneužitelná k lokální eskalaci práv.

    Ladislav Hagara | Komentářů: 7
    Preferuji
     (62%)
     (28%)
     (10%)
    Celkem 317 hlasů
     Komentářů: 61, poslední dnes 12:19
    Rozcestník

    Debian 10.10

    Byl vydán Debian 10.10, tj. desátá opravná verze Debianu 10 s kódovým názvem Buster. Řešeny jsou především bezpečnostní problémy, ale také několik vážných chyb. Instalační média Debianu 10 lze samozřejmě nadále k instalaci používat. Po instalaci stačí systém aktualizovat.

    19.6. 20:11 | Ladislav Hagara | Nová verze


    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    Komentáře

    Vložit další komentář

    20.6. 03:05 Rolf
    Rozbalit Rozbalit vše Re: Debian 10.10
    Proc aktualizovat 10 kdyz Marp uz ma 11 ta snad obsahuje uz vsechny predesle opravy, nebo jak je to?
    Migi avatar 20.6. 10:51 Migi | skóre: 58 | blog: Mig_Alley
    Rozbalit Rozbalit vše Re: Debian 10.10
    Protože Debian 11 ještě není stable? Poprvé na debianu?
    20.6. 11:36 Conista
    Rozbalit Rozbalit vše Re: Debian 10.10
    Lol a co to znamená být stable? To si nějaký manažér od zelenýho stolu řekne tak a teď tam plácneme nálepku stable?
    Jendа avatar 20.6. 12:14 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    Ne, to znamená, že už se nebudou povyšovat verze programů a budou se jen backportovat opravy.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 12:47 facepalm
    Rozbalit Rozbalit vše Re: Debian 10.10
    Tak to som zvedavy na tu "stabilitu" ked oprava vyjde len vo vyssej verzii apky. Pretoze backporter != autor a teda ten patch bude cista nikym netestovana zlatanina, kde jedine meritko kvality je, ze sa to podarilo skompilovat...
    Jendа avatar 20.6. 14:49 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    Nemusíš čekat na budoucí vydání, dělají to už 20 let, tak si můžeš udělat obrázek. Za mě: většinou to funguje, narazil jsem na jeden nebo možná dva bugy způsobené tímto. A pak samozřejmě teda to OpenSSL fiasko.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 14:05 hm
    Rozbalit Rozbalit vše Re: Debian 10.10
    neklam
    Max avatar 20.6. 12:44 Max | skóre: 69 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: Debian 10.10
    Ne, stable znamená, až dojde k freezu (stop novinek) a dokončí se všechny důležité opravy nutné k tomu, aby se to označilo za stable.
    Zdar Max
    Měl jsem sen ... :(
    20.6. 12:45 hm
    Rozbalit Rozbalit vše Re: Debian 10.10
    pretože debian 11 má IBA marp, ostatní musia čakať, kým oficiálne vyjde, preto update na 10.10 dáva zmysel
    pushkin avatar 21.6. 14:41 pushkin | skóre: 43 | blog: FluxBlog
    Rozbalit Rozbalit vše Re: Debian 10.10
    Ale houby, Debian 11 se dá stáhnout pěkných pár měsíců.
    22.6. 12:38 hm
    Rozbalit Rozbalit vše Re: Debian 10.10
    marpov posluhovač ideš het
    20.6. 09:37 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Tyjo uz konecne HP stihlo udelat driver hplip na Debian 10.9? Si ted nainstaluju 10.10 a zas mi nepojede tiskarna, nez se ti mamlasi z HP vzpamatuji. To je tragicka korporatni garazovka tohle.

    Ne.. proste neeeeeee... proboha ...

    Debian (....... 10.1,10.2,10.3,10.4,10.5,10.6,10.7,10.8) a slus.
    Migi avatar 20.6. 10:54 Migi | skóre: 58 | blog: Mig_Alley
    Rozbalit Rozbalit vše Re: Debian 10.10
    10.9 a 10.10 jsou v uvozovkách jen jeden apt update && apt upgrade od sebe. Je to jeden a ten samý systém. Ten člověk u HP, co tam píše ty verze, jen očividně nemá co na práci. Podobně jako ty, když hledáš problémy tam kde nejsou. Nebo jako já, když se po letech přihlásím na abíčko, jen abych v neděli dopoledne krmil troly.
    20.6. 11:12 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Tak pokud problemem neni to, ze laserovka od HP proste od 10.9 netiskne, tiskove ulohy se v cups tvari jako ze prosly a tiskarna se ani nehne, tak v poho, asi hledam problem tam kde neni. Mozna ty bys s tim byl spokojen, ze to netiskne .. se*e pes, ze jo... ja jaksi nee. Dik za chytry koment :D Asi sis nevsim, nebo tiskarnu od HP pod debianem vubec neprovozujes, ze od 10.9 jsou prejmenovany jiste baliky python-qt na pyqt (nebo naopak) a v HP si ten, co nema co na praci toho dosud nevsiml. Trole.
    20.6. 11:39 Conista
    Rozbalit Rozbalit vše Re: Debian 10.10
    Já bych hledal chybu v Debianu kdo ví co zase posrali že to nejede na novějších verzích
    20.6. 12:10 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    No prejmenovali baliky. A HP installer s tim nepocita a prste mu chybi jim ocekavane nazvy baliku. Jsou na netu navody jak ten installer prekonfigurovat. Patlal jsem se s tim asi 2 hodiny, laboroval a laboroval a nepovedlo se. Furt to trva na ocekavanych nazvech baliku. A to i kdyz vypnes podporu python-qt. Furt to po nich saha a nenajde je samozrejme, neb debianista to prejmenoval.

    Nekterym na netu se to prej povedlo. Jedna se o 3 pismenkovou zmenu. Ja to patlam 2 hodiny zadara a typek v HP za tohle bere mzdu. Pritom pro nej je to prace na 20 minut, neb presne vi kde sahnout v tom jejich instalatoru.

    To je proste cely jadro problemu. Strasny tohle. A to prosim mame uz verzi debianu 10.10. A HP nic. Lautr nic. Garazovka jakasi.
    Jendа avatar 20.6. 12:16 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    No prejmenovali baliky.
    Jako v rámci stable, a to navíc rok a půl po vydání? To se podle mě neděje.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 12:20 Jindřich Makovička | skóre: 17
    Rozbalit Rozbalit vše Re: Debian 10.10
    Kromě toho, já přes hplip tisknu a skenuju na unstable úplně normálně. Akorát jsem jednu chvíli myslel, že se mi začaly špatně renderovat PDF, ale pak se ukázalo, že prostě došla černá.
    20.6. 13:01 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
    ./hplip-3.21.4.run 
    Creating directory hplip-3.21.4
    Verifying archive integrity... All good.
    Uncompressing HPLIP 3.21.4 Self Extracting Archive..................
    
    HP Linux Imaging and Printing System (ver. 3.21.4)
    HPLIP Installer ver. 5.1
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    Installer log saved in: hplip-install_Sun-20-Jun-2021_12:42:50.log
    
    \
    note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
    \/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
      warnings.warn(str(e), _gtk.Warning)
    error: debian-10.9 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.8 version packages.
    
    Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y
    
    
    INSTALLATION MODE
    -----------------
    Automatic mode will install the full HPLIP solution with the most common options.
    Custom mode allows you to choose installation options to fit specific requirements.
    
    Please choose the installation mode (a=automatic*, c=custom, q=quit) : c
    
    
    INTRODUCTION
    ------------
    This installer will install HPLIP version 3.21.4 on your computer.
    Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
    
    
    DISTRO/OS CONFIRMATION
    ----------------------
    Distro appears to be Debian 10.9.
    
    Is "Debian 10.9" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y
    
    
    DRIVER OPTIONS
    --------------
    Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : 
    
    Initializing. Please wait...
    
    
    SELECT HPLIP OPTIONS
    --------------------
    You can select which HPLIP options to enable. Some options require extra dependencies.
    
    Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? 
    Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? n
    Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
    Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? n
    Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? 
    
    
    ENTER ROOT/SUPERUSER PASSWORD
    -----------------------------
    Please enter the root/superuser password: 
     
    
    INSTALLATION NOTES
    ------------------
    NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.
    
    Please read the installation notes. Press <enter> to continue or 'q' to quit: 
    
    
    SECURITY PACKAGES
    -----------------
    AppArmor is installed. 
    AppArmor protects the application from external intrusion attempts making the application secure
    
    Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? 
    
    
    RUNNING PRE-INSTALL COMMANDS
    ----------------------------
    OK
    
    
    RUNNING HPLIP LIBS REMOVE COMMANDS
    ----------------------------------
    su -c "apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp"
    su -c "apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp" ( hp_libs_remove step 1)
    OK
    
    
    MISSING DEPENDENCIES
    --------------------
    Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
    Package-Name         Component            Required/Optional   
    Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? 
    
    
    INSTALL MISSING REQUIRED DEPENDENCIES
    -------------------------------------
    note: Installation of dependencies requires an active internet connection.
    
    
    CHECKING FOR NETWORK CONNECTION
    -------------------------------
    Network connection present.
    
    
    RUNNING PRE-PACKAGE COMMANDS
    ----------------------------
    su -c "dpkg --configure -a" (Pre-depend step 1)
    su -c "apt-get install -f" (Pre-depend step 2)
    su -c "apt-get update" (Pre-depend step 3)
    OK
    
    
    DEPENDENCY AND CONFLICT RESOLUTION
    ----------------------------------
    error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
    error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
    
    
    RUNNING POST-PACKAGE COMMANDS
    -----------------------------
    OK
    
    
    RE-CHECKING DEPENDENCIES
    ------------------------
    error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
    error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
    error: Installation cannot continue without these dependencies.
    error: Please manually install this dependency and re-run this installer.
    

    Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? y

    ./hplip-3.21.4.run 
    Creating directory hplip-3.21.4
    Verifying archive integrity... All good.
    Uncompressing HPLIP 3.21.4 Self Extracting Archive........
    
    HP Linux Imaging and Printing System (ver. 3.21.4)
    HPLIP Installer ver. 5.1
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    Installer log saved in: hplip-install_Sun-20-Jun-2021_12:50:09.log
    
    \
    note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
    \/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
      warnings.warn(str(e), _gtk.Warning)
    error: debian-10.9 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.8 version packages.
    
    Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*): y
    
    
    INSTALLATION MODE
    -----------------
    Automatic mode will install the full HPLIP solution with the most common options.
    Custom mode allows you to choose installation options to fit specific requirements.
    
    Please choose the installation mode (a=automatic*, c=custom, q=quit) : c
    
    
    INTRODUCTION
    ------------
    This installer will install HPLIP version 3.21.4 on your computer.
    Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).
    
    
    DISTRO/OS CONFIRMATION
    ----------------------
    Distro appears to be Debian 10.9.
    
    Is "Debian 10.9" your correct distro/OS and version (y=yes*, n=no, q=quit) ? 
    
    
    DRIVER OPTIONS
    --------------
    Would you like to install Custom Discrete Drivers or Class Drivers ( 'd'= Discrete Drivers*,'c'= Class Drivers,'q'= Quit)?   : 
    
    Initializing. Please wait...
    
    
    SELECT HPLIP OPTIONS
    --------------------
    You can select which HPLIP options to enable. Some options require extra dependencies.
    
    Do you wish to enable 'Network/JetDirect I/O' (y=yes*, n=no, q=quit) ? 
    Do you wish to enable 'Graphical User Interfaces (Qt5)' (y=yes*, n=no, q=quit) ? y
    Do you wish to enable 'PC Send Fax support' (y=yes*, n=no, q=quit) ? n
    Do you wish to enable 'Scanning support' (y=yes*, n=no, q=quit) ? n
    Do you wish to enable 'HPLIP documentation (HTML)' (y=yes*, n=no, q=quit) ? 
    
    
    ENTER ROOT/SUPERUSER PASSWORD
    -----------------------------
    Please enter the root/superuser password: 
     
    
    INSTALLATION NOTES
    ------------------
    NOTE: Disable the CD Sources in your apt sources.list or the install will fail and hang.
    
    Please read the installation notes. Press <enter> to continue or 'q' to quit: 
    
    
    SECURITY PACKAGES
    -----------------
    AppArmor is installed. 
    AppArmor protects the application from external intrusion attempts making the application secure
    
    Would you like to have this installer install the hplip specific policy/profile (y=yes*, n=no, q=quit) ? 
    
    
    RUNNING PRE-INSTALL COMMANDS
    ----------------------------
    OK
    
    
    RUNNING HPLIP LIBS REMOVE COMMANDS
    ----------------------------------
    su -c "apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp"
    su -c "apt-get remove libhpmud0 libsane-hpaio printer-driver-postscript-hp" ( hp_libs_remove step 1)
    OK
    
    
    MISSING DEPENDENCIES
    --------------------
    Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
    Package-Name         Component            Required/Optional   
    pyqt5-dbus           gui_qt5              OPTIONAL            
    pyqt5                gui_qt5              REQUIRED            
    Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? 
    
    
    INSTALL MISSING REQUIRED DEPENDENCIES
    -------------------------------------
    note: Installation of dependencies requires an active internet connection.
    warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))
    
    Would you like to have this installer install the missing dependency (y=yes*, n=no, q=quit) ? 
    
    
    INSTALL MISSING OPTIONAL DEPENDENCIES
    -------------------------------------
    note: Installation of dependencies requires an active internet connection.
    warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
    
    Would you like to have this installer install the missing dependency (y=yes*, n=no, q=quit) ? 
    
    
    CHECKING FOR NETWORK CONNECTION
    -------------------------------
    Network connection present.
    
    
    RUNNING PRE-PACKAGE COMMANDS
    ----------------------------
    su -c "dpkg --configure -a" (Pre-depend step 1)
    su -c "apt-get install -f" (Pre-depend step 2)
    su -c "apt-get update" (Pre-depend step 3)
    OK
    
    
    DEPENDENCY AND CONFLICT RESOLUTION
    ----------------------------------
    Running 'su -c "apt-get install --force-yes -y gtk2-engines-pixbuf"'
    Please wait, this may take several minutes...
    Running 'su -c "apt-get install --force-yes -y python-pyqt5"'
    Please wait, this may take several minutes...
    Running 'su -c "apt-get install --force-yes -y python-dbus.mainloop.pyqt5"'
    Please wait, this may take several minutes...
    error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
    error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
    
    
    RUNNING POST-PACKAGE COMMANDS
    -----------------------------
    OK
    
    
    RE-CHECKING DEPENDENCIES
    ------------------------
    error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)' is still missing.
    error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))' is still missing.
    error: Installation cannot continue without these dependencies.
    error: Please manually install this dependency and re-run this installer.
    
    root@server2:/_inst# apt-cache search pyqt4-dbus
    root@server2:/_inst# apt-cache search python-qt4-dbus
    python-qt4-dbus - D-Bus Support for PyQt4
    python-qt4-dbus-dbg - D-Bus Support for PyQt4 (debug extensions)
    

    Jak tohle mohlo na 10.8 fungovat, kdyz se tedy takove zmeny nedeji?

    Nebo ma nekdo nejaky napad? Uplna automaticka instalace dela to same, a hplip z distra dela to, ze uloha projde a tiskarna se ani nehne.
    Jendа avatar 20.6. 14:54 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    Existuje snapshot repozitáře pro libovolný čas, pokud byl opravdu balíček později smazán/přejmenován, můžeš si ho vzít odtamtud.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 16:37 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    To se prave bojim, ale zkusit samozrejme muzu. Naposled jsem si takhle rozmlatil zavislosti s glibc a chtelo mi to odinstalovat pulku systemu.
    Jendа avatar 20.6. 17:51 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    Čekal bych, že glibc snad bude v rámci vydání kompatibilní, a jinak ti to přece při instalaci píše jestli je to kompatibilní a co to bude dělat.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 18:08 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    glibc byl priklad totalky havarky samozrejme. To neznamena, ze se to musi stat i tady. akorat si nedokazu predstavit kdyz X veci buzde zavislych na pyqt4-dbus a ja mu tam vnutim python-qt4-dbus. To muze dopadnout podobnou havarkou. Mozna mensi, ale preci jen...

    No jako situace je takova ze ted, kdyz uz potrebuju tisknout, naposled danove priznani, jinak cely rok nic, pac nemam datovku, tak tisknu u kamose v praci poslanim mu to na mail v PDF a stale se modlim, ze se v HP vzpamatuji :) Laborovat s tim .. no toho casu moc neni :) se priznam.

    Ale vim ze to tisklo. Minimalne z 10.8 rozhodne. Pak to tisknout prestalo z niceho nic.
    Jendа avatar 20.6. 19:16 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    A to jsi ten balíček měl a odinstaloval jsi ho? To je taky hodně nezvyklé, že by se při upgradu v rámci jedné verze distribuce odinstaloval balíček. Stáhl jsem si rok a půl starý seznam balíčků a v něm pyqt4-dbus taky není.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    Jendа avatar 20.6. 19:17 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    A jinak tohle se řeší úpravou toho skriptu (úpravou, pokud je čitelný; owarpováním dpkg pokud tahá informace z něj; výrobou dummy balíčku s tímto jménem; atd) aby si myslel že je to splněno.
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    20.6. 19:20 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Todle je uz na me vyssi divci, ktere se nevenuji dnes a denne, takze by to stalo moc casu, kdy misto venovani se klientum nevydelam nic. To si nemuzu zas az tak jen tak kdykoliv dovolit. Ale asi chapu cca jak to myslis. Jen nevim jestli mi to za 1x za rok tisk stoji za to. Samozrejme rad bych aby ta laserovka fungovala. Ale to usili .. vis jak. Jestli neni lepsi pockat proste a ono se to vyvrbi. Snad.
    21.6. 03:51 Palo M.
    Rozbalit Rozbalit vše Re: Debian 10.10
    Nechapem, preco tu kritizujes Debian, ked toto je evidentne len a len problem sposobeny vyrobcom tlaciarne (totzneho s vyrobcom toho balika co ti robi problem), teda je to problem sposobeny HP.

    Ja osobne si od HP uz nikdy ziadnu tlaciaren nekupim. A to nie kvoli Debianu, ale kvoli ich neslavne znamym praktikam.
    k3dAR avatar 20.6. 19:29 k3dAR | skóre: 60
    Rozbalit Rozbalit vše Re: Debian 10.10
    ze by to(stejne hplip jako zkousis) v 10.8 slo je dost divne, protoze nevidim ze by se mezi 10.8-10.9/10.10 ty balicky v Debianu prejmenovali, resp. aktualni nazev to melo nejen od 10.0, ale uz v Debian 9, viz dotaz tveho problemu v Debian 9

    porad nemam telo, ale uz mam hlavu... nobody
    k3dAR avatar 20.6. 19:58 k3dAR | skóre: 60
    Rozbalit Rozbalit vše Re: Debian 10.10
    Příloha:
    tak sem zjistil v cem je problem, NE ze by debian prejmenoval balicky, ALE hplip pri instalaci detekuje verzi systemu a podle toho nastavi hromadu veci ze "sablony" daneho distra dane verze a protoze Debian 10.9 ani 10.10 v sablone nema, tak nenastavi spravne nic, vezme nejakou default sablonu ci co... reseni je:
    # rozbalit instalacku bez instalovani
    mkdir /tmp/hplip-rozbalene
    sh hplip-3.21.4.run --noexec --target /tmp/hplip-rozbalene
    
    # otevrit soubor se "sablonama"
    nano /tmp/hplip-rozbalene/installer/distros.dat
    
    v sekci [debian] na radku zacinajici versions= pripsat na konci za 10.8 verze ,10.9,10.10 (oddelit , tak jak byli stavacici verze) odstavec/sekci zacinajici [debian:10.8] az radek naslednej "# ****************************************" zkopirovat a zmenit v nem vsechny 10.8 na 10.9, to same udelat pro 10.10...

    presne takto upravenej soubor (z hplip-3.21.4.run) davam do prilohy, pokud bys nechapal co kde zmenit, tak jim proste nahrad ten v rozbalenem adresari... ;-)
    # spustit instalaci
    cd /tmp/hplip-rozbalene
    ./hplip-install
    porad nemam telo, ale uz mam hlavu... nobody
    20.6. 20:08 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Zkusim.
    6.7. 11:35 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Funguje, diky. To se teda divim, ze tohle nejsou schopni v HP pridat. Takova velka firma. Mimochodem s distros.dat jsem se taky babral, ale sel jsem na to metodou upravy nazvu baliku v sekci pro 10.8, coz on pise ze pouziva, pokud nema 10.9. V podstate keca a jak pises, pouziva nejakou sablonu, ktera ale selze. Jeste jednou diky.
    Migi avatar 20.6. 15:13 Migi | skóre: 58 | blog: Mig_Alley
    Rozbalit Rozbalit vše Re: Debian 10.10
    No tak tady máš ten kámen urazu, namísto nějakoeho pochybneho run souboru máš pouzivat nativní baličky dostupne v repozitaři debianu, pak bycs neměl tyhle začatečnícký problemy a nemusel bys dělat tlaky ve veřejne diskusi.

    https://packages.debian.org/search?keywords=hplip-gui
    20.6. 16:33 nemam
    Rozbalit Rozbalit vše Re: Debian 10.10
    Ano, mam pouzivat nativni balicek. Pricemz pisu, ze nativni dela to, ze tiskova uloha projde a tiskarna se ani nehne. Chlape cti prosim poradne, nez odpovis a nedelej ze sebe hlupaka. Dik, jinak nema diskuze moc smysl.
    Migi avatar 20.6. 19:52 Migi | skóre: 58 | blog: Mig_Alley
    Rozbalit Rozbalit vše Re: Debian 10.10
    Tohle mi dělaly hp tiskarny bezne i na windows, Na nich stačilo tiskarnam zakazat obousmernou komunikaci a problem byl vyřešen i na linuxu. Alternativně stačilo tiskarnu popohnat stlačením nejakeho tlačítka, nevimajk se nazyva. Tohle povazuju za chybu tiskarny, nicmene uz jsem se tim dlouho nezabyval.
    Jendа avatar 20.6. 12:23 Jendа | skóre: 77 | blog: Jenda | JO70FB
    Rozbalit Rozbalit vše Re: Debian 10.10
    Není nic jako "já mám 10.9 a ty máš 10.10". Balíčky se updatují průběžně a jednou za pár měsíců na to někdo dá nálepku s vyšším číslem a přegeneruje instalační média (která si myslím, že v dnešní době stejně není důvod používat).
    Je to vlastně jenom taková obyčejná mikrovlnka, jenom otevřená ven.
    pushkin avatar 21.6. 14:43 pushkin | skóre: 43 | blog: FluxBlog
    Rozbalit Rozbalit vše Re: Debian 10.10
    Tak třeba u mě na Debianu 11 tisk v pohodě, ale sken ze záhadnýho důvodu jen přes síť (DJ 3545). Ale také to má být závada HPLIPu...

    Založit nové vláknoNahoru


    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.