Omarchy (Wikipedie) je linuxová distribuce s dlaždicovým správcem oken Hyprland. Založena je na Arch Linuxu. Vydána byla v nové verzi 4.5.0. Nově také pro Apple Silicon, konkrétně pro M1/M2/M3/Neo MacBooky.
Byla vydána nová stabilní verze 8.3 webového prohlížeče Vivaldi (Wikipedie). Postavena je na Chromiu 156 s bezpečnostními opravami z Chromia 157. Přehled novinek i s náhledy v příspěvku na blogu.
Multimediální přehrávač mpv byl vydán ve verzi 0.42.0. Jde o větší balík změn po bezmála roce. Mimo jiné se lépe integruje s Waylandem nebo rozšiřuje podporu DVD/Blu-ray, např. umožňuje přehrávat rovnou obrazy médií (soubory iso).
Desktopové prostředí LXQt (Lightweight Qt Desktop Environment, Wikipedie) vzniklé sloučením projektů Razor-qt a LXDE bylo vydáno ve verzi 2.5.0. Přehled novinek v poznámkách k vydání.
Byla vydána (𝕏) nová verze 8.0 LTS open source monitorovacího systému Zabbix (Wikipedie). Přehled novinek v oznámení na webu, v poznámkách k vydání a v aktualizované dokumentaci.
Byla vydána verze R14.1.7 desktopového prostředí Trinity Desktop Environment (TDE, fork KDE 3.5, Wikipedie). Přehled novinek v poznámkách k vydání, podrobnosti v seznamu změn.
Bazzite (Wikipedie), tj. linuxová distribuce vycházející z Fedora Linuxu a optimalizována pro hraní počítačových her, byla vydána ve verzi 45. S Open Gaming Collective (OGC) jádrem a novým Easy Anti-Cheatem pro Linux (EAC Linux v2).
MikroTik zveřejnil vlastní bezpečnostní upozornění potvrzující, že zranitelnost linuxového jádra postihuje také RouterOS 7. Jde o use-after-free při zpracování IPv4 TCP spojení s IP options. Zranitelnost se týká provozu směřujícího na TCP službu samotného routeru, nikoli paketů, které router pouze přeposílá. Opraveno v long-term od 7.24.6, v stable od 7.25.1 a devel od 7.26beta5.
Ve správci balíčků APT, používaném v Debianu a odvozených distribucích, byla nalezena a opravena kritická zranitelnost CVE-2026-109518. Vzdálený útočník může obejít ověření stažených balíčků pomocí přesměrování a dočasných chyb HTTP serveru.
Už podruhé se mi stal v Archu obdobný problém. Konkrétně nyní mi pacman při pokusu o upgrade hlásí:
error: unresolvable dependencies: dbus: requires expat>=2.0 fontconfig: requires expat>=2.0 libwmf: requires expat>=2.0 neon: requires expat>=2.0 perlxml: requires expat>=2.0 wxgtk: requires expat>=2.0
Nebylo by na tom nic divného, pokud bych neměl expat ve verzi 2.0.0-1 Nevíte někdo, co s tím?
pacman -Syu (za predpokladu ze je testing repozitar povolen v pacman.conf v etc). Pise ti to prave proto, ze nevi nic o novych verzich z testing repozitare.
To vím (asi jsem to měl uvést), že mi to zlobí u balíčků z testing repozitáře. Testing MÁM povolen. pacman -Syu právě v tomto případě pohoří a nic nenainstaluje ani nepřeinstaluje. Abych se někam dostal, musím u balíčků, které mají problém, provést downgrade na current verzi.
Mohu se ještě zeptat? Pokud mám povoleny repozitáře current, extra, je repozitář testing ignorován. Pro instalaci z něj je musím dočasně zakázat. Je tohle dáno obecně, nebo to lze někde přenastavit? Možná by právě tohle uvedený problém vyřešilo.
testing je jakozto nestabilni zakazan standartdne a povoluji si jej uzivatele sami...
Pokud je vsak testing povolen, maji z nej - jakozto nejnovejsi verze - balicky vzdy prednost pred ostatnini (at uz jsou v extra nebo current)Cely stav muzes napravit tim, ze zakazes testing, rucne "downgrade" expat na 1.9.5 a pak to pojede bez problemu. Nebo si muzes balicek expact dat do ignore listu prikazemIgnorePkg = balicek u ktereho chci zakazat jeho aktualizaci a povolit testing - budes aktualizovat novinky, ale expact se neupgraduje na 2.0. Balicek muzes pak povolit, az bude v current nebo extra (a vsechny zavisle veci na nem tam budou taky) a nebude ti zlobit update z testing.Tohle se stava, kdyz je na zrcadlo odkud tahas z testingu nekatualizovane (nebo se aktualizuje treba o 1 den pozadu ) a pak se stane, ze nejsou k dispozici nove balicky.
Ale je mozne ze chba je jinde naz na zrcadle...pacman -S expact (az zakazes testing)... pacman.conf, ale nemá. Mimochodem, expat downgradeovat nemusím - potřeba bylo provést downgrade u těch ostatních balíčků, kterým vadila "nízká verze" balíčku expat.
pacman -Q expat mi nahlásí správnou verzi. Jeho nepřítomnost v repozitáři by snad ale vadit neměla - přece si musí kontrolovat, zda je balíček nainstalován, a ne, zda je dostupný. Možná mám ale zkreslené představy
Tiskni
Sdílej: