abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 19:22 | Nová verze

    GNU Project Debugger aneb GDB byl vydán ve verzi 18.1. Podrobný přehled novinek v souboru NEWS.

    Ladislav Hagara | Komentářů: 0
    25.9. 23:33 | Humor

    Prezident USA Donald Trump během svého projevu na valném shromáždění OSN 22. září 2026 prohlásil, že umělá inteligence 'bude dále oficiálně nazývána superinteligencí', zkráceně SI. Svůj návrh zdůvodnil takto: 'Použití slova artificial činí inteligenci falešnou. Ona falešná není, ve skutečnosti je úžasná'. Zároveň ve svém proslovu prohlásil, že Spojené státy kategoricky odmítají jakékoliv pokusy o vytvoření 'globalistického

    … více »
    AfD 💙 | Komentářů: 12
    25.9. 23:22 | Nová verze

    Čínská technologická firma Xiaomi představila novou verzi 2.6 svého modelu MiMo, váhy modelů MiMo‑V2.6‑Pro‑RL a MiMo‑V2.6‑Flash‑RL jsou dostupné na HuggingFace pod licencí MIT. Výkonnější varianta Pro má přes bilion parametrů, z toho 42 miliard aktivních, úspornější Flash 309 miliard parametrů, z nichž se při generování aktivuje přibližně 15 miliard. Oba modely mají délku kontextového okna milion tokenů. Tyto MoE modely zvládají

    … více »
    AfD 💙 | Komentářů: 0
    25.9. 03:33 | Komunita

    Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.

    Ladislav Hagara | Komentářů: 0
    24.9. 21:11 | Nová verze

    Byla vydána nová verze 2.0 klienta F-Droid určeného pro instalaci bezplatných a otevřených mobilních aplikací do Androidu ze softwarového repozitáře F-Droid (Wikipedie). Jedná se o alternativu k Google Play.

    Ladislav Hagara | Komentářů: 7
    24.9. 12:11 | Komunita

    Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.

    Ladislav Hagara | Komentářů: 0
    24.9. 11:44 | Bezpečnostní upozornění

    Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…

    Ladislav Hagara | Komentářů: 0
    24.9. 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 0
    23.9. 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 10
    23.9. 14:33 | IT novinky

    Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.

    Ladislav Hagara | Komentářů: 11
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2735 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: SASL authentication failure: Can only find author (no password)

    24.10.2006 13:09 Marek
    SASL authentication failure: Can only find author (no password)
    Přečteno: 919×
    Můžu zde požádat o radu při rozběhnutí postfix + SASL + Courier. Při přihlášení nedojde k ověření hesla.

    Výpis z logu:
    - postfix/smtpd[12272]: warning: SASL authentication failure: Can only find author (no password)
    - postfix/smtpd[12272]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed
    - postfix/smtpd[12272]: disconnect from localhost[127.0.0.1]
    - courierpop3login: Connection, ip=[]
    - courierpop3login: LOGIN FAILED, ip=[]
    
    Výpis - telnet 25:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 server.tld ESMTP
    EHLO domena.tld
    250-server.tld
    250-PIPELINING
    250-SIZE 25000000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    
    Děkuji předem za nakopnutí ...

    Odpovědi

    24.10.2006 22:27 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    ještě bych dodal, že ověřování probíhá prostřednictvím MySQL databáze. Díky za jakoukoliv radu.
    24.10.2006 22:28 Zdeněk Burda | skóre: 61 | blog: Zdendův blog | Praha
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    co kdys nám sem popsal jak to máš nastavené?
    -- Nezdar není hanbou, hanbou je strach z pokusu.
    25.10.2006 15:27 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Díky za opravu a případné nápady, v čem by mohl být problém.

    Nastavení main.cf postfixu:
    broken_sasl_auth_clients = yes
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_application_name = smtpd
    smtpd_use_tls =                 yes
    smtp_use_tls =                  yes
    
    Nastavení /etc/default/saslauthd:
    START=yes
    MECHANISMS="pam"
    PARAMS="-m -r /var/spool/postfix/var/run/saslauthd/"
    
    S tímto nastavení nelze saslauthd spustit (failed). Pokud vypustím "PARAMS" pak ano.

    Nastavení /etc/courier/authdaemonrc
    authmodulelist="authmysql"
    authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"
    daemons=1
    version=""
    authdaemonvar=/var/run/courier/authdaemon
    
    Nastavení /etc/courier/authmodulelist
    authdaemon
    
    Nastavení /etc/courier/authmysqlrc:
    MYSQL_SERVER            localhost
    MYSQL_USERNAME          posta
    MYSQL_PASSWORD          posta
    
    MYSQL_DATABASE          maildb
    MYSQL_USER_TABLE        mailbox
    MYSQL_CRYPT_PWFIELD     password
    MYSQL_LOGIN_FIELD       username
    MYSQL_HOME_FIELD        '/home/mail/'
    MYSQL_NAME_FIELD        name
    MYSQL_MAILDIR_FIELD     maildir
    MYSQL_QUOTA_FIELD       quota
    
    30.10.2006 14:48 Jirka
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Ahoj,
    nemelo by to byt takto:

    Nastavení /etc/default/saslauthd:
    ...
    PARAMS="-r -m /var/spool/postfix/var/run/saslauthd/"
    
    30.10.2006 15:52 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Děkuji mnohokrát za radu, prohození parametrů pomohlo :-)
    Bohužel to stále neřeší problém s autentizací.

    Díky moc
    26.10.2006 11:19 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Pokud je potřeba uvést jiná nastavení pro zjištění příčiny, napište prosím která. Uričtě je zde uvedu. Díky
    24.10.2006 22:32 Zdeněk Burda | skóre: 61 | blog: Zdendův blog | Praha
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    pro výpisy používej pre tag (opravil jsem ti dotaz)
    -- Nezdar není hanbou, hanbou je strach z pokusu.
    30.10.2006 16:50 Jirka
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Ahoj,
    a jak probehne test autentifikace?
    testsaslauthd -u user -p password -f /var/spool/postfix/var/run/saslauthd/mux
    
    30.10.2006 17:33 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Autentifikace neproběhne. Chybová hláška:
    0: NO "authentication failed"
    Výpis z logu (auth.log):
    saslauthd[12976]: (pam_unix) check pass; user unknown
    saslauthd[12976]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
    saslauthd[12976]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying
                                                                authentication module
    saslauthd[12976]: do_auth: auth failure: [user=test@example.cz] [service=imap] [realm=]
                                             [mech=pam] [reason=PAM auth error]
    
    Opět nezvývá než poděkovat za radu, nyní je prooblém zase o něco jasnější.
    Může za to chyba ve výběru Auth modulu ? (snažím se využívat MySQL databáze - authmysql)
    vasek125 avatar 26.10.2006 12:05 vasek125 | skóre: 30 | Mladá Boleslav
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Problém bych hledal s /etc/pam.d/smtp. Připadně mohou být špatně zadány hodnoty v databázi.
    30.10.2006 13:02 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    děkuji za tip, /etc/pam.d/smtp je nastaveno takto:

    auth sufficient pam_mysql.so user=postfix passwd=heslo host=localhost db=maildb \
    table=mailbox usercolumn=username passwdcolumn=password crypt=1 md5=y auth required pam_deny.so

    account sufficient pam_mysql.so user=postfix passwd=heslo host=localhost db=maildb \
    table=mailbox usercolumn=username passwdcolumn=password
    account required pam_deny.so

    Zatím se nepodařilo spustit démona saslathd, což by mohl být důvod neúspěchu při přihlášní. Děkuji za jakékoliv další rady.
    10.1.2007 14:02 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Problém byl odstraněn. Bohužel jsem neměl v databázi uvedená platná hesla (MD5). Moc všem děkuji za rady, které byly určitě přínosem.

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.