abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 23:11 | Bezpečnostní upozornění

    Soutěž Pwn2Own Ireland 2026 skončila 9. října. Bezpečnostní výzkumníci získali celkem 1 262 000 dolarů na odměnách. Během soutěže bylo předvedeno zneužití 98 zero-day zranitelností. Testování zahrnovalo různé kategorie zařízení a software. Výzkumníci předváděli prakticky fungující útoky podle pravidel soutěže. Výsledky následně slouží výrobcům při přípravě oprav. Mezi pokořenými jsou: Samsung Galaxy S26, OpenAI Codex, Oracle Autonomous AI Database, Google Pixel 10, u iPhone 17 neuspěli.

    vencour | Komentářů: 0
    9.10. 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 6
    9.10. 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 8
    9.10. 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 14
    9.10. 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    9.10. 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 12
    9.10. 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    9.10. 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    9.10. 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 1
    8.10. 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2828 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: SASL authentication failure: Can only find author (no password)

    24.10.2006 13:09 Marek
    SASL authentication failure: Can only find author (no password)
    Přečteno: 922×
    Můžu zde požádat o radu při rozběhnutí postfix + SASL + Courier. Při přihlášení nedojde k ověření hesla.

    Výpis z logu:
    - postfix/smtpd[12272]: warning: SASL authentication failure: Can only find author (no password)
    - postfix/smtpd[12272]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed
    - postfix/smtpd[12272]: disconnect from localhost[127.0.0.1]
    - courierpop3login: Connection, ip=[]
    - courierpop3login: LOGIN FAILED, ip=[]
    
    Výpis - telnet 25:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 server.tld ESMTP
    EHLO domena.tld
    250-server.tld
    250-PIPELINING
    250-SIZE 25000000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    
    Děkuji předem za nakopnutí ...

    Odpovědi

    24.10.2006 22:27 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    ještě bych dodal, že ověřování probíhá prostřednictvím MySQL databáze. Díky za jakoukoliv radu.
    24.10.2006 22:28 Zdeněk Burda | skóre: 61 | blog: Zdendův blog | Praha
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    co kdys nám sem popsal jak to máš nastavené?
    -- Nezdar není hanbou, hanbou je strach z pokusu.
    25.10.2006 15:27 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Díky za opravu a případné nápady, v čem by mohl být problém.

    Nastavení main.cf postfixu:
    broken_sasl_auth_clients = yes
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_application_name = smtpd
    smtpd_use_tls =                 yes
    smtp_use_tls =                  yes
    
    Nastavení /etc/default/saslauthd:
    START=yes
    MECHANISMS="pam"
    PARAMS="-m -r /var/spool/postfix/var/run/saslauthd/"
    
    S tímto nastavení nelze saslauthd spustit (failed). Pokud vypustím "PARAMS" pak ano.

    Nastavení /etc/courier/authdaemonrc
    authmodulelist="authmysql"
    authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"
    daemons=1
    version=""
    authdaemonvar=/var/run/courier/authdaemon
    
    Nastavení /etc/courier/authmodulelist
    authdaemon
    
    Nastavení /etc/courier/authmysqlrc:
    MYSQL_SERVER            localhost
    MYSQL_USERNAME          posta
    MYSQL_PASSWORD          posta
    
    MYSQL_DATABASE          maildb
    MYSQL_USER_TABLE        mailbox
    MYSQL_CRYPT_PWFIELD     password
    MYSQL_LOGIN_FIELD       username
    MYSQL_HOME_FIELD        '/home/mail/'
    MYSQL_NAME_FIELD        name
    MYSQL_MAILDIR_FIELD     maildir
    MYSQL_QUOTA_FIELD       quota
    
    30.10.2006 14:48 Jirka
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Ahoj,
    nemelo by to byt takto:

    Nastavení /etc/default/saslauthd:
    ...
    PARAMS="-r -m /var/spool/postfix/var/run/saslauthd/"
    
    30.10.2006 15:52 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Děkuji mnohokrát za radu, prohození parametrů pomohlo :-)
    Bohužel to stále neřeší problém s autentizací.

    Díky moc
    26.10.2006 11:19 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Pokud je potřeba uvést jiná nastavení pro zjištění příčiny, napište prosím která. Uričtě je zde uvedu. Díky
    24.10.2006 22:32 Zdeněk Burda | skóre: 61 | blog: Zdendův blog | Praha
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    pro výpisy používej pre tag (opravil jsem ti dotaz)
    -- Nezdar není hanbou, hanbou je strach z pokusu.
    30.10.2006 16:50 Jirka
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Ahoj,
    a jak probehne test autentifikace?
    testsaslauthd -u user -p password -f /var/spool/postfix/var/run/saslauthd/mux
    
    30.10.2006 17:33 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Autentifikace neproběhne. Chybová hláška:
    0: NO "authentication failed"
    Výpis z logu (auth.log):
    saslauthd[12976]: (pam_unix) check pass; user unknown
    saslauthd[12976]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
    saslauthd[12976]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying
                                                                authentication module
    saslauthd[12976]: do_auth: auth failure: [user=test@example.cz] [service=imap] [realm=]
                                             [mech=pam] [reason=PAM auth error]
    
    Opět nezvývá než poděkovat za radu, nyní je prooblém zase o něco jasnější.
    Může za to chyba ve výběru Auth modulu ? (snažím se využívat MySQL databáze - authmysql)
    vasek125 avatar 26.10.2006 12:05 vasek125 | skóre: 30 | Mladá Boleslav
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Problém bych hledal s /etc/pam.d/smtp. Připadně mohou být špatně zadány hodnoty v databázi.
    30.10.2006 13:02 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    děkuji za tip, /etc/pam.d/smtp je nastaveno takto:

    auth sufficient pam_mysql.so user=postfix passwd=heslo host=localhost db=maildb \
    table=mailbox usercolumn=username passwdcolumn=password crypt=1 md5=y auth required pam_deny.so

    account sufficient pam_mysql.so user=postfix passwd=heslo host=localhost db=maildb \
    table=mailbox usercolumn=username passwdcolumn=password
    account required pam_deny.so

    Zatím se nepodařilo spustit démona saslathd, což by mohl být důvod neúspěchu při přihlášní. Děkuji za jakékoliv další rady.
    10.1.2007 14:02 Marek-27 | skóre: 3
    Rozbalit Rozbalit vše Re: SASL authentication failure: Can only find author (no password)
    Problém byl odstraněn. Bohužel jsem neměl v databázi uvedená platná hesla (MD5). Moc všem děkuji za rady, které byly určitě přínosem.

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.