FreeTube, desktopový klient pro YouTube využívající lokální API, byl vydán ve verzi 0.26.0. Toto velké opravné vydání mj. vrací částečnou podporu živých přenosů nebo přepracovává zobrazování titulků a obecně nastavení videa v přehrávači – FreeTube umožňuje např. přehrávat video s větším zrychlením.
Další vlna kyberútoků zasáhla chladicí zařízení supermarketů v sedmi evropských zemích, Belgii, Lucembursku, Švédsku, Nizozemsku, Irsku, Estonsku a Finsku. Mrazáky se v některých prodejnách opět 'proměnily v trouby' a zahřály až na 50°C, což pochopitelně vedlo ke znehodnocení uskladněných potravin. Útoky navazují na podobný incident ve Francii z první poloviny října letošního roku, pachatel stále není znám.
Zranitelnost v aktualizačním mechanismu WordPress umožňuje útočníkovi zasáhnout do dočasného instalačního adresáře během aktualizace jádra systému. Před aktualizací veřejně dostupného WordPressu dočasně zablokovat HTTP přístup k wp-content/upgrade/, následně aktualizovat a zkontrolovat logy. Postižené verze: WordPress 4.7 až 7.1.3.
Alpine Linux zveřejnil podrobnosti o útoku na svůj GitLab a 30. října oznámil obnovení provozu. Útočník se 20.–21. října pokusil zneužít chybu v regulárních výrazech. Exploit způsobil opakované pády workerů a několikrát se dostal do pokročilé fáze. Úspěšné spuštění kódu však nebylo potvrzeno. Fix: Opravený GitLab a současně Ruby 3.3.13, 3.4.12 nebo 4.0.9+, pokud jde o vlastní sestavení či kontejner.
Konference OpenAlt 2026 proběhne tento víkend 7. a 8. listopadu na FIT VUT v Brně. Jedná se již o 21. ročník této konference, která propojuje otevřené technologie, svobodný software, hardware a lidi, kteří chtějí věci nejen používat, ale také jim rozumět a měnit je k lepšímu. Více o konferenci v příspěvku OpenAlt 2026: technologie, které dávají svobodu na blogu spolku OpenAlt.
Eben Upton oznámil další zdražení jednodeskových počítačů Raspberry Pi. Tentokrát 16 GB varianty Raspberry Pi o 80 dolarů a 16 GB varianty Raspberry Pi Compute Module 5 o 40 dolarů. Cena Raspberry Pi 500+ se nemění.
Francouzské Národní shromáždění přijalo 30. října 2026 poměrem 11 hlasů pro, 10 proti a 14 abstencí pozměňovací návrh I-1358 ke státnímu rozpočtu na rok 2027, který zavádí daň z objemu dat doručovaných uživatelům internetu. Návrh socialistického poslance Laurenta Lhardita stanovuje sazbu 0,055 eura za gigabajt, tedy 55 eur za terabajt. Zatím nejde o platný zákon, ale o dílčí hlasování během prvního čtení rozpočtu. Daň by měli platit
… více »Nizozemská vláda ve snaze šetřit a zvyšovat efektivitu s využitím umělé inteligence (AI) hodlá zrušit asi 25.000 pracovních míst ve státní správě. Cílem je postupně dosáhnout ročních úspor až 3,5 miliardy eur (85,2 miliardy Kč). Na konci loňského roku ve státní správě pracovalo rekordních 160.000 lidí. „Nemůžeme pokračovat v tom, co jsme dělali dosud,“ uvedl státní tajemník pro efektivní fungování vlády Eric van den Burg. „Proto
… více »Potreboval by som nejaký softík (samozrejme pre linux) ktorý by mi vedel nejako vyhľadať všetky tieto domény ukazujúce na túto IP.To má prohledat všechny domény na světě?
V zásadě byste potřeboval provést zone transfer celého DNS stromu, čili začít od root serverů, vyptat se jich na všechny TLD domény a jejich nameservery, atd. atd... Ve všech stažených zónách byste pak hledal výskyt A záznamu pro tu vaši adresu. Takové řešení je ovšem prakticky nerealizovatelné - jednak by jeho náročnost byla extrémní (a to je eufemismus) a druhák drtivá většina nameserverů neumožňuje zone transfer každému přicmrndálkovi, co jde kolem, takže se navíc potřebné údaje ani nemáte jak dozvědět.
Suma sumárum, váš požadavek nelze žádným způsobem realizovat.
A kromě toho, ten požadavek je pofiderní už ze své podstaty. Konzistence DNS záznamů vyžaduje, aby pro jednu IP adresu existoval právě jeden A záznam a k němu odpovídající právě jeden PTR záznam. Dále pak může existovat hromada CNAME záznamů, které všechny míří na ten A záznam. Ovšem řešení "mám spoustu A záznamů pro jednu IP adresu" je zcela špatně, protože tyto záznamy jaksi z podstaty nemohou být všechny najednou konzistentní s reverzním záznamem.
Nicméně, i v případě, že je to nastaveno "tak jak to má být", se prostě o existenci nějakého CNAME záznamu nemůžete dozvědět žádným jiným způsobem, než zone transferem z toho nameserveru, který příslušný záznam drží.
Konzistence DNS záznamů vyžaduje, aby pro jednu IP adresu existoval právě jeden A záznam a k němu odpovídající právě jeden PTR záznam.
Taky jsem si to dřív myslel, ale podle všeho to není úplně pravda: nikde jsem totiž nenašel požadavek, že by PTR záznam nemohl být násobný. Takže varianta typu
name1. a 1.2.3.4 name2. a 1.2.3.4 4.3.2.1.in-addr.arpa. ptr name1. 4.3.2.1.in-addr.arpa. ptr name2.
by měla být v pořádku. Běžná praxe (nejen) českých provozovatelů webhostingu, kdy se naseká sto a záznamů se stejnou hodnotou a na reverzy se kašle, už ale samozřejmě v pořádku není.
Je fakt, že požadavek na unikátnost PTR záznamu jsem taky nikde explicitně formulovaný nenašel, i když tak nějak automaticky žiju s tím, že platí.
Když to ale vezmu z opačného konce, RFC 1033 říká, že "There should be one A record for each address of a host." Takže v první řadě nemá existovat více A záznamů k jedné adrese - a z toho pak sekundárně vyplyne, že vícenásobný PTR záznam jaksi nemá důvod existovat.
Je jistě pravda, že RFC 2119 říká, že should znamená, že "may exist valid reasons in particular circumstances to ignore a particular item, but the full implications must be understood and carefully weighed before choosing a different course." Myslím si ale, že kdejaký webhostingový server prostě nezakládá "valid reasons", nehledě k tomu, že drtivá většina "provozovatelů" těchto serverů se rozhodně nekvalifikuje do kategorie "full implications must be understood and carefully weighed" 
I nadále budu žít (a zejména provozovat DNS) v domění, že k jedné IP adrese patří právě jeden A záznam a právě jeden PTR záznam. Veskrze se to shoduje s myšlenkou "be conservative in what you do, be liberal in what you accept from others", uvedenou v RFC 793 
There should be one A record for each address of a host.
Tak na tenhle požadavek jsem zapomněl. Asi to bude tím, že jsem ho (chybně) vnímal spíš ve smyslu "má existovat (aspoň jeden)" než jako "právě jeden".
whois ti povie, komu bola pridelená. To bude nejaký ISP. Toho ISP sa potom opýtaš na detaily.
) - musíš do všech těch cca 200 národních zón, co jich na světě je. Nebo mám lepší nápad, pošli mi ty prachy na účet a já ti za to tu kravinu vymluvim
Tiskni
Sdílej: