Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.
Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.
Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.
Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.
Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.
Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.
Firma Anthropic, tvůrce AI modelu Claude, začala v oblasti Sanfranciského zálivu v tichosti provozovat vlastní biotechnologickou laboratoř. Anthropic prý chce pomocí AI urychlit hledání léků na nemoci, jimž farmaceutický průmysl dle názoru firmy věnuje příliš málo pozornosti. Firma tvrdí, že laboratoř se zatím soustředí především na základní biologii, nikoli přímo na vývoj léčiv. Farmaceutický výzkum je pro generálního ředitele Daria Amodeie velice osobní téma, jeho otec zemřel na hepatitidu C několik málo let před objevením účinné léčby.
Vědci z Googlu dokončili mapu všech neuronových spojení v mozku (tzv. konektom) samečka mušky octomilky obecné (drosophila melanogaster), hlavním cílem je komparativní analýza s již zmapovaným mozkem samičky. S tímto veřejně dostupným modelem, čítajícím přibližně 160 000 neuronů, se začali bavit nadšenci. Mozek mouchy pohání experimentálního kryptoburzovního bota Stonkfly, případně si zahrál počítačové hry Beat Saber, Mario64 a samozřejmě DOOM (gameplay videa). Ani mozek samičky nezůstal stranou, vyzkoušel si Minecraft.
Alibaba Cloud je dalším sponzorem nadace Omacom Foundation stojící za linuxovou distribucí Omarchy. Přislíbená částka je 3 miliony dolarů, tj. 1 milion dolarů ročně po dobu tří let. Stejná částka jako u DigitalOcean.
Byla vydána nová verze 262 správce systému a služeb systemd (Wikipedie, GitHub).
Ahoj,
na serveru mam Debian 5. Nedavno byla aktualizace, ktera aktualizovala MySQL. Bohuzel se aktualizace nepodarila. Kdyz spustim aktualizaci, MySQL se uz nespusti:
server:/# apt-get update Cíl http://ftp.cz.debian.org lenny Release.gpg Cíl http://ftp.cz.debian.org lenny/main Translation-cs Ign http://ftp.cz.debian.org lenny/contrib Translation-cs Ign http://ftp.cz.debian.org lenny/non-free Translation-cs Cíl http://ftp.cz.debian.org lenny Release Cíl http://www.debian-multimedia.org lenny Release.gpg Cíl http://www.debian-multimedia.org lenny/main Translation-cs Cíl http://www.debian-multimedia.org lenny Release Ign http://ftp.cz.debian.org lenny/main Packages/DiffIndex Ign http://ftp.cz.debian.org lenny/contrib Packages/DiffIndex Ign http://ftp.cz.debian.org lenny/non-free Packages/DiffIndex Cíl http://ftp.cz.debian.org lenny/main Packages Cíl http://ftp.cz.debian.org lenny/contrib Packages Cíl http://ftp.cz.debian.org lenny/non-free Packages Cíl http://www.debian-multimedia.org lenny/main Packages/DiffIndex Cíl http://security.debian.org lenny/updates Release.gpg Ign http://security.debian.org lenny/updates/main Translation-cs Ign http://security.debian.org lenny/updates/contrib Translation-cs Ign http://security.debian.org lenny/updates/non-free Translation-cs Cíl http://security.debian.org lenny/updates Release Ign http://security.debian.org lenny/updates/main Packages/DiffIndex Ign http://security.debian.org lenny/updates/contrib Packages/DiffIndex Ign http://security.debian.org lenny/updates/non-free Packages/DiffIndex Cíl http://security.debian.org lenny/updates/main Packages Cíl http://security.debian.org lenny/updates/contrib Packages Cíl http://security.debian.org lenny/updates/non-free Packages Čtu seznamy balíků... Hotovo server:/# apt-get upgrade Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo 0 aktualizováno, 0 nově instalováno, 0 k odstranění a 0 neaktualizováno. 2 instalováno nebo odstraněno pouze částečně. Po této operaci bude na disku použito dalších 0B. Chcete pokračovat [Y/n]? y Nastavuji balík mysql-server-5.0 (5.0.51a-24+lenny2) ... Stopping MySQL database server: mysqld. Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed! invoke-rc.d: initscript mysql, action "start" failed. dpkg: chyba při zpracovávání mysql-server-5.0 (--configure): podproces post-installation script vrátil chybový status 1 dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server: mysql-server závisí na mysql-server-5.0; avšak: Balík mysql-server-5.0 zatím není zkonfigurován. dpkg: chyba při zpracovávání mysql-server (--configure): problém se závislostmi - nechávám nezkonfigurované Při zpracování nastaly chyby: mysql-server-5.0 mysql-server E: Sub-process /usr/bin/dpkg returned an error code (1) server:/# /etc/init.d/mysql start Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed! server:/#
V logu se objevi nasledujici:
server:/# cat /var/log/syslog ... Sep 10 15:41:26 server mysqld[1800]: 090910 15:41:26 [Note] /usr/sbin/mysqld: norm^[-B▒ln▒ ukon▒en▒ Sep 10 15:41:26 server mysqld[1800]: Sep 10 15:41:26 server mysqld[1800]: 090910 15:41:26 InnoDB: Starting shutdown... Sep 10 15:41:28 server mysqld[1800]: 090910 15:41:28 InnoDB: Shutdown completed; log sequence number 0 623369 Sep 10 15:41:28 server mysqld[1800]: 090910 15:41:28 [Note] /usr/sbin/mysqld: ukon^[-B▒en▒ pr▒ce hotovo Sep 10 15:41:28 server mysqld[1800]: Sep 10 15:41:29 server mysqld_safe[14891]: ended Sep 10 15:41:32 server mysqld_safe[14921]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER ! Sep 10 15:41:32 server mysqld_safe[14921]: To do so, start the server, then issue the following commands: Sep 10 15:41:32 server mysqld_safe[14921]: /usr/bin/mysqladmin -u root password 'new-password' Sep 10 15:41:32 server mysqld_safe[14921]: /usr/bin/mysqladmin -u root -h server.server .server password 'new-password' Sep 10 15:41:32 server mysqld_safe[14921]: Sep 10 15:41:32 server mysqld_safe[14921]: Alternatively you can run: Sep 10 15:41:32 server mysqld_safe[14921]: /usr/bin/mysql_secure_installation Sep 10 15:41:32 server mysqld_safe[14921]: Sep 10 15:41:32 server mysqld_safe[14921]: which will also give you the option of removing the test Sep 10 15:41:32 server mysqld_safe[14921]: databases and anonymous user created by default. This is Sep 10 15:41:32 server mysqld_safe[14921]: strongly recommended for production servers. Sep 10 15:41:32 server mysqld_safe[14921]: Sep 10 15:41:32 server mysqld_safe[14921]: See the manual for more instructions. Sep 10 15:41:32 server mysqld_safe[14921]: Sep 10 15:41:32 server mysqld_safe[14921]: Please report any problems with the /usr/bin/mysqlbug script! Sep 10 15:41:32 server mysqld_safe[14921]: Sep 10 15:41:32 server mysqld_safe[14921]: The latest information about MySQL is available on the web at Sep 10 15:41:32 server mysqld_safe[14921]: http://www.mysql.com Sep 10 15:41:32 server mysqld_safe[14921]: Support MySQL by buying support/licenses at http://shop.mysql.com Sep 10 15:41:32 server mysqld_safe[14990]: ERROR: 1046 Nebyla vybr^[-B▒na ▒▒dn▒ datab▒ze Sep 10 15:41:32 server mysqld_safe[14990]: 090910 15:41:32 [ERROR] Aborting Sep 10 15:41:32 server mysqld_safe[14990]: Sep 10 15:41:33 server mysqld_safe[14990]: 090910 15:41:33 [Note] /usr/sbin/mysqld: ukon^[-B▒en▒ pr▒ce hotovo Sep 10 15:41:33 server mysqld_safe[14990]: Sep 10 15:41:34 server mysqld_safe[15076]: started Sep 10 15:41:34 server mysqld[15079]: InnoDB: Error: pthread_create returned 12 Sep 10 15:41:34 server mysqld_safe[15085]: ended Sep 10 15:41:48 server /etc/init.d/mysql[15235]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in Sep 10 15:41:49 server /etc/init.d/mysql[15235]: ^G/usr/bin/mysqladmin: connect to server at 'localhost' failed Sep 10 15:41:49 server /etc/init.d/mysql[15235]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' Sep 10 15:41:49 server /etc/init.d/mysql[15235]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists! Sep 10 15:41:49 server /etc/init.d/mysql[15235]: Sep 10 15:41:55 server mysqld_safe[15314]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER ! Sep 10 15:41:55 server mysqld_safe[15314]: To do so, start the server, then issue the following commands: Sep 10 15:41:55 server mysqld_safe[15314]: /usr/bin/mysqladmin -u root password 'new-password' Sep 10 15:41:55 server mysqld_safe[15314]: /usr/bin/mysqladmin -u root -h server.server .server password 'new-password' Sep 10 15:41:55 server mysqld_safe[15314]: Sep 10 15:41:55 server mysqld_safe[15314]: Alternatively you can run: Sep 10 15:41:55 server mysqld_safe[15314]: /usr/bin/mysql_secure_installation Sep 10 15:41:55 server mysqld_safe[15314]: Sep 10 15:41:55 server mysqld_safe[15314]: which will also give you the option of removing the test Sep 10 15:41:55 server mysqld_safe[15314]: databases and anonymous user created by default. This is Sep 10 15:41:55 server mysqld_safe[15314]: strongly recommended for production servers. Sep 10 15:41:55 server mysqld_safe[15314]: Sep 10 15:41:55 server mysqld_safe[15314]: See the manual for more instructions. Sep 10 15:41:55 server mysqld_safe[15314]: Sep 10 15:41:55 server mysqld_safe[15314]: Please report any problems with the /usr/bin/mysqlbug script! Sep 10 15:41:55 server mysqld_safe[15314]: Sep 10 15:41:55 server mysqld_safe[15314]: The latest information about MySQL is available on the web at Sep 10 15:41:55 server mysqld_safe[15314]: http://www.mysql.com Sep 10 15:41:55 server mysqld_safe[15314]: Support MySQL by buying support/licenses at http://shop.mysql.com Sep 10 15:41:55 server mysqld_safe[15383]: ERROR: 1046 Nebyla vybr^[-B▒na ▒▒dn▒ datab▒ze Sep 10 15:41:55 server mysqld_safe[15383]: 090910 15:41:55 [ERROR] Aborting Sep 10 15:41:55 server mysqld_safe[15383]: Sep 10 15:41:55 server mysqld_safe[15383]: 090910 15:41:55 [Note] /usr/sbin/mysqld: ukon^[-B▒en▒ pr▒ce hotovo Sep 10 15:41:55 server mysqld_safe[15383]: Sep 10 15:41:56 server mysqld_safe[15469]: started Sep 10 15:41:56 server mysqld[15472]: InnoDB: Error: pthread_create returned 12 Sep 10 15:41:56 server mysqld_safe[15478]: ended Sep 10 15:42:11 server /etc/init.d/mysql[15628]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in Sep 10 15:42:11 server /etc/init.d/mysql[15628]: ^G/usr/bin/mysqladmin: connect to server at 'localhost' failed Sep 10 15:42:11 server /etc/init.d/mysql[15628]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' Sep 10 15:42:11 server /etc/init.d/mysql[15628]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists! Sep 10 15:42:11 server /etc/init.d/mysql[15628]: Sep 10 15:42:49 server mysqld_safe[15728]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER ! Sep 10 15:42:49 server mysqld_safe[15728]: To do so, start the server, then issue the following commands: Sep 10 15:42:49 server mysqld_safe[15728]: /usr/bin/mysqladmin -u root password 'new-password' Sep 10 15:42:49 server mysqld_safe[15728]: /usr/bin/mysqladmin -u root -h server.server .server password 'new-password' Sep 10 15:42:49 server mysqld_safe[15728]: Sep 10 15:42:49 server mysqld_safe[15728]: Alternatively you can run: Sep 10 15:42:49 server mysqld_safe[15728]: /usr/bin/mysql_secure_installation Sep 10 15:42:49 server mysqld_safe[15728]: Sep 10 15:42:49 server mysqld_safe[15728]: which will also give you the option of removing the test Sep 10 15:42:49 server mysqld_safe[15728]: databases and anonymous user created by default. This is Sep 10 15:42:49 server mysqld_safe[15728]: strongly recommended for production servers. Sep 10 15:42:49 server mysqld_safe[15728]: Sep 10 15:42:49 server mysqld_safe[15728]: See the manual for more instructions. Sep 10 15:42:49 server mysqld_safe[15728]: Sep 10 15:42:49 server mysqld_safe[15728]: Please report any problems with the /usr/bin/mysqlbug script! Sep 10 15:42:49 server mysqld_safe[15728]: Sep 10 15:42:49 server mysqld_safe[15728]: The latest information about MySQL is available on the web at Sep 10 15:42:49 server mysqld_safe[15728]: http://www.mysql.com Sep 10 15:42:49 server mysqld_safe[15728]: Support MySQL by buying support/licenses at http://shop.mysql.com Sep 10 15:42:50 server mysqld_safe[15797]: ERROR: 1046 Nebyla vybr^[-B▒na ▒▒dn▒ datab▒ze Sep 10 15:42:50 server mysqld_safe[15797]: 090910 15:42:50 [ERROR] Aborting Sep 10 15:42:50 server mysqld_safe[15797]: Sep 10 15:42:50 server mysqld_safe[15797]: 090910 15:42:50 [Note] /usr/sbin/mysqld: ukon^[-B▒en▒ pr▒ce hotovo Sep 10 15:42:50 server mysqld_safe[15797]: Sep 10 15:42:51 server mysqld_safe[15883]: started Sep 10 15:42:51 server mysqld[15886]: InnoDB: Error: pthread_create returned 12 Sep 10 15:42:51 server mysqld_safe[15892]: ended Sep 10 15:43:06 server /etc/init.d/mysql[16042]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in Sep 10 15:43:06 server /etc/init.d/mysql[16042]: ^G/usr/bin/mysqladmin: connect to server at 'localhost' failed Sep 10 15:43:06 server /etc/init.d/mysql[16042]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' Sep 10 15:43:06 server /etc/init.d/mysql[16042]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists! Sep 10 15:43:06 server /etc/init.d/mysql[16042]: server:/var/log#
Zajimave je, ze po rebootu serveru MySQL bezproblemu nabehne. Nevite nekdo co s tim?
Ja uz nemam zadny napad. 
no tak pustim dpkg-reconfigure rucne a zjistim co se deje ... nevim proc to pak poustis ...dpkg: chyba při zpracovávání mysql-server (--configure): problém se závislostmi - nechávám nezkonfigurované Při zpracování nastaly chyby: mysql-server-5.0 mysql-server E: Sub-process /usr/bin/dpkg returned an error code (1)
server:/# dpkg-reconfigure mysql-server /usr/sbin/dpkg-reconfigure: mysql-server je porušený, nebo není plně nainstalovaný server:/#
dpkg --configure mysql-server-5.0
server:/# dpkg --configure mysql-server-5.0 Nastavuji balík mysql-server-5.0 (5.0.51a-24+lenny2) ... Stopping MySQL database server: mysqld. Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed! invoke-rc.d: initscript mysql, action "start" failed. dpkg: chyba při zpracovávání mysql-server-5.0 (--configure): podproces post-installation script vrátil chybový status 1 Při zpracování nastaly chyby: mysql-server-5.0 server:/#
Toto se mi stalo taky. Zazálohovat data a kompletně odinstalovat server a nainstalovat znovu ..
Mysliste MySQL server, nebo cely server? 
I kdyz to udelam, kde mam jistotu, ze se mi nestane znova?
Samozřejmě mysql server, protože blokuje aktualizaci dalších balíčků. Pak jej nainstalovat znovu. Pokud by byla znovu chyba, je nutné najít jeji příčinu, může to blokovat jiný poškozený balíček. Chvíli jsem si s tím vyhrál, stalo se mi to při upgradu z mysql 5.0 na 5.1
Tiskni
Sdílej: