Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.
BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.
V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."
Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.
Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.
Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.
… více »Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.
Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.
ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím
… více »ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
Moc prosim o pomoc.
Nastavuji balík slapd (2.4.23-7) …
Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.4.11-1+lenny2... done.
Moving old database directories to /var/backups:
There are leftover files in /var/lib/ldap. This will probably break
creating the initial directory. If that's the case please move away
stuff in there and retry the configuration.
Loading from /var/backups/slapd-2.4.11-1+lenny2:
Directory /var/lib/ldap for dc=firma,dc=cz not empty, aborting.
dpkg: chyba při zpracovávání slapd (--configure):
podproces instalovaný post-installation skript vrátil chybový status 1
configured to not write apport reports
Při zpracování nastaly chyby:
slapd
E: Sub-process /usr/bin/dpkg returned an error code (1)
/etc/ldap i ve /var/lib/ldap jsem vratil.. ale pribilo mi /etc/ldap/slapd.d a moje databaze neni videt .. takze se asi nejak zmenila konfigurace. ze?
/etc/ldap/slapd.d aby to bralo mou puvodni konfiguraci.. tohle je nejaka "novinka" pro dynamicky konfig. Potrebuji ale poradit s tim MySQL jeste. Diky moc.
dpkg -l mysql-server* Požadované=Neznámé/Instalovat/Odinstalovat/Vyčistit/Podržet | Stav=Ne/Instalován/Konfigurační soubory/Rozbalen/Nezkonfigurován/Nekompletní | instalace/Očekávané spouštěče/Nevyřízené spouštěče |/ Chyba?=(nic)/Nutná přeinstalace (Stav,Chyba: velké písmeno=chyba) ||/ Název Verze Popis +++-==============-==============-============================================ iU mysql-server 5.1.49-3 MySQL database server (metapackage depending un mysql-server-4 žádná (popis není k dispozici) rc mysql-server-5 5.0.51a-24+len MySQL database server binaries iF mysql-server-5 5.1.49-3 MySQL database server binaries and system da un mysql-server-c žádná (popis není k dispozici) un mysql-server-c žádná (popis není k dispozici) ii mysql-server-c 5.1.49-3 MySQL database server binaries
ii mysql-server-5.1 5.1.49-3 MySQL database server binaries and system database setnebo jsem to přehlédl?
Požadované=Neznámé/Instalovat/Odinstalovat/Vyčistit/Podržet | Stav=Ne/Instalován/Konfigurační soubory/Rozbalen/Nezkonfigurován/Nekompletní | instalace/Očekávané spouštěče/Nevyřízené spouštěče |/ Chyba?=(nic)/Nutná přeinstalace (Stav,Chyba: velké písmeno=chyba) ||/ Název Verze Popis +++-=====================================================-=====================================================-========================================================================================================================== iU mysql-server 5.1.49-3 MySQL database server (metapackage depending on the latest version) un mysql-server-4.1 žádná (popis není k dispozici) rc mysql-server-5.0 5.0.51a-24+lenny5 MySQL database server binaries iF mysql-server-5.1 5.1.49-3 MySQL database server binaries and system database setup un mysql-server-core žádná (popis není k dispozici) un mysql-server-core-5.0 žádná (popis není k dispozici) ii mysql-server-core-5.1 5.1.49-3 MySQL database server binaries server:/var/log#
Nastavuji balík mysql-server-5.1 (5.1.49-3) …
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: chyba při zpracovávání mysql-server-5.1 (--configure):
podproces instalovaný post-installation skript vrátil chybový status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server:
mysql-server závisí na mysql-server-5.1; avšak:
Balík mysql-server-5.1 zatím není zkonfigurován.
dpkg: chyba při zpracovávání mysql-server (--configure):
problém se závislostmi - nechávám nezkonfigurované
configured to not write apport reports
configured to not write apport reports
Při zpracování nastaly chyby:
mysql-server-5.1
mysql-server
Feb 6 22:31:29 server /etc/mysql/debian-start[25823]: Upgrading MySQL tables if necessary. Feb 6 22:31:29 server /etc/mysql/debian-start[25826]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored Feb 6 22:31:29 server /etc/mysql/debian-start[25826]: Looking for 'mysql' as: /usr/bin/mysql Feb 6 22:31:29 server /etc/mysql/debian-start[25826]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck Feb 6 22:31:29 server /etc/mysql/debian-start[25826]: This installation of MySQL is already upgraded to 5.1.49, use --force if you still need to run mysql_upgrade Feb 6 22:31:29 server /etc/mysql/debian-start[25833]: Checking for insecure root accounts. Feb 6 22:31:29 server /etc/mysql/debian-start[25837]: Triggering myisam-recover for all MyISAM tablesNevim ale, jak tu opravu pouzit, protoze tohle asi neni to prave:
mysql_upgrade Looking for 'mysql' as: mysql Looking for 'mysqlcheck' as: mysqlcheck Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock' mysqlcheck: Got error: 1045: Access denied for user 'root'@'localhost' (using password: NO) when trying to connect FATAL ERROR: Upgrade failed
> telnet localhost 3306 Trying 127.0.0.1... Connected to localhost. Escape character is '^]'. ? 5.0.51a-24+lenny5�?cElsz.sz,?-jR:j(&(5oS0^CConnection closed by foreign host.
/var/log/apache2/error.log se mi ukazuji same takovete hlasky:
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0
Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
[ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -n 200 -r -0 rm PHP Warning: PHP Startup: uploadprogress: Unable to initialize module Module compiled with module API=20060613 PHP compiled with module API=20090626 These options need to match in Unknown on line 0
magic_quotes_gpc byla volovina už v PHP 4/5.x a register_long_arrays nevím, co je (viz dokumentace), ale asi to bude něco podobně zbytečného. Joomla určitě do logu také píše, co se jí nelíbí.
Feb 11 17:50:55 Betelgeuse mysqld_safe[25253]: 110211 17:50:55 InnoDB: Starting shutdown...
Feb 11 17:51:00 Betelgeuse mysqld_safe[25253]: 110211 17:51:00 InnoDB: Shutdown completed; log sequence number 0 43655
Feb 11 17:51:00 Betelgeuse mysqld_safe[25253]: 110211 17:51:00 [Note]
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: Check that the above file is the right version for this program!
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00 [Note] Plugin 'FEDERATED' is disabled.
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00 InnoDB: Started; log sequence number 0 43655
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00 [ERROR] /usr/sbin/mysqld: unknown option '--skip-bdb'
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00 [ERROR] Aborting
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]:
Feb 11 17:51:00 Betelgeuse mysqld_safe[25278]: 110211 17:51:00 InnoDB: Starting shutdown...
Feb 11 17:51:05 Betelgeuse mysqld_safe[25278]: 110211 17:51:05 InnoDB: Shutdown completed; log sequence number 0 43655
Má někdo nějakej nápad? V konfiguraci jsem skip odstranil, ale nepomáhá to. Díky
skip bdb
zakomentujte jej.
mila:/var/log/apache2# /etc/init.d/mysql start Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed! mila:/var/log/apache2#
ii mysql-server 5.1.49-3 MySQL database server (metapackage depending on the latest version) un mysql-server-4.1 (popis není k dispozici) un mysql-server-5.0 (popis není k dispozici) ii mysql-server-5.1 5.1.49-3 MySQL database server binaries and system database setup un mysql-server-core (popis není k dispozici) un mysql-server-core-5.0 (popis není k dispozici) pi mysql-server-core-5.1 5.1.49-3 MySQL database server binaries un virtual-mysql-server (popis není k dispozici)V čem by mohl být problém .. Nechci instalovat znovu celý systém.
Tiskni
Sdílej: