abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 12:11 | Komunita

    Debian Inference Portal nabízí vývojářům Debianu bezplatný přístup ke službám AI/LLM. Sponzorem je společnost Scaleway.

    Ladislav Hagara | Komentářů: 0
    dnes 11:44 | Bezpečnostní upozornění

    Robert Ressl nalezl ve WordPressu kritickou zranitelnost CVE-2026-87902 s CVSS 9.2. Útočníkům umožňuje neoprávněný přístup k souborům a vzdálené spuštění kódu (RCE). Opravena je ve verzích 7.1.2, 7.0.6, 6.9.9…

    Ladislav Hagara | Komentářů: 0
    dnes 03:33 | IT novinky

    Společnost Meta na dvoudenní konferenci Meta Connect 2026 představuje své novinky. Vypíchnout lze lehké brýle s funkci VR Meta VR Glasses. Do prodeje půjdou na jaře 2027 za cenu 1299,99 dolarů.

    Ladislav Hagara | Komentářů: 0
    včera 14:44 | Nová verze

    Google Chrome 154 byl prohlášen za stabilní. Nejnovější stabilní verze 154.0.8037.57 přináší řadu novinek. Podrobný přehled v poznámkách k vydání. Opraveno bylo 108 bezpečnostních chyb. Vylepšeny byly také nástroje pro vývojáře.

    Ladislav Hagara | Komentářů: 4
    včera 14:33 | IT novinky

    Vláda sníží v příštím roce výdaje na IT služby státu o 1,4 miliardy korun. Úspory má umožnit lepší koordinace nákupu služeb napříč resorty prostřednictvím nového zmocněnce. Celkové roční výdaje státu na informační technologie a digitalizaci se podle údajů ministerstva průmyslu a obchodu pohybují okolo 20 až 25 miliard korun ročně, pro letošek bylo na 320 projektů vyčleněno 21 miliard.

    Ladislav Hagara | Komentářů: 3
    včera 14:22 | IT novinky

    Irská komise pro ochranu dat (DPC) uložila americké technologické společnosti Google ze skupiny Alphabet pokutu 403 milionů eur (9,8 miliardy Kč) za neoprávněné nakládání s údaji o poloze uživatelů. Firma podle komise porušila evropské nařízení o ochraně osobních údajů (GDPR). DPC uvedla, že při šetření zjistila, že si lidé nemuseli být vědomi skutečnosti, že jejich poloha byla využívána například k ovlivňování prostřednictvím reklam nebo k odvozování jejich zájmů, a mohli tak ztratit kontrolu nad svými osobními údaji.

    Ladislav Hagara | Komentářů: 2
    včera 02:11 | IT novinky

    Byla oznámena beta verze nového video kodeku Pyrowave pro streamování her v Steam Remote Play. S vysokou propustností a nízkou latencí. S podporou HDR a YUV 4:4:4.

    Ladislav Hagara | Komentářů: 0
    včera 01:11 | Nová verze

    Byl vydán Sublime Text 4 Build 4213. Sublime Text (Wikipedie) je proprietární multiplatformní editor textových souborů a zdrojových kódů. Ke stažení a k vyzkoušení je zdarma. Pro další používání je nutná licence v ceně 99 dolarů. Spolu se Sublime Merge je cena 168 dolarů.

    Ladislav Hagara | Komentářů: 0
    22.9. 21:55 | Zajímavý článek

    Firma Anthropic, tvůrce AI modelu Claude, začala v oblasti Sanfranciského zálivu v tichosti provozovat vlastní biotechnologickou laboratoř. Anthropic prý chce pomocí AI urychlit hledání léků na nemoci, jimž farmaceutický průmysl dle názoru firmy věnuje příliš málo pozornosti. Firma tvrdí, že laboratoř se zatím soustředí především na základní biologii, nikoli přímo na vývoj léčiv. Farmaceutický výzkum je pro generálního ředitele Daria Amodeie velice osobní téma, jeho otec zemřel na hepatitidu C několik málo let před objevením účinné léčby.

    AfD 💙 | Komentářů: 6
    22.9. 21:44 | Humor

    Vědci z Googlu dokončili mapu všech neuronových spojení v mozku (tzv. konektom) samečka mušky octomilky obecné (drosophila melanogaster), hlavním cílem je komparativní analýza s již zmapovaným mozkem samičky. S tímto veřejně dostupným modelem, čítajícím přibližně 160 000 neuronů, se začali bavit nadšenci. Mozek mouchy pohání experimentálního kryptoburzovního bota Stonkfly, případně si zahrál počítačové hry Beat Saber, Mario64 a samozřejmě DOOM (gameplay videa). Ani mozek samičky nezůstal stranou, vyzkoušel si Minecraft.

    AfD 💙 | Komentářů: 6
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (21%)
    Celkem 2726 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: jak na lokální mysql?

    23.3.2011 11:55 jardík
    jak na lokální mysql?
    Přečteno: 2246×
    Zdarec, nainstaloval jsem si:
    • mysql-server-core-5.1
    • apache2
    • php5
    • libapache2-mod-php5
    • phpmyadmin
    a nevím jak pracovat s mysql, potažmo phpmyadmin. Ve Windows jsem nainstaloval Wamp server a s mysql pracoval v příkazovém řádku hned...

    jarda@jarda-laptop:~$ sudo mysql_install_db
    Neither host 'jarda-laptop' nor 'localhost' could be looked up with
    /usr/bin/resolveip
    Please configure the 'hostname' command to return a correct
    hostname.
    If you want to solve this at a later stage, restart this script
    with the --force option
    jarda@jarda-laptop:~$ sudo mysql_install_db --force
    chown: neplatný uživatel: „mysql“
    chown: neplatný uživatel: „mysql“
    Installing MySQL system tables...
    110320 20:50:32 [ERROR] Fatal error: Can't change to run as user 'mysql' ;  Please check that the user exists!
    
    110320 20:50:32 [ERROR] Aborting
    
    110320 20:50:32 [Note] /usr/sbin/mysqld: Shutdown complete
    
    
    Installation of system tables failed!  Examine the logs in
    /var/lib/mysql for more information.
    
    You can try to start the mysqld daemon with:
    
        shell> /usr/sbin/mysqld --skip-grant &
    
    and use the command line tool /usr/bin/mysql
    to connect to the mysql database and look at the grant tables:
    
        shell> /usr/bin/mysql -u root mysql
        mysql> show tables
    
    Try 'mysqld --help' if you have problems with paths.  Using --log
    gives you a log in /var/lib/mysql that may be helpful.
    
    Please consult the MySQL manual section
    'Problems running mysql_install_db', and the manual section that
    describes problems on your OS.  Another information source are the
    MySQL email archives available at http://lists.mysql.com/.
    
    Please check all of the above before mailing us!  And remember, if
    you do mail us, you MUST use the /usr/scripts/mysqlbug script!
    
    pak ještě:
    /usr/sbin/mysqld --skip-grant &
    [1] 3375
    jarda@jarda-laptop:~$ 110323 11:52:46 [Warning] Can't create test file /var/lib/mysql/jarda-laptop.lower-test
    110323 11:52:46 [Warning] Can't create test file /var/lib/mysql/jarda-laptop.lower-test
    /usr/sbin/mysqld: Can't change dir to '/var/lib/mysql/' (Errcode: 13)
    110323 11:52:46 [ERROR] Aborting
    
    110323 11:52:46 [Note] /usr/sbin/mysqld: Shutdown complete
    
    pak v localhost/phpmyadmin se pokouším o login: #2002 Nepodařilo se přihlášení k MySQL serveru

    Řešení dotazu:


    Odpovědi

    23.3.2011 11:59 jardík
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    jo a ještě:
    /usr/bin/mysql -u root mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    
    Luboš Doležel (Doli) avatar 23.3.2011 12:26 Luboš Doležel (Doli) | skóre: 98 | blog: Doliho blog | Kladensko
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    Nemáš v systému uživatele mysql a pak ještě radši zkontroluj práva na /var/lib/mysql.
    24.3.2011 23:49 jardík
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    oboje jsem udělal a:

    jarda@jarda-laptop:~$ sudo mysql_install_db --force
    [sudo] password for jarda: 
    Installing MySQL system tables...
    OK
    Filling help tables...
    OK
    
    To start mysqld at boot time you have to copy
    support-files/mysql.server to the right place for your system
    
    PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
    To do so, start the server, then issue the following commands:
    
    /usr/bin/mysqladmin -u root password 'new-password'
    /usr/bin/mysqladmin -u root -h jarda-laptop password 'new-password'
    
    Alternatively you can run:
    /usr/bin/mysql_secure_installation
    
    which will also give you the option of removing the test
    databases and anonymous user created by default.  This is
    strongly recommended for production servers.
    
    See the manual for more instructions.
    
    You can start the MySQL daemon with:
    cd /usr ; /usr/bin/mysqld_safe &
    
    You can test the MySQL daemon with mysql-test-run.pl
    cd /usr/mysql-test ; perl mysql-test-run.pl
    
    Please report any problems with the /usr/scripts/mysqlbug script!
    
    jarda@jarda-laptop:~$  /usr/sbin/mysqld --skip-grant &
    [1] 3860
    jarda@jarda-laptop:~$ 110324 23:43:27 [Warning] One can only use the --user switch if running as root
    
    110324 23:43:27 [Note] Plugin 'FEDERATED' is disabled.
    110324 23:43:27  InnoDB: Started; log sequence number 0 44233
    110324 23:43:27 [ERROR] Can't start server : Bind on unix socket: No such file or directory
    110324 23:43:27 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ?
    110324 23:43:27 [ERROR] Aborting
    
    110324 23:43:27  InnoDB: Starting shutdown...
    110324 23:43:33  InnoDB: Shutdown completed; log sequence number 0 44233
    110324 23:43:33 [Note] /usr/sbin/mysqld: Shutdown complete
    
    
    kam tohle: support-files/mysql.server mám umístit v Ubuntu? Napadlo mě jen Systém->Předvolby->Aplikace po spuštění

    jarda@jarda-laptop:~$  /usr/bin/mysql -u root mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    
    Není nějaký kvalitní step by step tutoriál? Všechny co jsem našel (english) tak mají neduh, že se někde v návodu odchalují od mé reality (je to mou distribucí?) no a nemohu nikdy dokončit nastavení :)
    Řešení 1× (Emch)
    25.3.2011 00:26 Sten
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    Proč v Ubuntu instalujete MySQL takhle? Ubuntu není Windows, tam se aplikace normálně instalují balíčkovacím systémem, ne tak, že se stáhnout z netu:
    sudo aptitude install mysql-server
    A to je vše a MySQL je nainstalována a funkční ;-)
    27.3.2011 10:45 jardík
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    ano, tohle vyřešilo mé problémy. Díky! ;-)
    Emch avatar 25.3.2011 08:30 Emch | skóre: 4 | blog: Machal
    Rozbalit Rozbalit vše Re: jak na lokální mysql?
    Plně souhlasím se Stenem;) P.S. zkoušel jste to vypnout a zapnout? :-D zní to blbě, ale co si pamatuju, když jsem instaloval mysql, tak jsem pak musel restartovat systém, aby to jelo :-D
    Je to tak jednoduchý, že to zvládne i fotbalista.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.