Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.
BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.
V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."
Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.
Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.
Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.
… více »Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.
Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.
ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím
… více »ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.
jarda@jarda-laptop:~$ sudo mysql_install_db
Neither host 'jarda-laptop' nor 'localhost' could be looked up with
/usr/bin/resolveip
Please configure the 'hostname' command to return a correct
hostname.
If you want to solve this at a later stage, restart this script
with the --force option
jarda@jarda-laptop:~$ sudo mysql_install_db --force
chown: neplatný uživatel: „mysql“
chown: neplatný uživatel: „mysql“
Installing MySQL system tables...
110320 20:50:32 [ERROR] Fatal error: Can't change to run as user 'mysql' ; Please check that the user exists!
110320 20:50:32 [ERROR] Aborting
110320 20:50:32 [Note] /usr/sbin/mysqld: Shutdown complete
Installation of system tables failed! Examine the logs in
/var/lib/mysql for more information.
You can try to start the mysqld daemon with:
shell> /usr/sbin/mysqld --skip-grant &
and use the command line tool /usr/bin/mysql
to connect to the mysql database and look at the grant tables:
shell> /usr/bin/mysql -u root mysql
mysql> show tables
Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /var/lib/mysql that may be helpful.
Please consult the MySQL manual section
'Problems running mysql_install_db', and the manual section that
describes problems on your OS. Another information source are the
MySQL email archives available at http://lists.mysql.com/.
Please check all of the above before mailing us! And remember, if
you do mail us, you MUST use the /usr/scripts/mysqlbug script!
pak ještě:
/usr/sbin/mysqld --skip-grant & [1] 3375 jarda@jarda-laptop:~$ 110323 11:52:46 [Warning] Can't create test file /var/lib/mysql/jarda-laptop.lower-test 110323 11:52:46 [Warning] Can't create test file /var/lib/mysql/jarda-laptop.lower-test /usr/sbin/mysqld: Can't change dir to '/var/lib/mysql/' (Errcode: 13) 110323 11:52:46 [ERROR] Aborting 110323 11:52:46 [Note] /usr/sbin/mysqld: Shutdown completepak v localhost/phpmyadmin se pokouším o login: #2002 Nepodařilo se přihlášení k MySQL serveru
Řešení dotazu:
/usr/bin/mysql -u root mysql ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
jarda@jarda-laptop:~$ sudo mysql_install_db --force [sudo] password for jarda: Installing MySQL system tables... OK Filling help tables... OK To start mysqld at boot time you have to copy support-files/mysql.server to the right place for your system PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER ! To do so, start the server, then issue the following commands: /usr/bin/mysqladmin -u root password 'new-password' /usr/bin/mysqladmin -u root -h jarda-laptop password 'new-password' Alternatively you can run: /usr/bin/mysql_secure_installation which will also give you the option of removing the test databases and anonymous user created by default. This is strongly recommended for production servers. See the manual for more instructions. You can start the MySQL daemon with: cd /usr ; /usr/bin/mysqld_safe & You can test the MySQL daemon with mysql-test-run.pl cd /usr/mysql-test ; perl mysql-test-run.pl Please report any problems with the /usr/scripts/mysqlbug script! jarda@jarda-laptop:~$ /usr/sbin/mysqld --skip-grant & [1] 3860 jarda@jarda-laptop:~$ 110324 23:43:27 [Warning] One can only use the --user switch if running as root 110324 23:43:27 [Note] Plugin 'FEDERATED' is disabled. 110324 23:43:27 InnoDB: Started; log sequence number 0 44233 110324 23:43:27 [ERROR] Can't start server : Bind on unix socket: No such file or directory 110324 23:43:27 [ERROR] Do you already have another mysqld server running on socket: /var/run/mysqld/mysqld.sock ? 110324 23:43:27 [ERROR] Aborting 110324 23:43:27 InnoDB: Starting shutdown... 110324 23:43:33 InnoDB: Shutdown completed; log sequence number 0 44233 110324 23:43:33 [Note] /usr/sbin/mysqld: Shutdown completekam tohle: support-files/mysql.server mám umístit v Ubuntu? Napadlo mě jen Systém->Předvolby->Aplikace po spuštění
jarda@jarda-laptop:~$ /usr/bin/mysql -u root mysql ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)Není nějaký kvalitní step by step tutoriál? Všechny co jsem našel (english) tak mají neduh, že se někde v návodu odchalují od mé reality (je to mou distribucí?) no a nemohu nikdy dokončit nastavení :)
sudo aptitude install mysql-serverA to je vše a MySQL je nainstalována a funkční
zní to blbě, ale co si pamatuju, když jsem instaloval mysql, tak jsem pak musel restartovat systém, aby to jelo
Tiskni
Sdílej: