abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    včera 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 0
    včera 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 7
    včera 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 8
    včera 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    včera 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 11
    včera 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    včera 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    včera 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 1
    8.10. 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    8.10. 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 9
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2822 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba

    Dalibor Smolík avatar 19.4.2011 08:54 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Přečteno: 623×
    Příloha:
    Zdravím, po reinstalaci Debianu na počítači, kde je připojená přes LPT tiskárna, není možné se k ní připojit z jakéhokoliv jiného počítače (Linux) přes cups/sambu, což dosud bylo možné. Na stroji byl postupně vyzkoušen Squeeze a sid, kernel 2.6.38-2-686, zkoušel jsem i jiné jádro. Tiskárna lokálně tiskne normálně. Tisk spravuji z klienta přes localhost:631, tiskárnu nainstaluji a provedu tisk testovací stránky, objeví se hlášení
    Brother1240-2231  	Test Page  	root  	1k  	Unknown  	completed at
    Tue Apr 19 08:40:22 2011 
    avšak tiskárna netiskne .. Nepomáhá ani administrace z KDE, kde je hlášeno, že tisk úspěšně proběhl .. Kde je zakopaný pes? Sambu i cups jsem restartoval. jinak nastavení tiskárny:
    Description:	Brother1240
    Location:	
    Driver:	Brother HL-1240 Foomatic/hl1250 (recommended) (grayscale, 2-sided printing)
    Connection:	smb://WORKGROUP/DEBIAN/Brother1240
    Defaults:	job-sheets=none, none media=iso_a4_210x297mm sides=one-sided
    
    část konfigurace samby je v příloze.
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.

    Řešení dotazu:


    Odpovědi

    Dalibor Smolík avatar 19.4.2011 18:25 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Zobrazení prostřednictvím smb4k se zdá v pořádku, samba tiskárnu vidí. Démon cups také evidentně běží
    ps ax | grep cups
     1198 ?        Ss     0:00 /usr/sbin/cupsd -C /etc/cups/cupsd.conf
     2927 pts/0    S+     0:00 grep cups
    
    ještě, zda není možné, že je někde odmítnut přístup .. dost závažný problém :-(
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    19.4.2011 20:46 NN
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Dake logy cups, samby nejsou ?

    NN
    Dalibor Smolík avatar 20.4.2011 09:09 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Ve webovém rozhraní (port 631) jsem sledoval access log a error log. Access_log po pokusu o tisk testovací stránky (provedený v 8:58:48 hod) říká:
    localhost - - [20/Apr/2011:08:58:27 +0200] "POST /printers/Brother1240 HTTP/1.1" 401 124 Purge-Jobs successful-ok
    localhost - - [20/Apr/2011:08:58:28 +0200] "POST /printers/Brother1240 HTTP/1.1" 401 124 Purge-Jobs successful-ok
    localhost - root [20/Apr/2011:08:58:28 +0200] "POST /printers/Brother1240 HTTP/1.1" 200 124 Purge-Jobs successful-ok
    localhost - - [20/Apr/2011:08:58:36 +0200] "POST /printers/Brother1240 HTTP/1.1" 200 484 Print-Job successful-ok
    
    
    Error_log hlásí:
    D [20/Apr/2011:08:58:48 +0200] [CGI] Started /usr/lib/cups/cgi-bin/admin.cgi (PID 3885)
    I [20/Apr/2011:08:58:48 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=3885)
    D [20/Apr/2011:08:58:48 +0200] cupsdSendCommand: 15 file=14
    D [20/Apr/2011:08:58:48 +0200] [CGI] admin.cgi started...
    D [20/Apr/2011:08:58:48 +0200] cupsdAcceptClient: 17 from localhost (Domain)
    D [20/Apr/2011:08:58:48 +0200] [CGI] http=0xb8b953b8
    D [20/Apr/2011:08:58:48 +0200] [CGI] org.cups.sid cookie is "6e286f7a3866d0d9ae5ba42fb02df875"
    D [20/Apr/2011:08:58:48 +0200] [CGI] No form data, showing main menu...
    D [20/Apr/2011:08:58:48 +0200] [CGI] /usr/share/cups/drivers/pscript5.dll: No such file or directory
    D [20/Apr/2011:08:58:48 +0200] cupsdReadClient: 17 POST / HTTP/1.1
    D [20/Apr/2011:08:58:48 +0200] cupsdAuthorize: No authentication data provided.
    D [20/Apr/2011:08:58:48 +0200] cupsdReadClient: 17 1.1 Get-Subscriptions 1
    D [20/Apr/2011:08:58:48 +0200] Get-Subscriptions ipp://localhost/
    D [20/Apr/2011:08:58:48 +0200] Returning IPP successful-ok for Get-Subscriptions (ipp://localhost/) from localhost
    D [20/Apr/2011:08:58:48 +0200] Script header: Content-Type: text/html;charset=utf-8
    D [20/Apr/2011:08:58:48 +0200] Script header: 
    D [20/Apr/2011:08:58:48 +0200] cupsdReadClient: 17 WAITING Closing on EOF
    D [20/Apr/2011:08:58:48 +0200] cupsdCloseClient: 17
    D [20/Apr/2011:08:58:48 +0200] cupsdSetBusyState: Dirty files
    D [20/Apr/2011:08:58:48 +0200] PID 3885 (/usr/lib/cups/cgi-bin/admin.cgi) exited with no errors.
    
    log samby (na tiskovém serveru):
    [2011/04/20 08:58:37.888474,  1] smbd/service.c:1070(make_connection_snum)
      __ffff_192.168.0.102 (::ffff:192.168.0.102) connect to service Brother1240 initially as user nobody (uid=65534, gid=65534) (pid 2453)
    [2011/04/20 08:58:38.742730,  0] printing/print_cups.c:1036(cups_job_submit)
      Unable to print file to Brother1240 - client-error-not-found
    [2011/04/20 08:58:38.745426,  1] smbd/service.c:1251(close_cnum)
    
    ale je tu ještě něco jiného ve /var/log/samba/log.smbd:
    [2011/04/20 08:58:37.897523,  0] printing/print_cups.c:1193(cups_queue_get)
      Unable to get jobs for ipp://localhost/printers/Brother1240 - client-error-not-found
    
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    20.4.2011 10:13 NN
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Takze bych se zameril na toto:

    error_log:
    /usr/share/cups/drivers/pscript5.dll: No such file or directory
    samba:
    Unable to print file to Brother1240 - client-error-not-found
    log.smbd:
    Unable to get jobs for ipp://localhost/printers/Brother1240 - client-error-not-found
    NN
    Dalibor Smolík avatar 20.4.2011 11:51 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Ještě jedna nesrovnalost (zřejmě to tak má být). Dříve jsem měl nainstalované balíčky cups .. a cupsys. V současné době nemohu balíčky typu "cupsys" najít. Je pouze pro lenny? Nemůže být problém v tomto?
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    Řešení 1× (jozka)
    Dalibor Smolík avatar 21.4.2011 11:52 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Po reinstalaci Debianu přestala tisknout tiskárna cups/samba
    Díky za snahu o pomoc. Nakonec jsem tiskárnu přímo na serveru odinstaloval a instaloval znovu. Jako ovladač jsem použil ppd file stažený pro daný typ tiskárny z netu, totéž jsem učinil na klientech. Restart cups a samba - a již to funguje :-)
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.