abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

    dnes 14:11 | Zajímavý článek

    Odborníci Národního úřadu pro kybernetickou a informační bezpečnost (NÚKIB) a Vojenského zpravodajství vypracovali materiál Cestujte (kyber)bezpečně: doporučení pro cesty do zahraničí (pdf), který má českým sportovcům mířícím na Olympiádu v Pekingu i veřejnosti přiblížit základy kyberbezpečnosti a poradit jim, jak používat technologie, aby byla jejich komunikace v zahraničí bezpečnější.

    Ladislav Hagara | Komentářů: 2
    dnes 08:00 | Zajímavý software

    Společnost SUSE oznámila vydání verze 1.0.0 open source multiplatformní desktopové aplikace Rancher Desktop pro správu Kubernetes a kontejnerů. Postavena je nad Electronem. Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 6
    dnes 00:22 | Bezpečnostní upozornění

    Byly zveřejněny informace o bezpečnostní chybě CVE-2022-0330 v Linuxu v ovladači i915 GPU od Intelu. Jedná se o chybějící TLB flush. Útočník může přistupovat k náhodným stránkám paměti. V upstreamu je chyba již opravena. Oprava má dopad na výkon GPU.

    Ladislav Hagara | Komentářů: 1
    včera 22:55 | Komunita

    Kolik může stát nejlevnější nový počítač s klávesnicí a displejem, na kterém lze ještě spustit Linux? Brian Benchoff se dostal k 15 dolarům [Twitter, Hacker News].

    Ladislav Hagara | Komentářů: 8
    včera 08:00 | Nová verze

    Po půl roce vývoje od vydání verze 5.8 byla vydána nová verze 5.9 svobodného open source redakčního systému WordPress. Kódové označení Josephine bylo vybráno na počest jazzové zpěvačky, herečky, tanečnice a bojovnice za svobodu a rovnoprávnost Josephine Bakerové.

    Ladislav Hagara | Komentářů: 2
    včera 07:00 | Bezpečnostní upozornění

    Byly zveřejněny informace o zranitelnosti PwnKit zneužitelné k lokální eskalaci práv, aneb rootem snadno a rychle, pomocí pkexec z balíčku polkit. Jedná se o CVE-2021-4034 s CVSS 7.8. Zranitelné jsou všechny verze pkexec od první verze vydané v květnu 2009, tj. posledních více než 12 let. V upstreamu je chyba již opravena.

    Ladislav Hagara | Komentářů: 8
    25.1. 16:55 | Nová verze

    Flameshot (GitHub), nástroj pro vytváření a úpravu snímků obrazovky postavený nad frameworkem Qt, byl vydán ve verzi 11.0.0. Změněno bylo číslování verzí. Verze 11 následuje po verzi 0.10.

    Ladislav Hagara | Komentářů: 3
    25.1. 09:00 | Komunita

    V pátek 28. ledna začíná 14. ročník konference DevConf.CZ. Jde o každoroční komunitní konferenci pro vývojáře, administrátory, DevOps inženýry, testery, autory dokumentace a další přispěvatele či uživatele technologií open source. Konference proběhne podruhé online, a to v termínu 28. - 29. ledna.

    … více »
    Dorka | Komentářů: 7
    25.1. 08:00 | Nová verze

    Byla vydána nová verze 2.35.0 distribuovaného systému správy verzí Git. Přispělo 93 vývojářů, z toho 35 nových. Přehled novinek v příspěvku na blogu GitHubu a v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 2
    25.1. 07:00 | Zajímavý software

    Giada je open source minimalistický softwarový nástroj pro tvorbu hudby navržený pro diskžokeje, elektronické hudebníky a živou produkci. Vydána byla verze 0.20.0 aneb Alicanto. Vedle zdrojových kódů je ke stažení také balíček ve formátu AppImage.

    Ladislav Hagara | Komentářů: 0
    Jestliže jste používali distribuci CentOS Linux, jejíž konec byl oznámen před rokem, kam jste přešli?
     (30%)
     (1%)
     (8%)
     (19%)
     (1%)
     (4%)
     (37%)
    Celkem 216 hlasů
     Komentářů: 14, poslední 14.1. 14:44
    Rozcestník



    Dotaz: Chybí PHP v poslední verzi Debianu - Proč?

    31.8.2013 02:35 Jakub
    Chybí PHP v poslední verzi Debianu - Proč?
    Přečteno: 547×
    Čau, nainstaloval jsem poslední verzi Debianu, zvolil webserver + ssh a po instalaci jsem zjistil, že tam není nainstalovaný PHP. Zkusil jsem aptitude install php5 ale vyskočilo na mne, že to koliduje s balíčkem apache2-mpm-worker. Sakra používám debián 100 let a ted tohle, nikdy jsem neměl problém s php. Co se děje? poradí někdo? Díky

    Řešení dotazu:


    Odpovědi

    31.8.2013 02:40 Jakub
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?
    Ještě přikládám raději výpis ;)
    root@debian:~# aptitude install php5
    Následující NOVÉ balíky budou instalovány:
      apache2-mpm-prefork{ab} libapache2-mod-php5{a} libonig2{a} libqdbm14{a} php5 php5-cli{a} php5-common{a}
    0 balíků aktualizováno, 7 nově instalováno, 0 k odstranění a 0 neaktualizováno.
    Potřebuji stáhnout 6 111 kB archivů. Po rozbalení bude použito 18,7 MB.
    Následující balíky mají nesplněné závislosti:
     apache2-mpm-worker : Koliduje s: apache2-mpm což je virtuální balík.
     apache2-mpm-prefork : Koliduje s: apache2-mpm což je virtuální balík.
    Následující akce vyřeší tyto závislosti:
    
         Odstranit následující balíky:
    1)     apache2-mpm-worker
    
    
    
    Přijmout toto řešení? [Y/n/q/?]
    
    31.8.2013 07:21 citanus
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?
    nevim jak to bylo v debianu doted, ale co znam debian tak je konzervativni. A neni jednoduchy ho rozbit, coz mpm + php modul urcite umi..:

    http://www.php.net/manual/en/faq.installation.php#faq.installation.apache2
    xkucf03 avatar 31.8.2013 21:42 xkucf03 | skóre: 49 | blog: xkucf03
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?

    Dej Y a budeš to mít, jak jsi zvyklý.

    Mám rád, když se lidé přou, znamená to, že vědí, co dělají, a že mají směr. Frantovo.cz, SQL-DK, Relational pipes
    31.8.2013 18:15 Jakub
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?
    Vážně nikdo neví ? :-(
    31.8.2013 18:58 ivan
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?
    Tak to daj odstranit. Nasledne daj nainstalovat libapache2-mod-php5 a Debian si uz doinstaluje ten spravny Apache.
    Josef Kufner avatar 31.8.2013 19:06 Josef Kufner | skóre: 70
    Rozbalit Rozbalit vše Re: Chybí PHP v poslední verzi Debianu - Proč?
    Worker je vícevláknový server, což PHP nemá rádo, neboť v něm kopec věcí s vlákny nepočítá.

    Máš dvě možnosti:
    1. Použít nevláknový Apache, např. balíček apache2-mpm-prefork.
    2. Spouštět PHP přes FastCGI (balíček php5-fpm nebo php5-cgi).
    Hello world ! Segmentation fault (core dumped)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.