abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 10:33 | IT novinky

    Rodina produktů Raspberry Pi se rozšířila o Raspberry Pi Smart Display Module. Deska pro Raspberry Pi Compute Module 5 se zasouvá přímo do displejů dle specifikace Intel SDM. Cena desky je 30 dolarů.

    Ladislav Hagara | Komentářů: 1
    včera 23:44 | Nová verze

    Byla vydána nová verze 2.56.0 distribuovaného systému správy verzí Git. Přispělo 104 vývojářů, z toho 39 nových. Přehled novinek v příspěvku na blogu GitHubu a v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 1
    včera 21:22 | Bezpečnostní upozornění

    Hackerská skupina ShinyHunters oznámila průnik do informačních systémů FBI, prostřednictvím zero-day zranitelnosti v platformě Oracle PeopleSoft, kterou úřad využívá mimo jiné pro náborový portál FBIJobs.gov. Útočníci tvrdí, že získali až 3 TB dat o současných i bývalých zaměstnancích a uchazečích o práci. Jako důkaz zveřejnili vzorek přibližně 5 000 záznamů obsahující jména, adresy, telefonní čísla, data narození, čísla

    … více »
    AfD 💙 | Komentářů: 2
    včera 21:11 | Zajímavý článek

    Doba kompilace linuxového jádra se díky rychlejšímu hardwaru a optimalizacím kbuildu snižuje k deseti sekundám. Nejnovější patche Lorenza Stoakse (vznikají i s pomocí SI) zkrátily na testovacím stroji dobu sestavení z dlouhých 22 vteřin na pouhých 15, a to bez použití RAMdisku. Testovací systém tvořily dva procesory AMD EPYC 9575F (oba dohromady poskytují celkem 128 jader a 256 vláken), čtyřiadvacet 64GB DDR5-6400 paměťových modulů a

    … více »
    AfD 💙 | Komentářů: 10
    včera 01:33 | Komunita

    Před rokem a půl vývojáři postmarketOS informovali, že pro projekt hledají nové jméno. Včera bylo oznámeno: postmarketOS se nově jmenuje Nura.

    Ladislav Hagara | Komentářů: 6
    27.9. 13:44 | Zajímavý projekt

    Hra Factorio dorazila na Printables. Hned teď si můžete stáhnout 65 různých modelů a nechat celou mimozemskou planetu oživnout na svém stole.

    Ladislav Hagara | Komentářů: 13
    26.9. 19:22 | Nová verze

    GNU Project Debugger aneb GDB byl vydán ve verzi 18.1. Podrobný přehled novinek v souboru NEWS.

    Ladislav Hagara | Komentářů: 0
    25.9. 23:33 | Humor

    Prezident USA Donald Trump během svého projevu na valném shromáždění OSN 22. září 2026 prohlásil, že umělá inteligence 'bude dále oficiálně nazývána superinteligencí', zkráceně SI. Svůj návrh zdůvodnil takto: 'Použití slova artificial činí inteligenci falešnou. Ona falešná není, ve skutečnosti je úžasná'. Zároveň ve svém proslovu prohlásil, že Spojené státy kategoricky odmítají jakékoliv pokusy o vytvoření 'globalistického

    … více »
    AfD 💙 | Komentářů: 26
    25.9. 23:22 | Nová verze

    Čínská technologická firma Xiaomi představila novou verzi 2.6 svého modelu MiMo, váhy modelů MiMo‑V2.6‑Pro‑RL a MiMo‑V2.6‑Flash‑RL jsou dostupné na HuggingFace pod licencí MIT. Výkonnější varianta Pro má přes bilion parametrů, z toho 42 miliard aktivních, úspornější Flash 309 miliard parametrů, z nichž se při generování aktivuje přibližně 15 miliard. Oba modely mají délku kontextového okna milion tokenů. Tyto MoE modely zvládají

    … více »
    AfD 💙 | Komentářů: 1
    25.9. 03:33 | Komunita

    Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2749 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: ISPconfig - Apache did not start after modifying this vhost file.

    11.7.2016 22:02 Lanny2013 | skóre: 2
    ISPconfig - Apache did not start after modifying this vhost file.
    Přečteno: 1020×
    Dobrý den, mám následující problém s ISPconfig. A potřeboval bych poradit.
    Po aktualizaci OS Linux Debian 7 na Debian 8. Mi nefunguje ISPconfig korektně.

    V administraci při změně DNS záznamů se tváří, že změnu vykonal korektně ale po zkoumání se změna projeví až kdýž ručně provedu restart service bind9 restart

    Další problém je s vytvořením vhost. Vytvoří vždy dva soubory normální "domena.vhost" a k tomu "domena.vhost.err". Což by ještě nebylo nic nenormálního. Problém je v tom, že v souboru "domena.vhost" je pouze napsáno:

    # Apache did not start after modifying this vhost file.
    # Please check file /etc/apache2/sites-available/domena.vhost.err for syntax errors.

    no když vezmu obsah z souboru "domena.vhost.err" a překopíruji standartně do "domena.vhost" nasledně restartuji manualně apache2 service apache2 restart Tak vše v pořádku funguje bez jediné chybové hlášky o špatné syntaxi.

    Budu rád za každou konstruktivní radu.

    Řešení dotazu:


    Odpovědi

    12.7.2016 16:35 NN
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Podivej se do logu prislusnych sluzeb..
    13.7.2016 12:24 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    V první řadě děkuji za odpověď

    apache log - error.log:
    [authz_core:error] [pid 25013] [client ::1:52020] AH01630: client denied by server configuration: /var/www/ 

    Což je problém, ale nemá podle mne vliv na moje problémy s systémem.
    Ještě jsem se podíval do logu ispconfug a tam je:
    Debug	Restarting httpd: systemctl restart apache2.service
    Debug Calling function 'restartHttpd' from module 'web_module'.
    Warning Reason for Apache restart failure: Failed to get D-Bus connection: Unknown error -1
    To je asi ono ale nevím jak tu chybu odstranit.
    Ruža Becelin avatar 13.7.2016 13:04 Ruža Becelin | skóre: 40 | blog: RuzaBecelinBlog
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Zkusit apache restartovat manualne a zkontrolovat logy...
    13.7.2016 14:16 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    výstup logu apache error.log po restartu
    [Wed Jul 13 14:10:19.917461 2016] [ssl:warn] [pid 30305] AH01909: server:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Jul 13 14:10:19.919081 2016] [suexec:notice] [pid 30305] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Wed Jul 13 14:10:19.965902 2016] [auth_digest:notice] [pid 30307] AH01757: generating secret for digest authentication ...
    [Wed Jul 13 14:10:19.967448 2016] [:notice] [pid 30311] FastCGI: wrapper mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Wed Jul 13 14:10:19.967506 2016] [:notice] [pid 30311] FastCGI: process manager initialized (pid 30311)
    [Wed Jul 13 14:10:19.999316 2016] [ssl:warn] [pid 30307] AH01909: server:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Jul 13 14:10:20.006220 2016] [mpm_prefork:notice] [pid 30307] AH00163: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 PHP/5.6.22-0+deb8u1 OpenSSL/1.0.1t configured -- resuming normal operations
    [Wed Jul 13 14:10:20.006286 2016] [core:notice] [pid 30307] AH00094: Command line: '/usr/sbin/apache2'
    
    
    děkuji za odpověď
    13.7.2016 14:31 NN
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Neni to jen obecny error log? Nemas generovane error logy pro kazdy virtualhost zvlast?
    13.7.2016 14:47 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Dobrý den, samozřejmě mám, ale do toho se nic nezapisuje je prázdný. Jenom chci upřesnit, že chyba se projeví při změně konfigurace na všech vhos. Takže když změním konfiguraci jiného webu tak se změna neprojeví. změnu konfigurace zapíše pouze do souboru *.vhost.err. Vezmu-li ale tento obsah a překopíruji do souboru *.vhost ručně restartuji apache tak vše funguje bez jediné chybové zprávy.

    Ruža Becelin avatar 13.7.2016 14:57 Ruža Becelin | skóre: 40 | blog: RuzaBecelinBlog
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Nemuze mit apache neco proti tomu .err?
    Ruža Becelin avatar 13.7.2016 15:00 Ruža Becelin | skóre: 40 | blog: RuzaBecelinBlog
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Aha, to je neco, co vytvari ISPConfig, koukni sem.
    13.7.2016 15:37 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    To asi nebude správná cesta.
    SSL Certifikát používám pouze na jednou webu.

    No nicméně při té aktualizaci OS se změnila verze apache 2.2 na apache 2.4. Jak jsem se někde dočetl tak verze apache 2.4 má vhost koncovku conf.
    Zkoušel jsem to teď ručně dopsat tuto příponu conf ale ISPconfig stejně nakonec vytvoří nový soubor *.vhost a *.vhost.err.
    Nicméně se domnívám jestli není chyba někde v tomto přístupu.
    Heron avatar 13.7.2016 16:59 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Failed to get D-Bus connection: Unknown error -1
    Problém není v konfiguraci apache, problém je, že ispconfig nemůže apache restartovat. Toto je chyba systemd / dbus. (Zkuste restartovat dbus apod. Chyb Unknown error -1 je plný net.)

    Případně sem zkuste dát výpis journalctl -b -f hned po tom neúspěšném restartu.
    13.7.2016 17:47 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Ahoj, no tak nějak jsem si myslel také, že je problém jak říkáš.
    restartoval jsem dbus: service dbus restart
    výpis se nepodařilo získat
    No journal files were found.

    Jsem přihlášen jako root.
    Můžeš mi ještě pomoci? děkuji.
    Heron avatar 13.7.2016 17:57 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Aha, tak mě napadá, že na Debian 8 ještě nemusíš mít jako init systemd. Otázkou je, co ten ispconfig vlastně volá, jestli něco nedetekuje špatně a nesnaží se to volat přes systemctl (restart bindu se mu taky nepodařil). Povedl se ten update Debian 7 na 8 v pořádku?

    Co ti vypíše cat /proc/1/exe jako root?
    13.7.2016 19:05 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Ahoj,
    je to přesně jak píšeš restart bindu se také neprovede automaticky. Upadate snad proběhl v pořádku nic tam podle mého nepsal.
    cat /proc/1/exe výstup nečitelný
    posílám kousek výstupu
    x0
    ŠHŔH               áďÇ@HÇHňHŔH
    ŔtHöÁużHňHŔH1 H,H9ę
    ŔuçHŹ$ 1öë?DHxH
    ŇtH+$ żH
    ŇOúčkË˙˙}3 ÷Â@
    öÂtGH1 H
    Ŕuë0fDHŔH
    Ŕtx0 uî˙˙˙HŔH
    Ŕuč.3 âű%3 ÷ÂtKHĆ0 H
    Ŕuë1HŔH
    Ŕtx0uî˙˙˙HŔH
    ŔučŢ2 â˙˙˙ďŇ2 öĆuE1Ŕż÷r@čdH­ŔHe0 â˙˙ý˙Š2 H
    Ń˙˙şHŢďĆ
            $ č˝Ĺ˙˙ďDžŹ$ čě- Ǣ- H
    ÉHČt8f.    p$:uśV:
           śP$H       u O˙˙˙HŔH
    ŔuŇ
    ˙Çž
    
    Dodám že se připojuji vzdáleně přes ssh putty
    Heron avatar 13.7.2016 19:11 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Sorry, mělo to být stat /proc/1/exe. To je jen na zjištění binárky, která běží jako init.
    13.7.2016 19:19 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Výstup
     File: â/proc/1/exeâ -> â/sbin/init (deleted)â
      Size: 0               Blocks: 0          IO Block: 1024   symbolic link
    Device: 3h/3d   Inode: 197242262   Links: 1
    Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
    Access: 2016-07-13 13:39:01.373765547 +0200
    Modify: 2016-05-25 09:09:01.463674654 +0200
    Change: 2016-05-25 09:09:01.463674654 +0200
     Birth: -
    
    Heron avatar 13.7.2016 19:41 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Deleted? To vypadá na poloviční stav mezi přechodem z initu na systemd. Rebootoval jste to po dist-upgrade?
    Heron avatar 13.7.2016 18:20 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Takže po troše pátrání jsem to našel:
    $app->system->getinitcommand¨
    function getinitcommand($servicename, $action, $init_script_directory = ''){
    		global $conf;
    		// upstart
    		if(is_executable('/sbin/initctl')){
    			exec('/sbin/initctl version 2>/dev/null | /bin/grep -q upstart', $retval['output'], $retval['retval']);
    			if(intval($retval['retval']) == 0) return 'service '.$servicename.' '.$action;
    		}
    		// systemd
    		if(is_executable('/bin/systemd') || is_executable('/usr/bin/systemctl')){
    			return 'systemctl '.$action.' '.$servicename.'.service';
    		}
    		// sysvinit
    		if($init_script_directory == '') $init_script_directory = $conf['init_scripts'];
    		if(substr($init_script_directory, -1) === '/') $init_script_directory = substr($init_script_directory, 0, -1);
    		return $init_script_directory.'/'.$servicename.' '.$action;
    	}
    ISPConfig odhaduje, podle existence různých binárek, na init systém, který daný OS používá.

    Jak z toho (nějakou normální cestou *) ven nevím (ISPConfig neznám).

    * Jedna možnost je přepnout systém na systemd, ale to bych takhle na dálku nedoporučoval,

    * Druhá je prostě odstranit detekci systemd z té fce.
    13.7.2016 19:17 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Ahoj,
    zkusil bych odstranit tedy tu funkci. Co je to za výstup souboru?
    Ještě jsem našel k tomu toto zde
    ale nevidím tam řešení.
    Heron avatar 13.7.2016 19:22 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    lib/clases/system.inc.php
    Řešení 1× (Lanny2013 (tazatel))
    13.7.2016 20:32 Lanny2013 | skóre: 2
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Moc moc děkuji za pomoc vše se zdá, že již funguje
    Pro ty co mají stejný problém upřesňuji řešení
    v souboru /usr/local/ispconfig/server/lib/classes/system.inc.php jsem zakomentoval následující řádky
               // systemd
    		//if(is_executable('/bin/systemd') || is_executable('/usr/bin/systemctl')){
    		//	return 'systemctl '.$action.' '.$servicename.'.service';
    		//}
    
    Heron avatar 13.7.2016 21:04 Heron | skóre: 53 | blog: root_at_heron | Olomouc
    Rozbalit Rozbalit vše Re: ISPconfig - Apache did not start after modifying this vhost file.
    Rád jsem pomohl. Není to ideální řešení. Jakmile ten ispconfig aktualizuješ, budeš muset znovu patchovat ten soubor (prostě je třeba na to myslet). Bylo by dobré vyřešit ten problém buď nastavením (nevím zda to jde), nebo změnou na podporovaný OS (v tomto případě asi korektně aktivovat systemd v Jessie).

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.