abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 15:44 | Nová verze

Byla vydána beta verze Linux Mintu 20.2 s kódovým jménem Uma. Na blogu Linux Mintu jsou hned tři oznámení. První o vydání Linux Mintu s prostředím Cinnamon, druhé o vydání Linux Mintu s prostředím MATE a třetí o vydání Linux Mintu s prostředím Xfce. Stejným způsobem jsou rozděleny také poznámky k vydání (Cinnamon, MATE, Xfce) a přehled novinek s náhledy (Cinnamon, MATE, Xfce). Linux Mint 20.2 bude podporován až do roku 2025.

Ladislav Hagara | Komentářů: 0
dnes 08:00 | Nová verze

Byla vydána verze 1.53.0 programovacího jazyka Rust (Wikipedie). Podrobnosti v poznámkách k vydání. Vyzkoušet Rust lze například na stránce Rust by Example.

Ladislav Hagara | Komentářů: 2
včera 22:33 | Nová verze

Na GOG.com lze do soboty 19. června získat zdarma počítačovou hru Absolute Drift (YouTube).

Ladislav Hagara | Komentářů: 2
včera 21:00 | Bezpečnostní upozornění

Bezpečnostní výzkumníci odhalili zásadní slabinu v šifrovacích algoritmech GEA-1 a GEA-2 používaných mobilními zařízeními. Jejich podezření, že slabina nevznikla náhodou, ale zcela úmyslně, s cílem zjednodušit útok na uživatele, posléze mluvčí autorů algoritmu (ETSI) potvrdil.

JiK | Komentářů: 14
včera 16:22 | Nová verze

Wasmer byl vydán ve verzi 2.0. Jedná se o běhové prostředí pro programy ve WebAssembly. Zdrojové kódy jsou k dispozici na GitHubu pod licencí MIT.

Ladislav Hagara | Komentářů: 0
včera 09:00 | IT novinky

Josef Průša představil novou vylepšenou SLA 3D tiskárnu Original Prusa SL1S SPEED. Její cena je 49 990 Kč. S mycí a vytvrzovací stanicí 64 990 Kč.

Ladislav Hagara | Komentářů: 1
včera 08:00 | Nová verze

Byla vydána nová verze 1.32.0 sady nástrojů pro správu síťových připojení NetworkManager. Novinkám se v příspěvku na blogu věnuje Thomas Haller.

Ladislav Hagara | Komentářů: 2
včera 07:00 | Nová verze

Bylo vydáno Eclipse IDE 2021-06 aneb Eclipse 4.20. Představení novinek tohoto vývojového prostředí také na YouTube.

Ladislav Hagara | Komentářů: 0
16.6. 23:11 | IT novinky

Měsíční kampaň Bulánci se vrací na Startovači na podporu vývoje nové verze dnes již dvacetileté počítačové hry Bulánci skončila. Vybráno bylo 7 308 770 Kč. Požadováno bylo 500 000 Kč.

Ladislav Hagara | Komentářů: 16
16.6. 18:33 | Zajímavý článek

Nakladatelství Raspberry Pi vydalo knihu The Computers That Made Britain věnovanou domácím počítačům z osmdesátých let (ZX Spectrum, BBC Micro, Commodore 64, …). Tištěnou verzi lze koupit za 12 liber. Elektronická verze je ke stažení za libovolnou částku, také zdarma (pdf).

Ladislav Hagara | Komentářů: 0
Používáte kalkulačku?
 (9%)
 (30%)
 (61%)
 (28%)
 (12%)
Celkem 225 hlasů
 Komentářů: 25, poslední dnes 07:59
Rozcestník

Dotaz: Mikrotik - přesměrování porů v LAN

13.5. 18:38 jan.rok | skóre: 21
Mikrotik - přesměrování porů v LAN
Přečteno: 372×
Prosím o radu zkušenější:

Mám funkční přesměrování portů z WAN do LAN, to udělat umím. Neumím ale udělat to, aby komunikace z LAN na moji veřejnou IP adresu a určitý port šla dovnitř na konkrétní IP.

Např.

Komunikace z LAN 192.168.1.1:10000 --> moje veřejnou IP app.firma.cz:10000 --> LAN 192.168.1.10:port 10000

nebo

Komunikace z LAN 192.168.1.1:20000 --> moje veřejnou IP app.firma.cz:20000 --> LAN 192.168.1.20:port 20000

Tato cesta, ale z WAN mi funguje. Z LAN to neumím...

Je to pro účely testování.

Děkuji za rady. JR.

Řešení dotazu:


Odpovědi

13.5. 18:42 bigBRAMBOR | skóre: 35
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
jestli tomu dobre rozumim, tak se to tu nedavno probiralo, sice pro linux ale prakticky je to uplne stejne. Dostanes tri napovedy, DNS, ipv6 a hairpin NAT.
14.5. 10:45 bigBRAMBOR | skóre: 35
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
presne jak jsem rikal, dostanes tri postupy, DNS, Hairpin a IPv6 - a hadku k tomu, stejne jako predtim :-D
14.5. 14:27 Vantomas | skóre: 31 | Praha
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Hádka teprve bude až si příspěvku všimne Filip Jirsák.
vencour avatar 14.5. 17:30 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Proč hádka? Jde o priority, o zařízení, která potřebuji pořešit, technologii, kterou chci nasadit. V principu můžu všechny uvedené prostředky/nástroje.
Pokud už bylo vše řešeno a stejně se pindá ... tak škoda cizího času ...
Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
13.5. 19:00 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN

Mikrotik má vlastní DNS takže je to jednoduché.

Nastavíš si tam DNS záznam app.firma.cz že je IP 192.168.1.20

Na veřejném DNS na internetu nastavíš v DNS záznam app.firma.cz je IP tvoje veřejná IP toho mikrotiku.

Když budeš se připojovat z internetu dostaneš veřejnou IP toho mikrotiku a nat bude správně fungovat, když se připojíš z místní sítě dostaneš IP přímo toho stroje a zase se bez problémů připojíš.

/ip dns
set allow-remote-requests=yes cache-size=4096KiB servers=193.17.47.1
/ip dns static
add address=192.168.1.20 comment="app.firma.cz" name=app.firma.cz
13.5. 19:28 jan.rok | skóre: 21
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Tohle ale bude fungovat jen pro jednu vnitřní IP adresu, ne?
13.5. 19:57 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Proč?

Pro všechny.

V lokálním DNS zadám místní IP a v veřejném DNS zadám všem tu veřejnou IP.

Jediná potíž bude že každý stroj může používat pouze unikátní port protože z venku to musíš nějak rozlišovat.

Prostě příslušný port půjde přiřadit pouze jedné lokální IP.
13.5. 21:00 GeorgeWH | skóre: 41
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A co ak lokalne stroje pouzivaju iny DNS server a nie mikrotik?
14.5. 19:12 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A proč v lokální síti používáš jiný DNS?

Pokud používáš jiný DNS musíš to řešit jinak jak už tu bylo řečeno je způsobů více.
14.5. 22:16 GeorgeWH | skóre: 41
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A proč v lokální síti používáš jiný DNS?

Teraz neviem, ci sa pytas vazne, alebo co.
14.5. 23:05 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Ano ptám se vážně......

Na všech soho routerech se používá jejich cache DNS a na mikrotiku je to špatně?

Prostě netuším proč by se to nemělo používat.

A kdo to nepoužívá tak ví proč a taky se nebude blbě ptát jak si nastavit přesměrování z LAN portu atd....

Ale to je na jinou diskuzi....
13.5. 20:59 mmm
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Je to dobře popsáno na MikroTik Wiki: https://wiki.mikrotik.com/wiki/Hairpin_NAT
13.5. 21:08 jan.rok | skóre: 21
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Už jsem to podle toho nastavil a funguje to, jak chci. Díky za rady, o téhle možnosti jsem nevěděl.

Co se týká toho DNS: jak píše kolega výše, co když PC používá jiný dns server a ne Mikrotik? Trochu jsem s DNS v Mikrotiku laboroval, nějak mi nechodil A záznam na lokální jméno, ale to už je na jiný dotaz.
13.5. 22:58 j
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
To je prece uplne sumak ne? Proste DNSko kteryho se klient uvnitr site pta, musi vracet interni adresu, pokud se pta klient zvenku, musi dostat verejnou. Naprosto bezna a narozdil od silenyho natovani zcela funkcni vec.

Samo jeste lepsi je zahodit v4 a pouzivat v6, pak dostavaj vsici verejnou adresu a netreba resit pojebanej nat.

Az tech klientu co je tlacis pres ten nat na mikrotika a pak zpet do site bude vic nez jeden, tak se ti ten mikrotik slozi. Naprosto vpohode takhle sejmes radove vykonejsi zelezo, jednoduse proto, ze to bud neunatuje nebo saturujes sit vnitrnim provozem a odstrelis si net.

---

Dete s tim guuglem dopice!
14.5. 02:33 Andrej | skóre: 49 | blog: Republic of Mordor
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN

IPv6.

Pak všechny tyhle nesmysly pozbudou smyslu.

Tenhle dotaz by bylo dobré přidat na seznam tisíců dalších dotazů typu „proč nepoužívat experiment z roku 1975 s 32-bitovými adresami, který selhal, a místo toho používat normální internet, jak má být“.

14.5. 19:36 czjaromir | skóre: 6
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Už jsem to IPv6 zkusil, pravda je že se situace stále vyvíjí. Nicméně před nedávnem jsem to zkusil a dopadlo to blbě. https://forum.root.cz/index.php?topic=8110.0

Řešení 1× (Andrej)
vencour avatar 14.5. 20:11 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Vlákno z roku 2013?
Ok, urážet lze všelijak ...
Klasik říká i "sebral jste i 30 vteřin života".
Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.