abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 23:44 | Nová verze

Google Chrome 95 byl prohlášen za stabilní. Nejnovější stabilní verze 95.0.4638.54 přináší řadu oprav a vylepšení (YouTube). Opraveno bylo 19 bezpečnostních chyb. Za nalezení nejvážnější z nich bylo vyplaceno 20 000 dolarů. Vylepšeny byly také nástroje pro vývojáře (YouTube).

Ladislav Hagara | Komentářů: 0
včera 21:00 | IT novinky

Google představil telefony Pixel 6 a Pixel 6 Pro. Předobjednat je lze za 599 a 899 dolarů. Z Česka a ze Slovenska zatím stále ne.

Ladislav Hagara | Komentářů: 5
včera 20:33 | Nová verze

Julius je open source reimplementace počítačové hry Caesar III. Vydána byla verze 1.7.0. Julius potřebuje ke spuštění originální média Caesar III. Lze zakoupit na GOG.com nebo na Steamu.

Ladislav Hagara | Komentářů: 1
včera 12:44 | IT novinky

Apple představil nové MacBooky Pro s novými vlastními čipy M1 Pro a M1 Max. Nejvýkonnější M1 Max má na sobě 10 CPU jader a 32 GPU jader. Vývojáři Asahi Linuxu si díky podpoře na Patreonu nové MacBooky Pro již objednali.

Ladislav Hagara | Komentářů: 28
včera 11:44 | IT novinky

Rodina produktů Raspberry Pi se rozrostla o rozšiřující desku Raspberry Pi Build HAT umožňující propojit Raspberry Pi s motory a senzory LEGO Technic z portfolia LEGO Education SPIKE. Současně byl představen 48W napájecí zdroj pro Raspberry Pi Build HAT a knihovna pro Python Build HAT.

Ladislav Hagara | Komentářů: 0
18.10. 18:33 | Nová verze

VKD3D-Proton byl vydán ve verzi 2.5. Jedná se fork knihovny vkd3d z projektu Wine pro Proton. Knihovna slouží pro překlad volání Direct3D 12 na Vulkan.

Ladislav Hagara | Komentářů: 1
18.10. 17:11 | Nová verze

Rozšíření GNOME Shellu Dash to Dock bylo po roce vydáno v nové verzi 70. Přidána byla podpora GNOME Shellu 40.

Ladislav Hagara | Komentářů: 0
18.10. 07:00 | Zajímavý software

L0phtCrack (Wikipedie), nástroj pro auditování a obnovu hesel v Microsoft Windows, je nově open source. Zdrojové kódy nejnovější verze 7.2.0 byly zveřejněny na GitLabu.

Ladislav Hagara | Komentářů: 4
15.10. 21:44 | IT novinky

V dubnu letošního roku byla hodnota Bitcoinu, decentralizované kryptoměny téměř 65 000 dolarů. V červnu hodnota klesla pod 30 000 dolarů. Aktuálně opět překonala 60 000 dolarů.

Ladislav Hagara | Komentářů: 51
15.10. 16:00 | Nová verze

Společnost PINE64 stojící za telefonem PinePhone, notebooky Pinebook a Pinebook Pro, IP kamerou PineCube, hodinkami PineTime, páječkou (pájecím perem) Pinecil, zdroji PinePower nebo RISC-V vývojovou deskou PineCone publikovala na svém blogu říjnový souhrn novinek (YouTube) a představila nový vylepšený PinePhone Pro.

Ladislav Hagara | Komentářů: 25
Kolik monitorů (obrazovek) používáte současně?
 (49%)
 (36%)
 (14%)
 (1%)
Celkem 375 hlasů
 Komentářů: 29, poslední včera 07:04
Rozcestník



Dotaz: Mikrotik - přesměrování porů v LAN

13.5. 18:38 jan.rok | skóre: 21
Mikrotik - přesměrování porů v LAN
Přečteno: 388×
Prosím o radu zkušenější:

Mám funkční přesměrování portů z WAN do LAN, to udělat umím. Neumím ale udělat to, aby komunikace z LAN na moji veřejnou IP adresu a určitý port šla dovnitř na konkrétní IP.

Např.

Komunikace z LAN 192.168.1.1:10000 --> moje veřejnou IP app.firma.cz:10000 --> LAN 192.168.1.10:port 10000

nebo

Komunikace z LAN 192.168.1.1:20000 --> moje veřejnou IP app.firma.cz:20000 --> LAN 192.168.1.20:port 20000

Tato cesta, ale z WAN mi funguje. Z LAN to neumím...

Je to pro účely testování.

Děkuji za rady. JR.

Řešení dotazu:


Odpovědi

13.5. 18:42 bigBRAMBOR | skóre: 36
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
jestli tomu dobre rozumim, tak se to tu nedavno probiralo, sice pro linux ale prakticky je to uplne stejne. Dostanes tri napovedy, DNS, ipv6 a hairpin NAT.
14.5. 10:45 bigBRAMBOR | skóre: 36
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
presne jak jsem rikal, dostanes tri postupy, DNS, Hairpin a IPv6 - a hadku k tomu, stejne jako predtim :-D
14.5. 14:27 Vantomas | skóre: 31 | Praha
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Hádka teprve bude až si příspěvku všimne Filip Jirsák.
vencour avatar 14.5. 17:30 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Proč hádka? Jde o priority, o zařízení, která potřebuji pořešit, technologii, kterou chci nasadit. V principu můžu všechny uvedené prostředky/nástroje.
Pokud už bylo vše řešeno a stejně se pindá ... tak škoda cizího času ...
Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
13.5. 19:00 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN

Mikrotik má vlastní DNS takže je to jednoduché.

Nastavíš si tam DNS záznam app.firma.cz že je IP 192.168.1.20

Na veřejném DNS na internetu nastavíš v DNS záznam app.firma.cz je IP tvoje veřejná IP toho mikrotiku.

Když budeš se připojovat z internetu dostaneš veřejnou IP toho mikrotiku a nat bude správně fungovat, když se připojíš z místní sítě dostaneš IP přímo toho stroje a zase se bez problémů připojíš.

/ip dns
set allow-remote-requests=yes cache-size=4096KiB servers=193.17.47.1
/ip dns static
add address=192.168.1.20 comment="app.firma.cz" name=app.firma.cz
13.5. 19:28 jan.rok | skóre: 21
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Tohle ale bude fungovat jen pro jednu vnitřní IP adresu, ne?
13.5. 19:57 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Proč?

Pro všechny.

V lokálním DNS zadám místní IP a v veřejném DNS zadám všem tu veřejnou IP.

Jediná potíž bude že každý stroj může používat pouze unikátní port protože z venku to musíš nějak rozlišovat.

Prostě příslušný port půjde přiřadit pouze jedné lokální IP.
13.5. 21:00 GeorgeWH | skóre: 41
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A co ak lokalne stroje pouzivaju iny DNS server a nie mikrotik?
14.5. 19:12 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A proč v lokální síti používáš jiný DNS?

Pokud používáš jiný DNS musíš to řešit jinak jak už tu bylo řečeno je způsobů více.
14.5. 22:16 GeorgeWH | skóre: 41
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
A proč v lokální síti používáš jiný DNS?

Teraz neviem, ci sa pytas vazne, alebo co.
14.5. 23:05 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Ano ptám se vážně......

Na všech soho routerech se používá jejich cache DNS a na mikrotiku je to špatně?

Prostě netuším proč by se to nemělo používat.

A kdo to nepoužívá tak ví proč a taky se nebude blbě ptát jak si nastavit přesměrování z LAN portu atd....

Ale to je na jinou diskuzi....
13.5. 20:59 mmm
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Je to dobře popsáno na MikroTik Wiki: https://wiki.mikrotik.com/wiki/Hairpin_NAT
13.5. 21:08 jan.rok | skóre: 21
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Už jsem to podle toho nastavil a funguje to, jak chci. Díky za rady, o téhle možnosti jsem nevěděl.

Co se týká toho DNS: jak píše kolega výše, co když PC používá jiný dns server a ne Mikrotik? Trochu jsem s DNS v Mikrotiku laboroval, nějak mi nechodil A záznam na lokální jméno, ale to už je na jiný dotaz.
13.5. 22:58 j
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
To je prece uplne sumak ne? Proste DNSko kteryho se klient uvnitr site pta, musi vracet interni adresu, pokud se pta klient zvenku, musi dostat verejnou. Naprosto bezna a narozdil od silenyho natovani zcela funkcni vec.

Samo jeste lepsi je zahodit v4 a pouzivat v6, pak dostavaj vsici verejnou adresu a netreba resit pojebanej nat.

Az tech klientu co je tlacis pres ten nat na mikrotika a pak zpet do site bude vic nez jeden, tak se ti ten mikrotik slozi. Naprosto vpohode takhle sejmes radove vykonejsi zelezo, jednoduse proto, ze to bud neunatuje nebo saturujes sit vnitrnim provozem a odstrelis si net.

---

Dete s tim guuglem dopice!
14.5. 02:33 Andrej | skóre: 49 | blog: Republic of Mordor
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN

IPv6.

Pak všechny tyhle nesmysly pozbudou smyslu.

Tenhle dotaz by bylo dobré přidat na seznam tisíců dalších dotazů typu „proč nepoužívat experiment z roku 1975 s 32-bitovými adresami, který selhal, a místo toho používat normální internet, jak má být“.

14.5. 19:36 czjaromir | skóre: 9
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Už jsem to IPv6 zkusil, pravda je že se situace stále vyvíjí. Nicméně před nedávnem jsem to zkusil a dopadlo to blbě. https://forum.root.cz/index.php?topic=8110.0

vencour avatar 14.5. 20:11 vencour | skóre: 56 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: Mikrotik - přesměrování porů v LAN
Vlákno z roku 2013?
Ok, urážet lze všelijak ...
Klasik říká i "sebral jste i 30 vteřin života".
Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.