abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    dnes 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 0
    včera 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    včera 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 7
    včera 16:33 | Zajímavý software

    Strands Decider 2B je malý open-source model s 2 miliardami parametrů, určený k rychlé klasifikaci vstupů a rozhodování mezi možnostmi, generující odpovědi ve stylu modelu Jev. Strands dosáhl přibližně 72% shody s Jevem na veřejné testovací sadě JevBench (tento benchmark pochopitleně nepředstavuje přímé srovnání s modelem Jev). Zdrojové kódy jsou k dispozici na GitHubu pod licencí Apache-2.0, váhy modelu na Hugging Face.

    ❗Červivý Hřib krade❗ | Komentářů: 3
    včera 16:22 | Upozornění

    Ve věku 90 let zemřela americká softwarová inženýrka Margaret Hamiltonová, která vedla tým, jenž vyvíjel letový software pro program Apollo amerického Národního úřadu pro letectví a vesmír (NASA).

    Ladislav Hagara | Komentářů: 4
    včera 13:33 | Humor

    Japonský Google rozšířil svou kolekci DYI fyzických klávesnic Gboard o klávesnici ve tvaru běžícího pásu. Proč se mají přesouvat ruce po klávesnici, když se mohou přesouvat klávesy k ruce? Pro zájemce je návod na sestavení včetně STL souborů pro 3D tisk a firmware k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 2
    7.10. 23:22 | Bezpečnostní upozornění

    Nejnovější X.Org X server 21.1.25 a Xwayland 24.1.14 řeší 12 bezpečnostních chyb.

    Ladislav Hagara | Komentářů: 0
    7.10. 16:33 | Nová verze

    Google Chrome 155 byl prohlášen za stabilní. Přináší podporu JPEG XL (.jxl). Opraveno bylo 247 bezpečnostních chyb.

    Ladislav Hagara | Komentářů: 1
    7.10. 16:00 | Komunita

    Konference OpenAlt 2026 hledá přednášející. Přihlásit přednášky lze do neděle 11. října. Konference proběhne o víkendu 7. a 8. listopadu na půdě Fakulty informačních technologií VUT v Brně. Témata konference jsou: Otevřený a svobodný software, IoT a Hnutí tvůrců, Vzdělávání, Bezpečnost a soukromí, Otevřená společnost, komunity a data, OpenMobility a další.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2817 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: fetchmail+postfix - vraci zpravy

    13.12.2004 10:38 Ooaniki
    fetchmail+postfix - vraci zpravy
    Přečteno: 575×
    Dobry den, nastavil jsem v praci postovni server - postfix, fetchmail a popa3d. V praci mame pevne pripojeni bez reverzniho zaznamu nicmene nastavil jsem myorigin a mydestination na "nase_domena.cz" a kdykoliv poslu mejl pres postfix tak to funguje k plne spokojenosti. Problem je vsak ve fetchmailu. Ve chvili kdy se pokusi stahnout postu od nase providera, ktery nam dela webhosting a ma oficilne "nase_domena.cz" tak ji stahne ze serveru ale nedoruci ji do lokalnich schranek a pres postfix ji vrati zpet s touto hlaskou:
    The Postfix program
    
    peta@localhost.localhost (expanded from peta@localhost): Host or domain
        name not found. Name service error for name=localhost.localhost type=A:
        Host not found
    
    v priloze je jinak napsano:
    Final-Recipient: rfc822; peta@localhost.localhost
    Original-Recipient: rfc822; peta@localhost
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
        for name=localhost.localhost type=A: Host not found
    
    Fetchmail jinak funguje naprosto v poradku, stahuje ze vzdalenych uctu, posila a uklada postu lokalne jen mu zrejme v tomto pripade vadi ona hlavicka kde je uveden "nekdo@nase_domena.cz" jinak si to nedovedu vysvetlit. Jde nekde nastavit aby toto nastaveni ignoroval a postu proste ukladal v kazdem pripade?

    Anebo jakym jinym zpusobem obejit to, ze nemame reverz a ze nevlastnime "nase_domena.cz"? Predem dekuji za jakkoukoliv radu, preji hezky den.

    Odpovědi

    13.12.2004 13:15 jaja
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    divne, melo by to fungovat
    13.12.2004 15:38 Ooaniki
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    No bohuzel to nefunguje :-(
    13.12.2004 18:59 Martin H.
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    Dobry den, ... The Postfix program

    peta@localhost.localhost (expanded from peta@localhost): Host or domain name not found. Name service error for name=localhost.localhost type=A: Host not found ...
    No, viděl bych to na nesoulad jména hostname v postfixu a počítače. Rozhodně se neresolvuje název na IP. Zkuste si do /etc/hosts připsat ještě taky IP_ADRESA_SERVERU hostname hostname.vase_domena.cz

    Případně rozchoďte vlastní DNSku vase_domena.cz pouze pro Vaši lokální síť. Tedy pro Vaši síť bude autoritativní a ostatní záznamy budou forwardovány. A na ní si dejte kromě A záznamů i MX záznam. A je po problému.

    PS: Osobně mám na všech serverech spuštěný BIND pro lokální síť, kde mám i poštovní server.
    13.12.2004 20:24 Michal Svanda
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    Zkuste nenechat fetchmail predat zpravu postfixu. Coz se da docilit napr. pomoci
    fetchmail -m "/usr/bin/procmail -d %T"
    U mne to tak funguje a emaily to nevraci.
    17.12.2004 12:30 Ooaniki
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    Tak jsem to vyzkousel, pres procmail to projde... nicmene od te chvile uz nejde precist mailbox - presneji: z outloku se na nej nejde dostat - chce porad user/pass, v syslogu je jen nic nerikajici:

    localhost popa3d[2807]: Authentication passed for peta localhost popa3d[2807]: Failed or refused to load /var/spool/mail/peta

    pritom prava jsou nastavena jako u jinych uzivatelu (do kterych vsak procmail nezapisoval) a tem to jede

    u webovyho rozhrani ve webmin postfix vidi ze mailbox neni prazdny, ukazuje spravne jeho velikost ale kdyz na nej kliknu tak ukaze schranku prazdnou

    kdyz se kouknu do mc tak v souboru /var/spool/mail/peta je mejl ktery procmail stahnul... nevi nekde v cem by mohla byt chyba? Ze by procmail mel nejaky jiny format se kterym si popa3d nerozumi?
    17.12.2004 12:46 Ooaniki
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    Limitem ktery ma popa3d ohledne velikosti to nebude:

    ls -l /var/spool/mail/peta -rw-rw---- 1 peta mail 2400 pro 17 12:21 /var/spool/mail/peta
    13.12.2004 23:15 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: fetchmail+postfix - vraci zpravy
    Prostě máte bordel ve jménech.

    co toto je za adresa ? peta@localhost.localhost toto je nesmysl když už tak peta@localhost

    Takže udělat pořádek na DNS a v souboru hosts.

    Případně v fetchmailu zadejte celou adresu ve tvaru xxx@yyy

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.