abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 4
    dnes 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    dnes 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 10
    dnes 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    dnes 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    dnes 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 0
    včera 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    včera 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 8
    včera 16:33 | Zajímavý software

    Strands Decider 2B je malý open-source model s 2 miliardami parametrů, určený k rychlé klasifikaci vstupů a rozhodování mezi možnostmi, generující odpovědi ve stylu modelu Jev. Strands dosáhl přibližně 72% shody s Jevem na veřejné testovací sadě JevBench (tento benchmark pochopitleně nepředstavuje přímé srovnání s modelem Jev). Zdrojové kódy jsou k dispozici na GitHubu pod licencí Apache-2.0, váhy modelu na Hugging Face.

    ❗Červivý Hřib krade❗ | Komentářů: 4
    včera 16:22 | Upozornění

    Ve věku 90 let zemřela americká softwarová inženýrka Margaret Hamiltonová, která vedla tým, jenž vyvíjel letový software pro program Apollo amerického Národního úřadu pro letectví a vesmír (NASA).

    Ladislav Hagara | Komentářů: 10
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2818 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Mediawiki internal server error

    26.4.2018 09:13 Jack Hokus | skóre: 34 | blog: LostHeaven
    Mediawiki internal server error
    Přečteno: 626×
    Dobrý den,

    na testovací server ve virtualboxu jsem si nahodil mediawiki. Po spuštění jsem dostal chybovou hlášku: MediaWiki 1.30 internal error Installing some PHP extensions is required.

    Php mám nainstalováno, php admin jede bez problémů. Zkoušel jsem hledat, ale zatím jsem nic nenašel, má někdo nějaký nápad?

    Petr
    http://www.jackhokus.cz/

    Odpovědi

    26.4.2018 09:18 Petr
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Php-xml a php-mbstring mas?
    26.4.2018 09:42 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    zkoušel jsem vyhledat vámi uvedený balíček Php-xml a našel jsem jen tyto:
    • php5-xmlrpc php-libkolabxml1
    • php5-xmlreader
    • php5-xmlrpc
    • php5-xmlwriter
    • php7-xmlreader instalováno
    • php7-xmlrpc
    • php7-xmlwriter instalováno
    Druhý balíček jsem nenašel vůbec. Našel jsem dotaz podobný svému na tomto fóru, tak jsem hledal i mezi moduly pro apache, ale taky jsem nenašel.

    Můžete mi prosím poradit, kde hledat? Pokud jde o mnou používanou distribuci, tak je to OpenSuSe.

    Děkuji

    http://www.jackhokus.cz/
    26.4.2018 09:59 tf
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    No a na jake distribuci to zkousite?
    26.4.2018 10:34 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    zkouším to na OpenSuSe

    http://www.jackhokus.cz/
    26.4.2018 10:02 NN
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Podivej se do logu Apache, tam bude detail toho erroru..
    26.4.2018 10:30 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    do logů jsem se právě podíval. Jsou tam dva soubory, jednak access_log a error_log

    V souboru error_log je toto
    [Thu Apr 26 07:38:25.784087 2018] [ssl:warn] [pid 1655] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Thu Apr 26 07:38:25.845490 2018] [mpm_prefork:notice] [pid 1655] AH00163: Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 configured -- resuming normal operations
    [Thu Apr 26 07:38:25.845523 2018] [core:notice] [pid 1655] AH00094: Command line: '/usr/sbin/httpd-prefork -D SYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -D SYSTEMD -D FOREGROUND'
    
    Soubor access_log obsahuje toto:
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/codemirror/addon/lint/sql-lint.js?v=4.8.0.1 HTTP/1.1" 200 1048 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/vendor/codemirror/addon/lint/lint.js?v=4.8.0.1 HTTP/1.1" 200 8609 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/js/console.js?v=4.8.0.1 HTTP/1.1" 200 57278 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/dot.gif HTTP/1.1" 200 43 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/pmahomme/img/logo_right.png HTTP/1.1" 200 4306 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:51:42 +0200] "GET /phpMyAdmin/themes/pmahomme/img/b_help.png HTTP/1.1" 200 705 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    ::1 - - [25/Apr/2018:11:51:57 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    ::1 - - [25/Apr/2018:11:51:58 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    ::1 - - [25/Apr/2018:11:51:59 +0200] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips PHP/7.0.7 (internal dummy connection)"
    192.168.32.131 - - [25/Apr/2018:11:55:39 +0200] "GET /phpMyAdmin/ HTTP/1.1" 200 14150 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [25/Apr/2018:11:55:57 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /mediawiki/resources/assets/mediawiki.png HTTP/1.1" 200 22508 "http://192.168.32.131/mediawiki/" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /favicon.ico HTTP/1.1" 404 1036 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:08:33:40 +0200] "GET /favicon.ico HTTP/1.1" 404 1036 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:09:06:36 +0200] "GET /mediawiki HTTP/1.1" 301 240 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    192.168.32.131 - - [26/Apr/2018:09:06:36 +0200] "GET /mediawiki/ HTTP/1.1" 500 921 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"
    
    Nevím, co přesně hledat, tak jsem to bral podle data. Pokud je třeba něco dodat, dejte vědět.
    http://www.jackhokus.cz/
    26.4.2018 11:08 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Jasně ti to píše, že chybí nějaké rozšíření. Nevím jakým postupem jsi to instaloval, ale vypadá to, jako bys použil nějaký konfigurák, co obsahuje nastavení pro nějaké rozšíření, jaké nemáš.

    Já v takovém případě nejprve zakomentuji všechna rozšíření a pak je postupně povoluji, dokud se neobjeví ta chyba. Může to být totiž i jeho špatnou verzí.
    26.4.2018 11:43 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    vycházel jsem z několika návodů:

    Mediawiki 1 Mediawiki 2 Apache, databáze, PHP admin

    Pokud jde o ty konfigurační soubory, tak jsem žádné nepřebíral, nainstaloval jsem balíčky podle návodu. Takže všechny konfigurační soubory jsou distribuční. Tohle je můj první pokus o něco takového, takže jediný konfigurační soubor, který mne v této souvislosti mne napadá je php.ini, měl jste na mysli ten, nebo jiný?

    Petr

    http://www.jackhokus.cz/
    26.4.2018 13:32 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Kdepák.. Hlavní konfigurační soubor MediaWiki je LocalSettings.php v kořenu adresáře kde jsou zdrojáky.

    Jinak se omlouvám, ale videonávody jsou upřímně řečeno na hovno. Stejně jako instalace přes klikátka. Ovšem každopádně výsledkem instalačního procesu by měl být výše zmíněný soubor.

    26.4.2018 19:47 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý večer,

    není se za co omlouvat, teď už jsem doma, zítra se na to mrknu. O existenci konfiguračního souboru LocalSettings.php jsem neměl ani ponětí.

    Petr
    http://www.jackhokus.cz/
    30.4.2018 08:45 Jack Hokus | skóre: 34 | blog: LostHeaven
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    Dobrý den,

    při hledání řešení jsem pro sebe objevil příkaz php -m, takže tady je seznam u modulů.
    [PHP Modules]
    bz2
    Core
    ctype
    curl
    date
    dom
    filter
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Reflection
    session
    SimpleXML
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlrpc
    xmlwriter
    zip
    
    http://www.jackhokus.cz/
    30.4.2018 08:50 Aleš Kapica | skóre: 52 | blog: kenyho_stesky | Ostrava
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    No. Jelikož křišťálovou kouli nemám, tak ti alespoň přihodím seznam modulů které mám nainstalované na serveru co mi běží wiki já. Pozn.: Výpisy jsou dva, protože ty servery spravuji dva.
    [PHP Modules]
    bz2
    calendar
    Core
    ctype
    date
    dom
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    json
    libxml
    mbstring
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib
    
    [Zend Modules]
    Zend OPcache
    
    
    Tohle je ten druhý
    [PHP Modules]
    bcmath
    bz2
    calendar
    Core
    ctype
    date
    dba
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imap
    json
    ldap
    libxml
    mbstring
    mcrypt
    memcache
    memcached
    mhash
    mysql
    mysqli
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    Phar
    posix
    readline
    Reflection
    session
    shmop
    SimpleXML
    soap
    sockets
    SPL
    standard
    sysvmsg
    sysvsem
    sysvshm
    tokenizer
    wddx
    xml
    xmlreader
    xmlrpc
    xmlwriter
    Zend OPcache
    zip
    zlib
    
    [Zend Modules]
    Zend OPcach
    
    30.4.2018 10:38 NN
    Rozbalit Rozbalit vše Re: Mediawiki internal server error
    a nebo se podivam do manualu..

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.