abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 17:33 | Bezpečnostní upozornění

Před šesti týdny byly publikovány výsledky bezpečnostního auditu zdrojových kódů OpenVPN a nalezené bezpečnostní chyby byly opraveny ve verzi OpenVPN 2.4.2. Guido Vranken minulý týden oznámil, že v OpenVPN nalezl další čtyři bezpečnostní chyby (CVE-2017-7520, CVE-2017-7521, CVE-2017-7522 a CVE-2017-7508). Nejzávažnější z nich se týká způsobu, jakým aplikace zachází s SSL certifikáty. Vzdálený útočník může pomocí speciálně

… více »
Ladislav Hagara | Komentářů: 0
včera 06:55 | Zajímavý projekt

V Edici CZ.NIC vyšla kniha Průvodce labyrintem algoritmů. Kniha je ke stažení zcela zdarma (pdf) nebo lze objednat tištěnou verzi za 339 Kč (připojení přes IPv4) nebo 289 Kč (připojení přes IPv6).

Ladislav Hagara | Komentářů: 6
včera 06:33 | Zajímavý software

Byla vydána verze 2.2.0 svobodného správce hesel KeePassXC (Wikipedie). Jedná se o komunitní fork správce hesel KeePassX s řadou vylepšení.

Ladislav Hagara | Komentářů: 0
včera 06:11 | IT novinky

Vývojář Debianu Henrique de Moraes Holschuh upozorňuje v diskusním listu debian-devel na chybu v Hyper-Threadingu v procesorech Skylake a Kaby Lake od Intelu. Za určitých okolností může chyba způsobit nepředvídatelné chování systému. Doporučuje se aktualizace mikrokódu CPU nebo vypnutí Hyper-Threadingu v BIOSu nebo UEFI [reddit].

Ladislav Hagara | Komentářů: 0
24.6. 01:23 | Komunita

Phoronix spustil 2017 Linux Laptop Survey. Tento dotazník s otázkami zaměřenými na parametry ideálního notebooku s Linuxem lze vyplnit do 6. července.

Ladislav Hagara | Komentářů: 3
23.6. 22:44 | Nová verze

Po třech měsících vývoje od vydání verze 5.5.0 byla vydána verze 5.6.0 správce digitálních fotografií digiKam (digiKam Software Collection). Do digiKamu se mimo jiné vrátila HTML galerie a nástroj pro vytváření videa z fotografií. V Bugzille bylo uzavřeno více než 81 záznamů.

Ladislav Hagara | Komentářů: 1
23.6. 17:44 | Nová verze

Byla vydána verze 9.3 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 3
23.6. 13:53 | Nová verze

Simon Long představil na blogu Raspberry Pi novou verzi 2017-06-21 linuxové distribuce Raspbian určené především pro jednodeskové miniaturní počítače Raspberry Pi. Společně s Raspbianem byl aktualizován také instalační nástroj NOOBS (New Out Of the Box Software). Z novinek lze zdůraznit IDE Thonny pro vývoj v programovacím jazyce Python a především offline verzi Scratche 2.0. Ten bylo dosud možné používat pouze online. Offline bylo možné používat pouze Scratch ve verzi 1.4. Z nového Scratchu lze ovládat také GPIO piny. Scratch 2.0 vyžaduje Flash.

Ladislav Hagara | Komentářů: 1
22.6. 14:24 | Nová verze

Opera 46, verze 46.0.2597.26, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 59. Z novinek lze zmínit například podporu APNG (Animated Portable Network Graphics). Přehled novinek pro vývojáře na blogu Dev.Opera. Oznámení o vydání zmiňuje také první televizní reklamu.

Ladislav Hagara | Komentářů: 0
22.6. 13:37 | IT novinky

I čtenáři AbcLinuxu před dvěma lety vyplňovali dotazníky věnované Retro ThinkPadu. Nyní bylo potvrzeno, že iniciativa Retro ThinkPad je stále naživu a Lenovo připravuje speciální edici ThinkPadu jako součást oslav jeho 25. výročí.

Ladislav Hagara | Komentářů: 36
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (31%)
 (1%)
 (9%)
 (44%)
 (9%)
Celkem 842 hlasů
 Komentářů: 65, poslední 1.6. 19:16
    Rozcestník

    Dotaz: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok

    28.5.2006 13:34 kavol | skóre: 28
    nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Přečteno: 623×
    Zdravíčko,

    mám problémek s grafikou ... nejede mi 3D akcelerace, když si pustím glxgears (nebo cokoliv jiného 3D), tak zatížení procesoru vylítne na 100% a karta samotná se zjevně nudí :-(

    mám Gentoo na AMD64, dělá to jak se "stabilními" ovladači 1.0.8756 i s odmaskovanými novými 1.0.8762

    přitom modul do jádra se natáhne v pohodě, dle glxinfo by to mělo být ok:
    direct rendering: Yes
    OpenGL renderer string: GeForce2 MX/AGP/SSE2
    a nástroj nvidia-settings s tím v pohodě spolupracuje ...

    netuší prosím někdo, kde by mohl mít pes hrob? (pochopitelně návod na Gentoo aj. mám pročtené ...)

    Odpovědi

    28.5.2006 13:38 knizmi | skóre: 27 | blog: Blog | Kosmonosy
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    No, me pri spusteni glxgears taky zatizeni procesoru vyleti na 100%... A podle toho Direct rendering bych rekl, ze vam 3D akcelerace funguje. Napiste sem kolik FPS vam glxgears davaji. Podle me vam akcelerace jede, ale od te karty uz nemuzete cekat zazraky.
    28.5.2006 14:07 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    No, me pri spusteni glxgears taky zatizeni procesoru vyleti na 100%...
    pak se obávám, že je cosi shnilého i u vás - mě se za normálních okolností drží do 5%, nejen co si pamatuju z dob kdy to fungovalo ale i ověřeno na jiném stroji
    A podle toho Direct rendering bych rekl, ze vam 3D akcelerace funguje.
    no, to já bych řekl také, ale reálně tomu tak prostě není :-(
    Napiste sem kolik FPS vam glxgears davaji.
    $ glxgears
    2752 frames in 5.0 seconds = 550.400 FPS
    3035 frames in 5.0 seconds = 607.000 FPS
    3041 frames in 5.0 seconds = 608.200 FPS
    3070 frames in 5.0 seconds = 614.000 FPS
    3094 frames in 5.0 seconds = 618.800 FPS
    3030 frames in 5.0 seconds = 606.000 FPS
    2960 frames in 5.0 seconds = 592.000 FPS
    2891 frames in 5.0 seconds = 578.200 FPS
    2858 frames in 5.0 seconds = 571.600 FPS
    ... a tak dál
    Podle me vam akcelerace jede, ale od te karty uz nemuzete cekat zazraky.
    zázraky od ní nečekám, dokonce mám ze dřív vyzkoušeno, že s nativní akcelerací dosáhnu menší FPS než se softwarovou emulací - rozdíl je ovšem v tom zatížení CPU ... u některých věcí se potom trhá zvuk, prakticky nereaguje kurzor myši atp.

    --

    ještě jsem zjistil jednu věc, věci ve fulscreenu mi nejdou na celou obrazovku, ale jen v malém okýnku na středu (jakoby karta neuměla přepnout rozlišení)
    28.5.2006 15:05 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    No, me pri spusteni glxgears taky zatizeni procesoru vyleti na 100%...
    pak se obávám, že je cosi shnilého i u vás - mě se za normálních okolností drží do 5%, nejen co si pamatuju z dob kdy to fungovalo ale i ověřeno na jiném stroji
    Že bych si v těch několika letech nevšimnul nefunkční akcelerace? Spuštění glxgears mi taky vezme 97% CPU a hlásí:
    2241 frames in 5.0 seconds = 448.112 FPS
    2242 frames in 5.0 seconds = 448.388 FPS
    2242 frames in 5.0 seconds = 448.326 FPS
    2241 frames in 5.0 seconds = 448.041 FPS
    2244 frames in 5.0 seconds = 448.709 FPS
    2241 frames in 5.0 seconds = 448.146 FPS
    2245 frames in 5.0 seconds = 448.842 FPS
    2239 frames in 5.0 seconds = 447.752 FPS
    2244 frames in 5.0 seconds = 448.614 FPS
    GK označí glxinfo jako "GeForce2 MX/AGP/3DNOW!", v obchodě byla označena jako "MX 200".

    Nikdy mne nenapadlo zapochybovat o nedostatečné výkonosti, krom ojedinělých situací nezaznamenávám trhání zvuku, zasekávání kurzoru a mplayer s vo=xv přehrává přes celý fulscreen. Tak teď nevím, ale nárustu výkonu se bránit nebudu, jen zjistit, včem je zakopaný pes.
    28.5.2006 20:06 razor | skóre: 32
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Jó tak to jsme na tom stejně. Stejná karta, "stejné" výsledky glxgears, vytížení procesoru blížící se 100% a nárustu výkonnu se též nebudu bránit :-) Driver: media-video/nvidia-kernel-1.0.8178-r3
    28.5.2006 15:58 knizmi | skóre: 27 | blog: Blog | Kosmonosy
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    No, je fakt, ze necele 4000 FPS u glxgears se mi na me sestave (A64 3000+ a GF6400) zda malo, ale bezne hraju DeusEx (pres wine) a chvili jsem hral i demicko Dooma3 (nativne). A pochybuju, ze by mi tohle muj Athlon utah softwarove :-)
    Na druhou stranu, pokud je u me realnych tech +-3800 FPS, tak u GF2MX si myslim tech 600 FPS docela odpovida.
    28.5.2006 18:11 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    hmmm ... tak že bych si to blbě pamatoval a vysoká zátěž byla u glxgears normální? ... totiž, prve když jsem psal "ověřeno na druhém stroji", mínil jsem obecně při používání 3D (gameska torcs), přímo glxgears jsem tam nezkoušel, neb jaksi nemůžu najít v jakém jsou balíčku ...

    ale stejně se mi to furt nezdá, je to trhaný až hrůza, tohle přece není normální???
    28.5.2006 19:19 trekker.dk | skóre: 71
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Když spustím glxgears, tak htop píše, že spotřebovává 0.0% procesorového času. Na druhou stranu se ty kolečka točí dost pomalu a nevypisuje to počet FPS (hw akcelerace ale funguje)
    Quando omni flunkus moritati
    28.5.2006 20:29 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    glxgears -iacknowledgethatthistoolisnotabenchmark
    glxgears -printfps
    
    ;)
    Urine should only be green if you're Mr. Spock.
    28.5.2006 20:32 knizmi | skóre: 27 | blog: Blog | Kosmonosy
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Ono to vazne funguje i s tim benchmarkem :-) Uz asi chapu, proc to tak udali
    28.5.2006 20:41 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    hau, já tam takový hezký options nemám :-(

    a jinak rychlost točení koleček je irelevantní, podstatný je, jestli jdou plynule (což u mě momentálně ne, na tý nvidii, na noťasu s mnohem slabším intelem jo), a jaký udaj fps (jo, benchmark to není, ale k orientaci stačí)
    28.5.2006 22:10 trekker.dk | skóre: 71
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Díky, man glxgears ani glxgears --help nějak nepomáhalo.
    496 frames in 5.0 seconds = 99.047 FPS
    502 frames in 5.0 seconds = 100.159 FPS
    501 frames in 5.0 seconds = 99.999 FPS
    502 frames in 5.0 seconds = 100.236 FPS
    500 frames in 5.0 seconds = 99.996 FPS
    Nic moc, bejvávalo víc. Ale plynule to chodí a zátěž procesoru 0.0%, takže asi dobrý.
    Quando omni flunkus moritati
    28.5.2006 20:31 knizmi | skóre: 27 | blog: Blog | Kosmonosy
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Ja od jiste doby musim psat glxgears -printfps. Nevim, jestli je to novejsima X nebo je to naka specialita Debianu :-( A podle rychlosti kolecek se nic nepozna, u me se taky tocej pomalu.
    David Watzke avatar 28.5.2006 20:36 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Asi specialita, protože na Gentoo:
    dave ~ $ glxgears -iacknowledgethatthistoolisnotabenchmark
    Warrning: unknown parameter: -iacknowledgethatthistoolisnotabenchmark
    14830 frames in 5.0 seconds = 2965.995 FPS
    
    dave ~ $ glxgears -printfps
    Warrning: unknown parameter: -printfps
    15006 frames in 5.0 seconds = 3001.198 FPS
    
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    28.5.2006 21:11 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    melo by to byt v glxgears z mesa-utils, ne z tech z xorg 6.9 ... ale ty mas urcite xorg 7.0 a tedy mesa-utils ...tak nevim .... viz. #bts360064
    Urine should only be green if you're Mr. Spock.
    David Watzke avatar 28.5.2006 21:23 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Mám Xorg 7.0 a x11-apps/mesa-progs-6.5.
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    Brabi avatar 28.5.2006 22:37 Brabi | skóre: 8 | blog: Fiend's records | Praha
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Hmm, no já mám s GeForce2 MX 400 jen pod 280 FPS :-( . Ještě se na to zítra mrknu. Zatížení při glxgears mám 28%.
    Pets are always a great help in times of stress. And in times of starvation too, o'course.
    Vykook avatar 28.5.2006 14:27 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    gforce2 neni podporovany novejsima driverama. sice se nactou, ale neakcelerujou. ve FreeBSD to hodej i dmesq
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 14:40 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    podle zmíněné stránky se to týká GeForce2 modelů:
    GeForce2 GTS 
    GeForce2 Pro 
    GeForce2 Ti 
    GeForce2 Ultra 
    GeForce2 MX Integrated graphics
    zatímco na stránce Supported Products List nVidia uvádí:
    GeForce2 Go
    GeForce2 Integrated GPU
    GeForce2 MX 100/200
    GeForce2 MX/MX 400
    jak vidno, tyto seznamy jsou disjuktní, a moje karta je na tom seznamu podporovaných ...

    v dmesg nic relevantního nevidím :-/

    leč dík za tip, zkusím jít po starších verzích, jestli se to s něčím nerozběhne ... matně si ale vybavuju, že jsem musel upgradovat na nějaké 1.0.8xxx, protože starší si nerozuměli s novým kernelem, a tehdy to šlo (Gentoo mluví o 1.0.71xx jako poslední použitelné pro starší karty), vůbec netuším, kdy a proč to přestalo fungovat, prostě najednou jsem zjistil, že se mi sekají věci, které šly dřív hladce ...
    Vykook avatar 28.5.2006 16:38 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    aha. takze ty bidaci vyskrtnou zrovna gforce2 gts kterou mam.. :(
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 18:03 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    zkusím jít po starších verzích ...
    tak jsem se dostal k 7174 a stále to samé, teda vlastně jistý positivní efekt to mělo:
    $ glxgears
    3396 frames in 5.0 seconds = 679.200 FPS
    3457 frames in 5.0 seconds = 691.400 FPS
    3457 frames in 5.0 seconds = 691.400 FPS
    3461 frames in 5.0 seconds = 692.200 FPS
    (srovnej s hodnotami výše :-))
    28.5.2006 18:41 XMurder | skóre: 25 | blog: introvert
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Pravda, a to samý i ovladače pro Windows...
    28.5.2006 18:30 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    tak jsem si to ještě zkusil se softwarovou emulací ...

    s X.org driverem nv mi to házelo něco kolem 120 fps, ale zajímavější výsledek byl s nvidiáckým driverem:
    $ glxgears
    2598 frames in 5.0 seconds = 519.600 FPS
    2940 frames in 5.0 seconds = 588.000 FPS
    2940 frames in 5.0 seconds = 588.000 FPS
    ... takže prakticky totéž, co s "akcelerací"

    rozdíl je v tom, že čas trávený na cpu je se sw emulací pouze user, zatímco s hw "akcelerací" je to tak půl-napůl user+system

    tak já nevim :-/

    jaktože se všecko najednou trhá, nejde nahodit fulscreen na celý obraz (u torcs ani nejde změnit rozlišení) a za všech okolností (i jen při blbým zobrazení menu v gameskách) to žere 100% cpu, když dřív to chodilo hladce ...???

    jsem z toho zmaten, odpoledne v háji a výsledek žádný :-(
    Vykook avatar 28.5.2006 19:03 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    me ta gts haze 4780 frames in 5.0 seconds = 955.866 FPS 4914 frames in 5.0 seconds = 982.784 FPS 4560 frames in 5.0 seconds = 911.865 FPS

    se em nechce verit ze je mezi nima takovej rozdil
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 19:11 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    se em nechce verit ze je mezi nima takovej rozdil
    no mě taky ne, já si myslím, že je cosi shnilýho ...

    jak je to na tom systému s vytížením CPU?
    Vykook avatar 28.5.2006 19:38 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    cca 50% :( taky zadna slava. ale nemam nvidiackej agp modul

    jinak nejvetsiho framerate dosahnes kdyz to okno schovas ;-)
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 20:22 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    jinak nejvetsiho framerate dosahnes kdyz to okno schovas ;-)
    $ glxgears
    20854 frames in 5.0 seconds = 4170.800 FPS
    23211 frames in 5.0 seconds = 4642.200 FPS
    ;-)

    s tim agp modulem nevim, co myslíš, nicméně mpžnosti nastavení NvAGP jsem samozřejmě vyzkoušel všechny
    Vykook avatar 28.5.2006 21:39 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    ne to sem si rikal sam pro sebe. ze sem z kernelconfigu zapomel vyhodit agp takze se nemuze nalaodovat nvagp a mozna proto me to zere tech 50%

    Omluvte me ze pisu jak debil zejtra maturuju a sem "trosku" nervozni
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 22:04 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    nvagp už je obsolete, ne? (aspoň já v systému nic takovýho nemám ...)

    navíc bez podpory AGP by to naopak mělo mít vyšší režii a tudíž žrát víc (nebo ne?)

    p.s. matura je vo ničom ;-)
    28.5.2006 22:17 Radomír Fojtík | skóre: 33 | blog: jen to zkouším | Tísek
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    nvagp už je obsolete, ne? (aspoň já v systému nic takovýho nemám ...)
    Já o těch grafických kartách vím kulové, ale z xorg.confu:
    #Option "NvAGP" "0"     #agp vypnuto
    Option "NvAGP" "1"      #pouzije se interni podpora nVIDIA AGP
    #Option "NvAGP" "2"     #pouzije se agpgart je-li podporovano v jadre
    #Option "NvAGP" "3"     #pouzije se agpgart je-li podporovano v jadre, jinak nVIDIA AGP
    
    A xorg.log následně hlásí:
    (**) NVIDIA(0): Option "NvAGP" "1"
    (**) NVIDIA(0): Use of NVIDIA internal AGP requested
    (II) NVIDIA(0): Detected AGP rate: 4X
    To snad je OK, ne?
    28.5.2006 22:40 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    no, option v konfiguráku je jedna věc a modul je druhá věc ... pokud mě (opět) neklame paměť, tak v dobách dávných a pradávných se musel do jádra kromě modulu nvidia nahrát ještě modul agpgart nebo nějaký nvidiácký agp modul ... teď tu v jádře možnost, jestli chci zbuildit agpgart, nemám a nvidia si vystačí s jedním modulem

    - ty možnosti v konfiguráku xorg jsem dneska samozřejmě otestoval všechny
    28.5.2006 23:07 trekker.dk | skóre: 71
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Ten modul od nvidie pro AGP nemám a agpgart taky ne (přeložit by šel, ale nějak se s nvidia ovladačem nesnáší - nechce se zavést, i když agpgart odstraním rmmodem)

    Není podpora pro AGP nakonec zabudovaná přímo v tom nvidia modulu?
    Quando omni flunkus moritati
    28.5.2006 23:15 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Není podpora pro AGP nakonec zabudovaná přímo v tom nvidia modulu?
    já myslím že ano, protože když jsem zkoušel měnit ten parametr nvagp, stačil restart x-ek, nemusel jsem s modulama vůbec šachovat (přičemž dle logu se to tvářilo, že to používá)
    Vykook avatar 28.5.2006 23:18 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    je. ale ve freebsd je i podpora v kernelu ktera je defaultne pustena, a ta se tloukla s tim agp z nvidia.
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 18:36 Semo | skóre: 44 | blog: Semo
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Na GeForce2 GTS (pokial si dobre pamatam) je posledny driver 66xx.

    V Gentoo je ako posledny stable.
    If you hold a Unix shell up to your ear, you can you hear the C.
    Vykook avatar 28.5.2006 19:01 Vykook | skóre: 23 | blog: Tomas
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    predpokladam ze cislovani bsd a lin driveru bude stejny a ja pouzivam nvidia-driver-1.0.7174_3 kterej sice akceleruje, ale ma zrovna vadnou podporu composite. a starsi drivery zas behaj jenom s petkovou radou.
    Nejde nám o dobro druhých. Nejde nám o bohatství. Jde o čisté opojení mocí.
    28.5.2006 19:13 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    7174 se u mě chová stejně (blbě), navíc má tu pěknou vlastnost, že když se pokusím spustit nějakou opengl blbost pod rootem, tak slítne xserver ...
    28.5.2006 21:31 knizmi | skóre: 27 | blog: Blog | Kosmonosy
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Nak mi to nedava spat. Pokud nekomu bezi glxgears s 50% vytizenim procesoru nebo min, tak to chci taky :-) Jen me tak napadlo, na karte s PCI-E veci jako agpgart resit nemusim, ze?
    28.5.2006 21:58 doli
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Od určité doby (verze ovladače) mi taky přestala fungovat akcelerace s kartou GeForce2 MX400. Nakonec jsem to vyřešil tak, že jsem si koupil novější kartu GeForce FX 5200.
    28.5.2006 22:06 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    nojo, jenže já už zkusil downgradovat ovladače až do nejnižší verze, která ještě jde natáhnout do aktuálního jádra (2.6.16) a nic :-(

    btw, ta hláška, co to píše s příliš starejma ovladačema, je:
    nvidia: Unknown symbol remap_page_range
    nvidia: Unknown symbol pci_find_class
    ... třeba by se to dalo obejít? programátoři, kde jste? ;-)
    29.5.2006 08:41 Filip Jirsák | skóre: 66 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    29.5.2006 14:00 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    http://www.abclinuxu.cz/forum/show/133446
    stejný problém, ale žádné řešení
    http://www.abclinuxu.cz/forum/show/126985
    ne, to je něco jiného - zkompilovat to jde
    http://bugs.gentoo.org/show_bug.cgi?id=127618
    patche z tohoto threadu již v portage jsou, použití 6629 s kernelem 2.6.16 to neřeší

    ... další pokusy? ;-)
    29.5.2006 18:57 Filip Jirsák | skóre: 66 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    http://www.abclinuxu.cz/forum/show/133446

    stejný problém, ale žádné řešení
    Aspoň, že v tom nejste sám – to potěší, ne? ;-) Pamatoval jsem si, že jsem se ze dvou diskuzí zde na Abíčku dostal v řešení tohohle problému někam dál, ale má cesta k ovladačům asi byla touhle diskuzí jen volně inspirována, protože tam fakt žádné odkazy nejsou…
    ... další pokusy? ;-)
    Ještě jednou to zkusím ;-)

    http://forums.gentoo.org/viewtopic-p-3207570.html

    Z této diskuze vyplývá, že 6629 pod 2.6.16 podporována nebude, a že starší karty podporuje jako poslední 7174, který by měl pod 2.6.16 fungovat.
    30.5.2006 10:38 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    http://forums.gentoo.org/viewtopic-p-3207570.html

    Z této diskuze vyplývá, že 6629 pod 2.6.16 podporována nebude, a že starší karty podporuje jako poslední 7174, který by měl pod 2.6.16 fungovat.
    to vyplývá i z uvedeného odkazu na bugzillu (a lehce se to rozchází s Gentoo wiki) - ovšem viz výše :-/
    30.5.2006 16:02 Filip Jirsák | skóre: 66 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Už to radši zkoušet nebudu ;-) Já jsem naštěstí mohl upgradovat na 8xxx (mezipřistání na nějaké 7xxx také nedopadlo dobře). Holt nVidia :-(
    Jan Drábek avatar 29.5.2006 19:00 Jan Drábek | skóre: 41 | blog: Tartar | Brno
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Obecně nerad používám nvidia ovladače z gentoo portage tree. Téměř vždy jsem s nimy měl potíže (nenačtené moduly chyby v modulech atd.). Vzal bych originální od NVIDIE.
    01010010 01000101 01010000 01101100 01001001 00110010 01000100 01100101 01010110
    David Watzke avatar 30.5.2006 06:11 David Watzke | skóre: 74 | blog: Blog... | Praha
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    A Gentoo snad neinstaluje originální od nVIDIA? :-/
    “Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
    30.5.2006 10:40 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    no, některé ještě patchuje ... čímž se ovšem množina zkompilovatelných rozšiřuje ;-)
    30.5.2006 10:55 Hovadko
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Nazdarek :-),

    ja jsem se s necim podobnym pred nedavnem popral v ArchLinuxu. Nainstalil jsem nejnovejsi ovladace (nejaka 8xxx rada), ale s moji GeForce4 MX440 to ani nehnulo. Zkousel jsem si je sam zkompilovat, ale porad nic. Vsechno se tvarilo, jako ze akcelerace jede¨(logy, atd ...), ale kdyz jsem spoustel X-ka tak se mi zadna NVidiacka uvitaci obrazovka neobjevila. No a postupne jsem dosel k tomu, ze mam nainstaleny ovladace ze 7xxx rady a jede to v pohode.
    1.6.2006 08:05 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: nVidia GeForce2 MX400 - nejede akcelerace, ač formálně je vše ok
    Tak jsem upgradoval Xka na tom notebooku s i855GM a dospěl jsem ke svému původnímu názoru, že 100% CPU při glxgears tak úplně normální není ... hází mi to zátěž do 30% a píše:
    $ glxgears
    libGL warning: 3D driver claims to not support visual 0x23
    libGL warning: 3D driver claims to not support visual 0x25
    libGL warning: 3D driver claims to not support visual 0x27
    libGL warning: 3D driver claims to not support visual 0x29
    libGL warning: 3D driver claims to not support visual 0x2b
    libGL warning: 3D driver claims to not support visual 0x2d
    libGL warning: 3D driver claims to not support visual 0x2f
    libGL warning: 3D driver claims to not support visual 0x31
    1523 frames in 5.0 seconds = 304.531 FPS
    1981 frames in 5.0 seconds = 396.007 FPS
    2401 frames in 5.0 seconds = 480.146 FPS
    2397 frames in 5.0 seconds = 479.324 FPS
    1970 frames in 5.0 seconds = 393.868 FPS
    2429 frames in 5.0 seconds = 485.691 FPS
    2414 frames in 5.0 seconds = 482.791 FPS
    ...
    (přičemž jede úplně plynule, nerozhodilo ho ani chvilkové využití cpu jiným procesem, viz snížená hodnota na třetím řádku odspoda)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.