Apple představil nový iPad mini, iMac s čipem M6, 14palcový MacBook Pro s čipem M6 a MacBook Pro s PROLED XDR displejem – první Mac s dotykovým ovládáním.
Nedávno představený projekt mapSTL.com řeší budoucnost. 𝕏: "Netušil jsem, kolik patentů na generování map existuje. Existují patenty na generování fantasy map 🫣. Cokoliv je na 3D tiskárnu a tvoří to produkt, bude to mít patenty. Tak bacha na to!" … více »
Multiplatformní emulátor terminálu Ghostty byl vydán ve verzi 1.4 (𝕏). Přehled novinek a vylepšení v poznámkách k vydání.
Byla objevena zranitelnost Tailworm v Tailscale a Headscale umožňující lokální eskalaci práv přihlášeného uživatele. Následně byla v Tailscale v opravené verzi 1.104.4+ změněna architektura aplikace. Viz příspěvek na blogu Tailscale.
Byl vydán Mozilla Firefox 159.0. Přehled novinek v poznámkách k vydání a poznámkách k vydání pro vývojáře. Řešeny jsou rovněž bezpečnostní chyby. Nový Firefox 159 bude brzy k dispozici také na Flathubu a Snapcraftu.
Nasazení softwaru, který nyní používá ve svých autech pro čínský trh, zvažuje automobilový koncern Volkswagen také v Evropě, kde by se mohl používat v budoucích vozech značek Volkswagen, Škoda a Cupra. Základem pro budoucí evropské modely by se mohla stát takzvaná China Electronic Architecture, elektronická architektura vyvinutá pro čínské modely ve spolupráci s tamní automobilkou Xpeng.
Vedoucím brněnské pobočky Red Hatu se stal Radek Vokál [LinkedIn].
Open source download manager Fatrat povstal z popela. Autor k dvacetiletému výročí projektu přidal do vínku podporu nejnovější knihovny libtorrent, rozhraní portoval na QT6, došlo k nahrazení podpory java rozšíření pythonem. Webové rozhraní bylo přepsáno s podporou mobilních zařízení. Aplikaci je taktéž možno zkompilovat bez podpory GUI. Více informací v releases.
Zranitelnost Broccoli2Shell (CVE-2026-111497) v kompresní knihovně Brotli se netýká pouze Node.js. Ohroženy jsou také aplikace využívající HTTP. Knihovnu používají webové prohlížeče, servery i řada dalších aplikací a technologií, například také Python nebo Bun. Identifikace všech zranitelných komponent může být obtížná, protože knihovna bývá součástí dalších softwarových balíčků nebo je přímo začleněna do spustitelných souborů aplikací.
Quad9, švýcarský celosvětově působící neziskový poskytovatel DNS, od 24. listopadu 2026 ukončí své služby ve Francii kvůli soudnímu sporu s katarskou televizní stanicí beIN. Ta požadovala blokování domén, které podle ní nelegálně zpřístupňují sportovní přenosy. Francouzský soud Katarům vyhověl a nařídil (🇫🇷, PDF) Quad9 blokaci zavést, pod hrozbou pokuty 1000 eur denně. Provozovatel příkaz odmítá s tím, že blokace
… více »Do konference přišlo celkem 2320 emailů, nejvíce jich poslali "Martin J. Bligh", William Lee Irwin III, Andrew Morton.
William Lee Irwin III si myslel, že řada 2.5 si vede dobře, takže nastal čas přeřadit na vyšší otáčky a vykopnout řadu 2.6 ven. Zeptal se, které problémy zdržují tento proces. Dave Jones odpověděl, že je zde plno modulů, které nejdou zkompilovat, tuny neportovaného kódu od jádra 2.4.18 a spousty triviálních patchů, které se zratily cestou. Podle něj jsme od jádra '2.6-test' velmi vzdáleni, ale přechod na tvrdší zmražení kódu by byl dobrý nápad. Alan Cox napsal vlastní seznam:
IDE stále není v pořádku a oprava bude trvat aspoň tři měsíce, než vůbec můžeme začít s vylepšováním. Celé zamykání TTY je kompletně špatné a nikdo se ani nepokusil začít s jeho opravou. Prostě vyzkoušejte masivní paralelní aktivitu na tty/pty. Problémy byly už před tím, ale pre-empt jej zničil a pohřbil. Většina ovladačů není možné ani zkompilovat.
Podle mně je důležité dostat se do stavu, kdy můžeme říci:
Jinak si všichni budou myslet, že ".0-pre" znamená ".0 jako ve Windows", což by znamenalo ztrátu základny testerů.
Když vezmeme v úvahu, že nové věci je nutné začlenit, měl by Linus dostat dovnitř opravy z řady 2.4 a opravy chyb při kompilaci modulů a pokud by to nepomohlo, měl by být vyřazen.
Prosím, už žádné přepisy "ISAPnP TNG" a modulů
Ohledně posledního bodu panoval obecný souhlas a Jochen Friedrich přidal, že framebuffer je také smetí, stejně jako ISDN a (trochu méně) USB.
Trond Myklebust implementoval části RFC 2203 a oznámil:
Následujících šest patchů implementuje podporu bezpečnostního protokolu RPCSEC_GSS (pouze autentifikace) a bezpečnostního mechanismu Kerberos V5.
RPCSEC_GSS je bezpečnostní mechanismus vyžadovaný pro všechny implementace NFSv4. Poskytuje protokol pro bezpečné přihlášení a přenos dat na bázi pro jednotlivé uživatele. Funguje takovým způsobem, že nezávisí na aktuálně použitém bezpečnostním mechanismu, ale podporuje jich širokou řadu. Mechanismy požadované RFC 3010 pro NFSv4 jsou Kerberos V5 (viz RFC 1964), SPKM-3 (RFC2025) a LIPKEY (RFC2847).
Naší snahou je poskytnout základní kernelovou RPC klientskou podporu pro RPCSEC_GSS protokol a pro komunikaci s démonem, který provádí vlastní výměnu bezpečnostního kontextu s RPC serverem. Komunikace mezi kernelem a uživatelským prostorem se uskutečňuje skrze skupinu pojmenovaných rour [named pipe] v soukromém souborovém systému podobném ramfs.
Dax Kelson odpověděl:
Jako uživatel a administrátor jsem na toto čekal po DLOUHOU dobu. Standardní bezpečnost/autentizace NFS stojí za starou belu [sucks]. Bez této podpory NFS servery s domovskými adresáři jen čekají na vyloupení ze strany škodolibého (nebo kompromitovaného) roota na klientském počítači.
NFSv4 s RPSEC_GSS je konečně nativní unixovské řešení sdílení souborů, za které se nestydím při konverzaci s administrátory těch ostatních operačních systémů.
Paul Jakma poznamenal, že root z klienta může stále vyloupit server, ale Dax Kelson vysvětlil, že zlý root může s RPSEC_GSS přistupovat / měnit / mazat soubory na serveru jen uživatelům, kteří jsou na klientovi přihlášeni. Takže dobrým zvykem by mělo být odstranění cachovaných osobních údajů [credentials] při odhlášení. Trond však napsal, že pokud byl root kompromitován, hra skončila, takže je zbytečné se bát, co by mohl provést. Bezpečnostní model RPSEC_GSS není míněn jako ochrana před rootem, ale jako ochrana před třetí stranou podhazující RPC požadavky vašim jménem (silná autentifikace), poškozování či úpravě platných RPC požadavků (kryptografická kontrola integrity dat) nebo odposloucháváním komunikace mezi serverem a klientem (soukromí dat).
Russell King zjevně dostával příliš hodně emailů týkajících se TTY a měl toho dost. Vysvětlil:
Rád bych vyjasnil následující bod:
Nejsem, opakuji nejsem správce TTY subsystému. Mám příliš mnoho jiných povinnosti na to, abych se jim stal.
Nicméně, čas od času si prohlédnu patche z TTY vrstvy a poskytnu (doufám že) užitečný názor. Patche si však budu vybírat sám a bude to záležet na tom, čeho se týkají, jak jsou komplexní a jak moc jsem zaneprázdněn.
A pro úplnost, neposílejte mi žádné záplaty pro TTY.
Henrik Andersen se zeptal, zda je možné zkompilovat jádro překladačem C++ od Intelu. John Bradford o tom pochyboval, neboť Linux výrazně používá rozšíření GCC. Nicméně Jeff Garzik napsal, že zmíněný překladač funguje pěkně na jádru. Jun Nakajima to potvrdil. Ville Herva dodal, že Intel se snaží o maximální kompatibilitu s gcc.
Nástroje: Tisk bez diskuse
Tiskni
Sdílej: