abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 13:22 | Zajímavý projekt

Více než 60 moderních telefonů má díky práci týmu dobrovolníků SOMainline šanci na zařazení do oficiálního linuxového jádra. Patche pro podporu chipsetu SD630 a SD660, kterým jsou tyto telefony poháněny, jsou postupně začleňovány. Tým se soustředí na zprovoznění klasických linuxových distribucí pro telefony, ale věnuje se i zprovoznění běžného AOSP. Další tým vývojářů postmarketOS již delší dobu pracuje na podpoře chipsetu MSM8953, který umožňuje vdechnout život dalším nejméně 30 telefonům vydaných v letech 2017 a 2018.

David Heidelberg | Komentářů: 18
včera 08:00 | Komunita

Svobodný kancelářský balík LibreOffice slaví 10 let od svého vzniku. Projekt byl představen 28. září 2010.

Ladislav Hagara | Komentářů: 15
včera 07:00 | Pozvánky

Ve dnech 15. až 17. října 2020 se bude konat společná openSUSE + LibreOffice konference. Původně měla konference probíhat v Norimberku, ale vzhledem k situaci bude probíhat online. Konference již zveřejnila program. Naplánováno je několik desítek přednášek. Registrace a podrobnosti naleznete na stránce konference.

Zdeněk Crhonek | Komentářů: 1
27.9. 18:11 | Zajímavý software

SimulIDE je realtimový simulátor elektronických obvodů. Podporuje také PIC, AVR a Arduino. K dispozici je verze 0.4.13. Vývojáře lze podpořit na Patreonu.

Ladislav Hagara | Komentářů: 0
27.9. 14:11 | Nová verze

Virtual Machine Manager aneb virt-manager (Wikipedie), tj. GUI pro správu virtuálních strojů podporovaných knihovnou libvirt, byl vydán ve verzi 3.0.0. Přehled novinek v příspěvku na blogu. Zdůrazněna je nová volba --cloud-init.

Ladislav Hagara | Komentářů: 4
27.9. 11:11 | Zajímavý software

Vývojáři programovacího jazyka Swift na svém blogu oznámili, že společností Apple v červnu představená knihovna Swift System je již open source a byla do ní přidána podpora Linuxu. Jedná se o knihovnu poskytující idiomatická rozhraní k systémovým voláním.

Ladislav Hagara | Komentářů: 0
26.9. 15:11 | Nová verze

Byl vydán Debian 10.6, tj. šestá opravná verze Debianu 10 s kódovým názvem Buster. Řešeny jsou především bezpečnostní problémy, ale také několik vážných chyb. Instalační média Debianu 10 lze samozřejmě nadále k instalaci používat. Po instalaci stačí systém aktualizovat.

Ladislav Hagara | Komentářů: 1
25.9. 23:11 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě BLURtooth (CVE-2020-15802) v Bluetooth 4.2 a 5.0 v Cross-Transport Key Derivation (CTKD). Útočník může provádět MITM nebo navázat spojení s libovolným zařízením. Podrobnosti v článku (pdf).

Ladislav Hagara | Komentářů: 2
25.9. 21:44 | IT novinky

Byly zveřejněny informace o úniku zdrojových kódů Windows XP.

Ladislav Hagara | Komentářů: 34
25.9. 15:22 | Zajímavý projekt

Chcete proniknout do tajů gitu? Klikněte na Learn Git Branching. Vizuální a interaktivní tutoriál ve webovém prohlížeči.

Ladislav Hagara | Komentářů: 1
Používáte aplikaci eRouška?
 (19%)
 (3%)
 (2%)
 (12%)
 (50%)
 (8%)
 (6%)
Celkem 459 hlasů
 Komentářů: 35, poslední 20.9. 21:50
Rozcestník

Dotaz: Chyba při kompilaci Xorg 6.9

Zafod avatar 29.12.2005 10:08 Zafod | skóre: 17 | blog: Zafodovo | Praha
Chyba při kompilaci Xorg 6.9
Přečteno: 166×
Po přečtení několika oslavných blogpostů na nové Xorg jsem si je chtěl na svym Slackware 10.2 zkompilovat též. Vybral sem si verzi pojmenovanou 6.9, čili tu monolitickou, neb na 7.0 (neboli modulární) sem na stránkách Xorg nenašel návod k instalaci. Jenže jsem skončil u následující chyby, který popravdě moc nerozumim. GCC mám verze 3.3.6, kernel 2.6.13. Netusíte někdo, co se s tím má dělat? Díky
In file included from xf86Ur-98.c:12:
/usr/include/linux/joystick.h:131: error: syntax error before "__s64"
/usr/include/linux/joystick.h:135: error: syntax error before '}' token
In file included from xf86Ur-98.c:12:
/usr/include/linux/joystick.h:142:2: #error Unexpected BITS_PER_LONG
make[7]: *** [xf86Ur-98.o] Error 1
make[7]: Leaving directory `/home/lada/src/xorg-6.9/xc/programs/Xserver/hw/xfree86/input/ur98'
make[6]: *** [all] Error 2
make[6]: Leaving directory `/home/lada/src/xorg-6.9/xc/programs/Xserver/hw/xfree86/input'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/lada/src/xorg-6.9/xc/programs/Xserver/hw/xfree86'
make[4]: *** [hw/xfree86] Error 2
make[4]: Leaving directory `/home/lada/src/xorg-6.9/xc/programs/Xserver'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/lada/src/xorg-6.9/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/lada/src/xorg-6.9/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/home/lada/src/xorg-6.9/xc'
make: *** [World] Error 2

Odpovědi

stativ avatar 29.12.2005 10:18 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Zkus pouzit nejnovejsi linux-libc-headers, s temi to funguje takrka bez problemu (slackware 10.1->current)
Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
Zafod avatar 29.12.2005 10:22 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Díky, vyzkouším a dám vědět
Zafod avatar 29.12.2005 20:32 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
No tak sem dopadl jak sedláci u Chlumce. Anžto netuším, jakej konkrétní balík měl kolega na mysli, upgradeoval sem celý jádro i s headers na 2.6.14 ze slackware current. K tomu sem sem musel upgradeovat i alsu. Rovnou sem k tomu přihodil i gcc a glibc a všechny balíky který mají v názvu libc. Použil sem nástroj upgradepkg a dopad sem moooc špatně. Mám hodně malej disk, nemám ani vypalovačku, takže nemám jak a kam zálohovat. Postupně přestalo fungovat všechno od X po eth0, takže sem to celý přeinstaloval. Holt co neni v hlavě ... Nicméně by mě zajímalo, kterej balík měl kolega 6xx na mysli. Díky
David Watzke avatar 29.12.2005 20:36 David Watzke | skóre: 74 | blog: Blog... | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Upgrade glibc, gcc a všechno kolem libc a jsi ještě naživu? To nebyl moc rozumnej krok. Doporučil bych ti spíš Xorg 7.0, ale soudím, že podle toho, co se ti stalo se ti do toho už zřejmě nechce...
“Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
Zafod avatar 30.12.2005 12:19 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Ale jo chce, nerad se vzdávám. A chybama se člověl učí. Vybral sem 6.9, protože je u toho návod k instalaci. U 7.0 sem ho na webu xorg nenašel. A podle toho tam píšou se jedná o stejnej kód, jen je rozdíl v tom, že 7.0 je modularizovaná
29.12.2005 20:37 Libor Klepac | skóre: 45 | Mýto
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
nejspis balicek, ktery obsahuje soubory z adresare /usr/include/linux ...v debianu je to linux-kernel-headers
Urine should only be green if you're Mr. Spock.
David Watzke avatar 29.12.2005 20:37 David Watzke | skóre: 74 | blog: Blog... | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
A v Gentoo sys-kernel/linux-headers.
“Being honest may not get you a lot of friends but it’ll always get you the right ones” ―John Lennon
Zafod avatar 30.12.2005 12:35 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
A ve Slacku kernel-headers-cislo_verze_kernelu. A to sem tam samozrejme mel.
30.12.2005 13:19 Libor Klepac | skóre: 45 | Mýto
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
to asi bude neco jineho ... tohle co pisete slouzi ... napr. pro dokompilovavani modulu , ale tamto ... je neco jineho ;), tamten balicek se moc casto nemeni, je ozkousen s verzi glibc, co je v systemu ...etc
Urine should only be green if you're Mr. Spock.
Zafod avatar 1.1.2006 19:51 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Ja myslím, že je to ono. Ve Slacku tenhle nalík (kernel-headers) obsahuje právě soubory z /usr/include/linux.
stativ avatar 2.1.2006 10:40 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
No, tady jde hlavne o to ze v slacku je jeste verze pro 2.4, 2.6 include soubory jsou sice v extra, ale moc bych jim neveril. Jinak prece je to neco malicko jineho, tyhle jsou, jak psal "nadpsavec" mirne upravene. Ty ve slaku jsou v podstate jen prekopirovane ze zdrojaku kernelu.
ostatne viz. Tim ale nechci rikat, ze by ty "jen zkopirovane" nefungovali, pravdepodobne by take fungovali bez problemu, ale jitota je jistota.
Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
Zafod avatar 2.1.2006 15:12 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Díky za link. Neměl jsem o tomhle tušení. Nicméně teď to zkouším kompilovat znovu na defaultní instalaci Slacku 10.2. Dám pak vědět jak jsem dopadl
30.12.2005 13:23 Libor Klepac | skóre: 45 | Mýto
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
to asi bude neco jineho ... tohle co pisete slouzi ... napr. pro dokompilovavani modulu , ale tamto ... je neco jineho ;), tamten balicek se moc casto nemeni, je ozkousen s verzi glibc, co je v systemu ...etc
Urine should only be green if you're Mr. Spock.
stativ avatar 30.12.2005 11:19 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
myslel jsem toto
Nahradis tim ty predchazeci ze slacku a jedes. Sice tam pak taky nastane chyba ale tu je snadny na googlu najit.
Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
stativ avatar 30.12.2005 11:21 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
koukam, ze i s timto si google vi rady: odkaz
Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
Zafod avatar 3.1.2006 09:47 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Slíbil jsem, že napíšu jak jsem dopadl s kompilací na default instalaci Slackware 10.2 (opravné balíky mám samozřejmě nainstalované). Nejprve jsem zkoušel X11R7 a výsledek nebyl nijak valný. Při kompilaci vlastního xorg-server se na mě vysypala hromada errorů týkajích se xf86drm.c:
make[5]: Entering directory `/tmp/tarballs/everything/xorg-server-X11R7.0-1.0.1/hw/xfree86/os-support/drm'
.
.
.
In file included from xf86drm.c:88:
../../../../hw/xfree86/os-support/xf86drm.h:224: error: syntax error before "drm_context_t"
../../../../hw/xfree86/os-support/xf86drm.h:224: warning: no semicolon at end of struct or union
../../../../hw/xfree86/os-support/xf86drm.h:234: error: syntax error before '}' token
../../../../hw/xfree86/os-support/xf86drm.h:234: warning: type defaults to `int' in declaration of `drmDMAReq'
../../../../hw/xfree86/os-support/xf86drm.h:234: warning: type defaults to `int' in declaration of `drmDMAReqPtr
'
../../../../hw/xfree86/os-support/xf86drm.h:234: warning: data definition has no type or storage class
../../../../hw/xfree86/os-support/xf86drm.h:237: error: syntax error before "drm_handle_t"
../../../../hw/xfree86/os-support/xf86drm.h:237: warning: no semicolon at end of struct or union
../../../../hw/xfree86/os-support/xf86drm.h:241: error: syntax error before '}' token
../../../../hw/xfree86/os-support/xf86drm.h:241: warning: type defaults to `int' in declaration of `drmRegion'
../../../../hw/xfree86/os-support/xf86drm.h:241: warning: type defaults to `int' in declaration of `drmRegionPtr
Ten výpis je mnohem a mnohem delší, tohle bylo jen na ukázku. Kdyby náhodou měl někdo zájem o celej výpis, zašlu ho.

Teď ještě kompiluju X11R6.9, což by podle tvůrců měl být ten samý kód. Tak sem zvědav, jestli skončím na stejné chybě.
Zafod avatar 3.1.2006 16:55 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Tak sláva, verze 6.9. je zkompilovaná a zapakovaná do tgz balíku. Není mi úplně jasné, že se chyba ze 7.0 neopakovala (když se údajně jedná o stejnej kód). Nicméně jsem rád. Instalace proběhne večer. O tom už ale napíšu do blogu. Každopádně se prokázalo, že s kernel-headers-2.4.31-i386-1 X11R6.9 zkompilovat jde.

PS: pokus by o zkompilovaný balíky měl někdo zájem, dejte vědět, vystavím je na FTP
3.1.2006 18:01 Lukáš MATELA | skóre: 16
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Já se hlásím určitě. Zatím mi na NB jede Xorg pouze v režimu VESA, protože defaultní Xorg ve Slacku 10.2 neumí pracovat s grafikou i915 :-(. Tato nová verze to prý snad řeší.

Do kompilace jsem se ale pustit neodvážil.
Zafod avatar 3.1.2006 20:45 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Najdete to na ftp://212.65.242.44, user slack, pass balicky. Prectete si README, je to jen par radek.
Zafod avatar 4.1.2006 00:23 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Asi vas zklamu, ale nebezi mi to. Spoštění X skončí chybou:
Fatal server error:
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
Pravda nezkoušel jsem to na stroji, na kterym jsem to kompiloval, ale doma, kde mám kernel 2.6.13 z testing. Ovšem nevěřim, že to mělo něčemu vadit.
5.1.2006 12:08 Michal Kubeček | skóre: 71 | Luštěnice
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Spouštíte to s právy uživatele root?
Zafod avatar 5.1.2006 12:58 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
No jo, zda se, ze ste trefil hrebicek na hlavicku, ja to zabalil s pravama pro lada:users. Ale nechapu jak je to mozny, vzdycky menim pri vyrobe tgz baliku majitele na roota. Tak tohle mi hlava nebere. Kazdopadne diky za nakopnuti
Zafod avatar 5.1.2006 16:00 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Balík sem opravil a skončil na stejný chybě. Není mi souzeno. Počkám halt na Patricka
6.2.2006 16:53 Lukáš MATELA | skóre: 16
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Zdravím všechny,

podařilo se někomu zkompilovat nebo stáhnout zkompilované Xorg 6.9 pro Slackware?
Zafod avatar 6.2.2006 17:25 Zafod | skóre: 17 | blog: Zafodovo | Praha
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Už jsou ke stažení ve Slackware Current.
6.2.2006 17:28 Lukáš MATELA | skóre: 16
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Dík, už to vidím, špatně jsem hledal
6.2.2006 17:32 Jirka
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Jak jsem si tak precetl vase problemy, tak bych vrele doporucil Gentoo. Tam se take kompiluje a narozdil od Slackware to kompilovani funguje pokazde spravne ;o)
stativ avatar 6.2.2006 17:38 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
bych se hadal, nikdy v zivote jsem s kompilaci cehokoliv nemel na slacku problemy, a to mam zkompilovanou pulku systemu.
Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
29.10.2006 10:10 --==[FReeZ]==--
Rozbalit Rozbalit vše Re: Chyba při kompilaci Xorg 6.9
Pouzivam take SlackWare, zkousel jsem verze 10.1, 10.2 a nyni uzivam 11 final. Nemel jsi nikdy s kompilaci v Slackwaru problem? Pote Ti doporucuji pokusit se o zkompilovani GNOME z http://www.gnome.org/, nejde mi o to, zda pouzivas KDE, FluxBox, nebo treba Xfce. Ale poukazuji na fakt, ze GNOME byl s nejvetsi pravdepodobnosti vyrazen ze SlackWaru prave proto, ze cini obrovske problemy jej zkompilovat a ani DropLine GNOME a FreeRock GNOME se mi prilis neosvedcily (chybove hlasky pri spousteni Gnome-ICU spojene s GDK, atp.)

Zkratka ve SlackWare je vse standardni (napr. umisteni souboru dodrzuje KISS) a ve vetsich bastlech, jako je GNOME je vse nestandardni a tak to Slacku dela potize, myslim ze i Gentoo bude mit sve problemy. (GTK nebo X.org/X11 je problemove ve vetsine distribuci, nepocita se s tim, ze si user downloaduje nejnovejsi verze a chce si je hned po instalaci zkompilovat).

Ale kdo opravdu chce vse zkompilovat, tomu se to podari s libovolnym modernim distrem =)

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.