abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 04:44 | Komunita

    Byly vyhlášeny výsledky letošní volby vedoucího projektu Debian (DPL, Wikipedie). Novým vedoucím je Andreas Tille.

    Ladislav Hagara | Komentářů: 0
    dnes 00:11 | Nová verze

    Po osmi měsících vývoje byla vydána nová verze 0.12.0 programovacího jazyka Zig (GitHub, Wikipedie). Přispělo 268 vývojářů. Přehled novinek v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    včera 23:55 | Pozvánky

    Poslední měsíc byl plný zajímavých akcí, o kterých Vám bastlíři z projektu MacGyver mohou povědět, protože se na ně sami vydali. Kde všude byli, ptáte se? Objevili se na Installfestu, Arduino Day, Hackaday Europe a tajném srazu bastlířů z Twitteru. A z každé akce pro vás mají zajímavé poznatky.

    … více »
    bkralik | Komentářů: 0
    včera 11:44 | IT novinky

    Mezinárodní nezisková organizace Women Who Code (WWCode, Wikipedie) založena v roce 2011 s cílem usnadnit ženám vstup do světa informačních technologií nečekaně skončila. Došly finance.

    Ladislav Hagara | Komentářů: 7
    19.4. 18:00 | IT novinky

    DuckDuckGo AI Chat umožňuje "pokecat si" s GPT-3.5 Turbo od OpenAI nebo Claude 1.2 Instant od Anthropic. Bez vytváření účtu. Všechny chaty jsou soukromé. DuckDuckGo je neukládá ani nepoužívá k trénování modelů umělé inteligence.

    Ladislav Hagara | Komentářů: 1
    19.4. 14:22 | IT novinky

    VASA-1, výzkumný projekt Microsoftu. Na vstupu stačí jediná fotka a zvukový záznam. Na výstupu je dokonalá mluvící nebo zpívající hlava. Prý si technologii nechá jenom pro sebe. Žádné demo, API nebo placená služba. Zatím.

    Ladislav Hagara | Komentářů: 6
    19.4. 04:44 | Nová verze

    Nová čísla časopisů od nakladatelství Raspberry Pi: MagPi 140 (pdf) a HackSpace 77 (pdf).

    Ladislav Hagara | Komentářů: 0
    19.4. 01:00 | Nová verze

    ESPHome, tj. open source systém umožňující nastavovat zařízení s čipy ESP (i dalšími) pomocí konfiguračních souborů a připojit je do domácí automatizace, například do Home Assistantu, byl vydán ve verzi 2024.4.0.

    Ladislav Hagara | Komentářů: 0
    18.4. 22:11 | IT novinky Ladislav Hagara | Komentářů: 0
    18.4. 20:55 | Nová verze

    Neziskové průmyslové konsorcium Khronos Group vydalo verzi 1.1 specifikace OpenXR (Wikipedie), tj. standardu specifikujícího přístup k platformám a zařízením pro XR, tj. platformám a zařízením pro AR (rozšířenou realitu) a VR (virtuální realitu). Do základu se z rozšíření dostalo XR_EXT_local_floor. Společnost Collabora implementuje novou verzi specifikace do platformy Monado, tj. open source implementace OpenXR.

    Ladislav Hagara | Komentářů: 4
    KDE Plasma 6
     (68%)
     (11%)
     (2%)
     (19%)
    Celkem 582 hlasů
     Komentářů: 4, poslední 6.4. 15:51
    Rozcestník

    Dotaz: X.org "nenajede" uplne

    Ku8aZ avatar 18.2.2005 22:51 Ku8aZ | skóre: 17
    X.org "nenajede" uplne
    Přečteno: 168×
    Vim, ze je jako problem hned o vlakno niz, ale nikdo tam nesdelil zadnou konstruktivni odpoved, navic je ten problem trosku jiny. Takze:

    OS: Gentoo, cerstve kompilovane podle navodu. Zkompiloval jsem posledni xorg-x11-6.8.2 a zkusil je spustit. Nakopiroval jsem tam konfiguraky z predchozi (funkcni) instalace a zkusil spustit. Xka nabehla, ale jen do cerne obrazovky s kurzorem. Zadna chyba, v logu vubec nic. Ve /var/log/messages jsem potom zjistit neco na zpusob
    Unknown PAM_UNIT: <DISPLAY>
    Unknown PAM_UNIT: <XAUTHORIZATION>
    
    Po kratke konzultaci s clovekem znalym mi poradil, ze na desktop s jednim uzivatelem PAM nepotrebuju, tak jsem vse prekompiloval bez jeho podpory a.....porad nic!! :-( Nevite kde hledat chybu? V konzoli to vypada asi takto:
    # echo $DISPLAY
    
    # echo $XAUTHORIZATION
    
    
    takze to vypada, ze nejsou ty promenne vubec nastavene. Ta chyba s PAM na me vybafla hned pri prvnim nalogovani do zakladniho systemu, takze mi to tam asi neco nahlodalo a ja ted nevim co. Nereaguje vubec nic...xinit, X, startx....porad stejny vysledek. Po startx se mi Fluxbox spousti (vidim to podle logovacich vypisu z jeho spousteciho souboru), ale nespusti se vlastni WM.

    Jsem z toho blazen, necham si poradit od zkusenejsich :-)
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz

    Odpovědi

    18.2.2005 23:48 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Pokud je černá obrazovka s kurzorem tak asi X ka běží no a teď v nich musíte něco spustit tj nějakej WM :-)

    Takže ten fluxbox zapíše co do svého logu ? Spustite exec /usr/X11R6/bin/fluxbox -log ~/.fluxbox/log :-)
    Ku8aZ avatar 18.2.2005 23:54 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Blbej zase nejsem :-D v .xinitrc mam
    exec startfluxbox
    a v jeho startovacim souboru mam par aplikaci (vsechny jsou samozrejme nainstalovane!) a nakonec to
    exec fluxbox -log ~/.fluxbox/fluxbox-log
    Jak rikam, ten soubor jsem ladil a az po spusteni FB se vse provedlo. Ale vypada to, ze ty X proste nemaji rady zadny WM :-(

    A netvrdte mi, ze to znamena, ze je dobre nakonfigurovany X server. Ten dobre nakonfigurovany je, to ja vim. Ale proste nespousti zadny WM, ani twm!
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz
    Ku8aZ avatar 18.2.2005 23:58 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Fluxbox nema v logu NIC! Rekl bych, ze to bude mit nejakou souvislost s tou promennou DISPLAY a XAUTHORITY. Nebo pred spustenim X tyto promenne nastavene nejsou? :-/
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz
    19.2.2005 00:03 Michal Marek (twofish) | skóre: 55 | blog: { display: blog; } | Praha
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Ty proměnné nastavuje xinit, .xinitrc je za normálních okolností zdědí. Před startem X nastavené nejsou.
    19.2.2005 00:06 xkesh | skóre: 46 | blog: eXtempore
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    zkus si zakomentovat radky v
    /etc/security/pam_env.conf
    
    ktere se tykaji DISPLAY i XAUTHORIZATION
    19.2.2005 00:13 xkesh | skóre: 46 | blog: eXtempore
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    XAUTHORITY, sorry ... vubec, zakomentuj tam vsecko :)
    Ku8aZ avatar 19.2.2005 00:25 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Bohuzel, tohle nepujde...jak uz jsem napsal, vse je zkompilovano bez podpory PAM a PAM jsem unmergnul do vecnych lovist... Ted jsem taky zjistil, ze jsou ty promenne nastavovany az potom. A ve velice ukecanem logu se mi objevovalo toto:
    select returned 1
    select returned 1
    select returned 1
    ...
    
    a to az do doby, nez jsem ten server ukoncil. A zere obcas 100% vykonu procesoru, takze to vypada, ze tam neco hnije...ale co?! Porovnaval jsem to s funkci konfiguraci a vypadalo to stejne. Tak ted zkousim kompilovat starsi verzi (6.8.0), ale moc neverim, ze by to dopadlo jinak :-( Sakra, ja chci pokracovat v instalaci systemu a ne si hrat s takovou debilni chybou!!!
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz
    19.2.2005 00:36 xkesh | skóre: 46 | blog: eXtempore
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    a.....porad nic!!
    Nejak jsi nenapsal, co ti to pise v logu pote, co jsi odhodil podporu pam. co jsem psal, se tyka te hlasky, cos vypsal. pricin, proc nenabehnout Xka, muze byt spousta, napr. spatne nastavena frekvence monitoru v xorg.conf... kristalovou kouli nemam ;)
    Ku8aZ avatar 19.2.2005 00:45 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    kristalovou kouli nemam ;)
    Ocenuji tvou pomoc, ale precti si to prosim poradne:
  • konfigurace je spravna - overena, fungovala pred naformatovanim disku bez jedineho steku
  • X do logu nezapisou vubec nic (krome nejakych (WW) o spatne ceste k nejakym fontum, ale to psalo vzdycky, tim to nebude). Jen pri vyssim verbose je tam vyse uvedene
    select returned 1
    nez to tipnu
  • zmena oproti PAM je ta, ze mi to pouze nepise vyse zminenou chybu po startu do logu
  • a Xka nabehnou!! Ale potom nic jineho...WM, programy...proste nic :-(
  • Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz
    19.2.2005 01:24 xkesh | skóre: 46 | blog: eXtempore
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    co graficka karta, posledni ovladac nvidia-kernel je tak trochu buggy, psal jsem to na gentoo.cz ... nejlip kdyz seberes svoje udaje (xorg verze, graficka karta, ovladace, chybovou hlasku...) a zahledas na forums.gentoo.org? Taky bych to mohl udelat, ale jednak netusim, co mas za sestavu a jednak mam lepsi veci na praci :)

    ten problem s PAM jsem mel taky, s timhle treba pomuze nekdo jinej ... ale doporucuju sem pripadne napsat vic konkretnich udaju, takhle je to tapani v mlze.
    19.2.2005 02:04 lada
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    presne tohle mi xorgy delaly taky, pomohl az jedine downgrade nvidia-kernel a nvidia-glx na verze -6111-r1. s touto verzi driveru mi vse bezi ok. mnoho zdaru !!
    19.2.2005 10:43 misterlister | skóre: 12 | blog: aiyyo
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Ahoj,

    měl jsem podobný problém - totiž že Xka (XFree86 i X.org) naběhla, ale objevila se pouze černá obrazovka. Na vině byl špatný ovladač NVIDIA. Bohužel nepíšete nic o verzi jádra a Vaší grafické kartě, nicméně u mě to byl problém s jádrem 2.6.10 a ovladačem 6629. Pomohlo až toto. A co se PAMu týče, nemyslím, že si s ním musíte lámat hlavu:
    Feb 19 10:26:22 [PAM-env] Unknown PAM_ITEM: <DISPLAY>
    Feb 19 10:26:22 [su] PAM pam_putenv: delete non-existent entry; DISPLAY
    Feb 19 10:26:22 [PAM-env] Unknown PAM_ITEM: <XAUTHORITY>
    
    ;-)
    Ku8aZ avatar 19.2.2005 11:29 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    Diky za podnetne navrhy, ale... mam Radeon :-) Presne Radeon M9 (Mobility 9000). Uz i dokonce vim, cim je chyba zpusobena. Zkoumal jsem, co se vse zmenilo od predchozi instalace a prisel jsem na to, ze jsem menil i kodovani, takze ted misto ISO8859-2 pouzivam UTF-8. A to nejak Xka nedokazou zkousnout...a nevim proc :-(

    Pokud je spustim jako
    LC_ALL=cs_CZ.ISO8859-2 startx
    nabehnout uplne v pohode, ale pokud je to UTF-8, delaji vyse zminenou chybu. Nevite nekdo, v cem muze byt zakopany pes? Font v xtermu? Nebo nejaky globalni font v X? Jak se to sakra nastavuje? TTF a Type1 fonty mam nakonfigurovane a kdyz pouziju font-server, zadna zmena...s fonty moc zkusenosti nemam :-(

    Nejlepe bych prosil popsat nastaveni UTF8 prostredi v Xkach jak pro blbce, abych to pochopil :-D;-)
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz
    19.2.2005 13:17 xkesh | skóre: 46 | blog: eXtempore
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    jo, to jsou ty "presne stejne konfigurace", to uz znam :P

    nebude mit problem spis Fluxbox nez Xka? viz

    http://gentoo-wiki.com/HOWTO_Make_your_system_use_unicode/utf-8 http://fluxmod.berlios.de/modules.php?name=News&file=article&sid=11

    Pro zajimavost, hledals vubec nekde? :)
    Ku8aZ avatar 19.2.2005 13:34 Ku8aZ | skóre: 17
    Rozbalit Rozbalit vše Re: X.org "nenajede" uplne
    No dobre, konfigurace je jina, ale systemu, Xka maji stejnou :-D :-P

    Fluxbox mam vyreseny, stacil flag disablexmb, tak to uz jsem prisel (nasel to - ano hledam, jako o zivot ;-)), ale spis mi vadi, ze mi nenabiha jiny WM (napr i ten pitomy twm). Takze by to chtelo osefovat nejak univerzalne...

    Na gentoo-wiki jsem se taky dival, skoro vsechno z toho uz jsem mel udelane. BTW, je promenna
    UNICODE="yes"
    jen pro konzoli, nebo to ovlivnuje i ostatni terminaly a musi se to osetrit jako v gentoo-wiki?
    Čeho se vlastně člověk bojí, když se bojí tmy...? jabber: ku8az AT jabbim.cz

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.