Byla vydána OpenIndiana 2026.10. Unixový operační systém OpenIndiana (Wikipedie) vychází z OpenSolarisu (Wikipedie).
Americký výrobce polovodičů onsemi (ON Semiconductor) zrušil plány na rozšíření výroby v rožnovském závodě v Česku za dvě miliardy dolarů (podle aktuálního kurzu zhruba 43,5 mld. Kč). Důvodem je vývoj na trhu.
O víkendu probíhá na FIT VUT v Brně konference OpenAlt 2026 o otevřeném softwaru a datech, IT bezpečnosti, DIY a IoT. Na programu je spousta zajímavých přednášek. Pokud jste v Brně, stavte se. Vstup zdarma. Přednášky lze sledovat i online na VHSky a YouTube.
Qualcomm uzavřel víceletou dohodu se SpaceX. Bude dodávat rádiové technologie, baseband jednotky a software pro plánovanou pozemní 5G síť Starlink Mobile. Výstavba má zahrnovat desítky tisíc základnových stanic v USA. Zahájení nasazování se očekává v roce 2027. Qualcomm dohodu označuje za svůj dosud největší 5G kontrakt.
Google rozšířil Cloud Vulnerability Reward Program. Nově nabízí odměnu až 250 tisíc dolarů za vysoce závažné architektonické bezpečnostní chyby označované jako Root-in-Cloud.
V březnu byla oznámena spolupráce GrapheneOS s Motorolou. Nejnovější vlajka Motorola Signature 27 je první Motorola s oficiální podporou GrapheneOS. GrapheneOS (Wikpedie) je varianta Androidu zaměřující se na bezpečnost a soukromí.
Omarchy (Wikipedie) je linuxová distribuce s dlaždicovým správcem oken Hyprland. Založena je na Arch Linuxu. Vydána byla v nové verzi 4.5.0. Nově také pro Apple Silicon, konkrétně pro M1/M2/M3/Neo MacBooky.
Byla vydána nová stabilní verze 8.3 webového prohlížeče Vivaldi (Wikipedie). Postavena je na Chromiu 156 s bezpečnostními opravami z Chromia 157. Přehled novinek i s náhledy v příspěvku na blogu.
).
Když se to tak vezme, je tenhle komentář k ničemu, ale třeba to nahlodá ty požadavky na technické řešení (-li nejsou dány hostingem, třeba).
Má to koukam i šablony, fajn.
Když si člověk hraje měsíc s Javou, tak se ani není čemu divit
Uz mam hotovo SCM
Parser mám rozdělený na dvě části. Blokový, který bere text řádku po řádce a formou stavového automatu řeší nadpisy, odstavce, seznamy a další blokové elementy a pak na řádku zavolá řádkový parser, který řeší řádkové elementy, jako zvýraznění, odkazy apod. Ten je mixem str_replace, ereg_replace a preg_replace_callback, přičemž zejména poslední fukce je hodně užitečná a doporučuji prostudovat.
Nahrazovací funkce s regexy jsou pro tento účel asi nejlepší řešení, to je pravda.
Druhá možnost je UTF-8, jako v MediaWiki (viz třeba Wikipedia: Čeština), ale to vede ke spoustě problémů, zjm. ve Firefoxu.hm, a bugy ve Firefoxu jsou pro výběr systému nějak extrémně důležité?
href a odkaz opět v některých prohlížečích nefunguje.
Diakritika prostě do URL adres (až na pár výjimek) nepatří, je s tím víc starostí než užitku.
Podle RFC 1738 všechny divnoznaky musí být v URL zakódované. Nijak se ale neřeší kódování znaků, pouze kódování oktetů.v současnosti (resp. pro HTTP 1.1) platí RFC 2396 (které vychází z 1738 a 1808), a to se v otázce kódování odkazuje na RFC 2277 RFC 2277 v sekci 3.1 říká, že "Protocols MUST be able to use the UTF-8 charset" a dále "Protocols MAY specify, in addition, how to use other charsets or other character encoding schemes for ISO 10646, such as UTF-16, but lack of an ability to use UTF-8 is a violation of this policy;" - a jelikož jsem v RFC 2616 (HTTP 1.1) nenašel žádnou specifikaci "how to use other charsets" týkající se URI, vyvozuji z toho, že se smí užívat pouze UTF-8
Jde o to, že když v Opeře napíšete example.org/žščř, tak se to odešle v UTF-8, ale ve Firefoxu v Latin1.za prvé, používá-li Firefox HTTP 1.1, pak musí zvládat UTF-8, za druhé, neurčí-li Firefox, že je v URI použito něco jiného, než UTF-8 (což nemůže, neboť mu k tomu RFC 2616 nedává prostředky, AFAIK), pak použití Latin1 je v rozporu s RFC 2396 (via RFC 2277)
Diakritika prostě do URL adres (až na pár výjimek) nepatří, je s tím víc starostí než užitku.kolikrát jsme už něco takového slyšeli? (nemám odkazovat na blogy a flejmy zde, že?
)
IMHO jediná věc (v současných URI), která by měla být omezena na ASCII, jsou doménová jména, neboť tam nejde o problém technický nýbrž obchodní (registrace domény firmy v miliónu různých variant včetně různých záměn podobně vypadajících znaků - už takhle je dost problémů typu mojefirma.cz vs. moje-firma.cz a se spekulanty registrujícími všemožné varianty překlepů kolem slavných domén ...)
Wordpress mi přišel příliš blogocentrický a já na stránkách blogovat neplánuju.
Tiskni
Sdílej: