abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 18:11 | Zajímavý článek

Společnost PINE64 stojící za telefonem PinePhone, notebooky Pinebook a Pinebook Pro, IP kamerou PineCube, hodinkami PineTime, páječkou (pájecím perem) Pinecil, zdroji PinePower nebo RISC-V vývojovou deskou PineCone publikovala na svém blogu dubnový souhrn novinek.

Ladislav Hagara | Komentářů: 0
dnes 12:22 | Nová verze

Laboratoře CZ.NIC vydaly novou verzi 4.17.0 aplikace Datovka, tj. svobodné multiplatformní desktopové aplikace pro přístup k datovým schránkám a k trvalému uchovávání datových zpráv v lokální databázi. Z novinek lze zdůraznit například přidání podpory pro typy datových schránek soudních znalců, tlumočníků a překladatelů, které mají být do produkčního prostředí zavedeny v průběhu května 2021.

Ladislav Hagara | Komentářů: 3
dnes 12:00 | Zajímavý článek

V příspěvku Rust v linuxovém jádru na blogu Googlu věnovaném počítačové bezpečnosti se řeší podpora programovacího jazyka Rust pro psaní ovladačů linuxového jádra. Připraven je prototyp. Dění kolem Rustu v Linuxu lze sledovat na GitHubu (Rust for Linux).

Ladislav Hagara | Komentářů: 5
dnes 09:00 | Nová verze

Po půl roce vývoje od vydání verze 11.0.0 byla vydána verze 12.0.0 překladačové infrastruktury LLVM (Wikipedie). Přehled novinek v poznámkách k vydání: LLVM, Clang, Extra Clang Tools, Flang, LLD, Polly a Libc++.

Ladislav Hagara | Komentářů: 0
dnes 09:00 | Komunita

Byl oznámen vznik nové organizace GNU Assembly zastřešující správce a přispěvatele do GNU softwaru. GNU zde ale neznamená GNU (GNU's Not Unix) ale "Gathering under a New Umbrella", "Governance, Not Unilateralism", "Group’s Not Uniform", "GNU’s Novelty is Unequaled" a "GNU Needs U". Organizace má již svůj GNU Social Contract a Contributor Covenant Code of Conduct.

Ladislav Hagara | Komentářů: 14
dnes 07:00 | Pozvánky

Spolek OpenAlt zve příznivce otevřených řešení a přístupu na 192. sraz, který proběhne virtuálně dnes 16. dubna od 18:00 na Meet.vpsFree.cz.

Ladislav Hagara | Komentářů: 0
včera 21:55 | Nová verze

Bylo vydáno minimalistické desktopové prostředí LXQt ve verzi 0.17.0. Nově ukončuje procesy-potomky na konci sezení. Přidává menší funkce a opravy napříč komponentami (panel, správa napájení) a aplikacemi (emulátor terminálu, správce souborů aj.).

Fluttershy, yay! | Komentářů: 1
včera 17:11 | Zajímavý projekt

Na Kickstarteru běží kampaň na podporu USB RTC pro Raspberry Pi aneb hodiny reálného času (nejenom) pro Raspberry Pi připojitelné přes USB.

Ladislav Hagara | Komentářů: 5
včera 16:00 | Nová verze

Google Chrome 90 byl prohlášen za stabilní. Nejnovější stabilní verze 90.0.4430.72 přináší řadu oprav a vylepšení (YouTube, Pete LePage z devadesátek :-)). Zdůraznit lze použití HTTPS jako výchozího protokolu při nezadání protokolu. Vylepšeny byly také nástroje pro vývojáře (YouTube). Opraveno bylo 37 bezpečnostních chyb.

Ladislav Hagara | Komentářů: 0
14.4. 11:00 | Zajímavý projekt

Björn Ståhl představil desktopové prostředí Pipeworld postavené na Arcanu, tj. na jeho vlastním display serveru, herním enginu a realtimovém multimediálním frameworku v jednom. Videoukázka na YouTube.

Ladislav Hagara | Komentářů: 6
Kolik času v průměru denně trávíte videohovory/-konferencemi? (ať už v práci, škole nebo soukromě)
 (52%)
 (13%)
 (15%)
 (11%)
 (7%)
 (1%)
 (1%)
Celkem 342 hlasů
 Komentářů: 7, poslední 8.4. 12:14
Rozcestník

Ano, uznávám, pomalu, ale jistě to na mém blogu vyhnívá... hlavně kvůli nedostatku času a nápadů, co si budeme povídat :-/ No a jelikož se většina mých zápisků v poslední době čím dál tím více odchylovala od zaměření ABC Linuxu, rozhodl jsem se založit tématicky volný blog Letters from Earth, na který jsem zároveň přesunul zápisky odsud za poslední půlrok.

FuxBlog budiž tedy nadále ryze technickým blogem se zaměřením na IT. Snad na něj budu mít čas...

Aktuální zápisy

ANSYS Electronics Desktop 2021R1 na nepodporované distribuci

3.2. 15:15 | Přečteno: 1343× | Linuxení aneb hrátky se šrotem | poslední úprava: 9.4. 11:50

Mezi jeden z mála hnusných a ošklivých kousků proprietárního software, na kterých jsem bohužel závislý je ANSYS Electronics Desktop. Ten samozřejmě používám na svém oblíbeném Debianu, ostatně kdo se kdy pokoušel počítat nějakou náročnější úlohu asi ví, že MS Windows se na to hodí asi jako Trabant pro transatlantické lety. Po poměrně dlouhou dobu fungoval můj starý návod na zprovoznění tohoto molochu na Debianu, což se ale s příchodem Debianu 10 a novými verzemi ANSYSu změnilo. Zde je tedy aktualizace.

Kde je zakopaný pes?

Celý problém ANSYS Electronics Desktopu je ten, že je to příšerný bastl, který používá směs různých knihoven k tomu, aby vůbec na Linuxu fungoval. Výpočetní jádro je zřejmě nativní, ale pro běh grafického prostření se jako klíčový používá MainWin 5.40 (to je taková hrozně fosilní záležitost na úrovni WINE, kterou vyvinula za pomoci originálních zdrojových kódů Windows společnost MainSoft), který je doplněn o nějaké knihovny z Qt, Tcl/Tk a pár dalších závislostí. Silnějším povahám, zatímco ty slabší tiše zvrací v koutku, je jasné, že tohle rozpohybovat na Linuxu není úplně legrace, takže ANSYS podporuje oficiálně pouze dvě distribuce - SLES a RHEL.

Pomyslnou korunkou na hlavě mixu knihoven a prostředí ANSYS Electronics Desktopu je pak instalátor napsaný v Javě, který byl příčinou toho, proč dlouhou dobu nebylo možné na Debianu 10 ANSYS Electronics Desktop vůbec nainstalovat. ANSYS totiž využíval jakousi prehistorickou verzi Javy (tuším 1.5.0u01), která na nových jádrech segfaultovala. No a jelikož instalátor má názvy souborů k instalaci poctivě zahashované, tak ruční instalace nepřicházela v úvahu. To se změnilo až s verzí 2020R2, ve které došlo k aktualizaci Javy, kterou si vynutila aktualizace jádra v RHEL/SLES. Na obranu ANSYSu je ale třeba dodat, že Javovský InstallShield na Linuxu používá více proprietárních programů (Matlab, Amesim...).

Co budeme potřebovat...

Jako první bude třeba najít relikvie dvou knihoven - xorg-x11-libXfixes-7.6_5.0-3.1.2.x86_64.rpm a xorg-x11-libXrender-7.6_0.9.6-9.1.2.x86_64.rpm. Ty se naštěstí ještě stále válejí na netu, takže není problém je stáhnout (třeba odtud). A pokud si myslíte, že vidíte špatně, pak ne. Opravdu jde o knihovny z roku 2011...

Druhá věc vyžaduje sáhnout si do archivů. Bude totiž třeba mít po ruce starší instalaci ANSYS Electronics Desktopu a ANSYSu jako takového. Z ANSYS Electronics Desktopu použijeme starší verzi MainWinu a z ANSYSu si vypůjčíme libGL.so.

Postup zprovoznění

  1. Nejprve musíme z Debiana udělat RHEL 7. To provedeme snadno pod rootem za pomoci:
    apt-get install rpm
    echo "Red Hat Enterprise Linux Server release 7.6 (Maipo)" > /etc/redhat-release
    
  2. Nyní můžeme ANSYS Electronics Desktop začít instalovat. Stejně jako dříve je třeba po rozbalení instalačního archivu smazat (přejmenovat) adresář /Linux/lib64. Instalaci pak následně spustíme v adresáři /Linux příkazem ./install.exe :-), načež by se mělo objevit hlavní menu instalátoru. Vše je grafické s romanticky modrým nádechem.
  3. V dalším kroku doplníme nezbytné knihovny - z obou stažených balíčků je třeba vyextrahovat soubory
    libXfixes.so.3 (symlink)
    libXfixes.so.3.1
    libXrender.so.1 (symlink)
    libXrender.so.1.3.0
    
    a ty nakopírovat do adresáře /opt/AnsysEM/AnsysEM21.1/Linux64/defer/. V témže adresáři je třeba smazat (přejmenovat) soubor libGL.so.1.2 a ten nahradit knihovnou z klasického ANSYSu, která bývá umístěna například zde: /opt/ansys162/v162/Framework/bin/Linux64/Mesa/libGL.so.1.5.070701, kterou zkopírujeme a přejmenujeme na libGL.so.1.2. Kontrolu nám zde poskytne velikost souboru - nahrazujeme knihovnu o velikosci cca 730 kB knihovnou o velikosti cca 14,5 MB. Poslední knihovna, kterou potřebujeme je libpng12.so.0, kterou si pořídíme jednoduše jako symlink na systémovou libpng16.so.16.36.0 (klidně přímo v /usr/lib/x86_64-linux-gnu/).
  4. Jako poslední je třeba nahradit dodávaný MainWin 5.40 za jeho starší verzi. V mém případě jsem použil nejbližší možnou, kterou jsem měl zprovozněnou na jiném stroji - z ANSYSu 2019R3.7, která je umístěna v /opt/AnsysEM/AnsysEM19.5/Linux64/mainwin540/. Tzn. smažeme (přejmenujeme) složku /opt/AnsysEM/AnsysEM21.1/Linux64/mainwin540/ a místo ní nakopírujeme složku /opt/AnsysEM/AnsysEM19.5/Linux64/mainwin540/. Při pozornějším zkoumání si přitom můžeme všimnout, že jediný rozdíl je aktualizace několika knihoven, jinak všechny ostatní mají shodný původ v roce 2015.

Frčíme

Nyní nám již stačí skočit do /opt/AnsysEM/AnsysEM21.1/Linux64/, zde spustit ./ansysedt a po trochu delším prvním spuštění (které obsahuje nějaké dodatečné konfigurace a kontrolu přítomných knihoven) a tradičních chybových hláškách

pushkin@pushkin-workntb:/opt/AnsysEM/AnsysEM21.1/Linux64$ ./ansysedt
### Warning: Dependency package bzip2-libs is not installed.
### Warning: Dependency package expat is not installed.
### Warning: Dependency package fontconfig is not installed.
### Warning: Dependency package freetype is not installed.
### Warning: Dependency package giflib is not installed.
### Warning: Dependency package glib2 is not installed.
### Warning: Dependency package glibc is not installed.
### Warning: Dependency package libdrm is not installed.
### Warning: One of the following alternate dependencies are not installed: libjpeg libjpeg-turbo
### Warning: Dependency package libpng is not installed.
### Warning: Dependency package libselinux is not installed.
### Warning: Dependency package libtiff is not installed.
### Warning: Dependency package libX11 is not installed.
### Warning: Dependency package libXau is not installed.
### Warning: Dependency package libxcb is not installed.
### Warning: Dependency package libXdamage is not installed.
### Warning: Dependency package libXext is not installed.
### Warning: Dependency package libXfixes is not installed.
### Warning: Dependency package libXft is not installed.
### Warning: Dependency package libXmu is not installed.
### Warning: Dependency package libXp is not installed.
### Warning: Dependency package libXrender is not installed.
### Warning: Dependency package libXt is not installed.
### Warning: Dependency package libXxf86vm is not installed.
### Warning: Dependency package mesa-dri-drivers is not installed.
### Warning: Dependency package mesa-libGL is not installed.
### Warning: Dependency package mesa-libGLU is not installed.
### Warning: Dependency package nss-softokn-freebl is not installed.
### Warning: Dependency package zlib is not installed.
by nám měl být odměnou běžící ANSYS Electronics Desktop 2021R1. Zatím jsem testoval pouze RMXprt a Maxwell 2D, kde se zdá, že vše funguje (v rámci ANSYSu) dle očekávání. Takže hodně úspěchů!


Update: Stejný postup funguje i pro Debian 11 Bullseye.

       

Hodnocení: 100 %

        špatnédobré        

Obrázky

ANSYS Electronics Desktop 2021R1 na nepodporované distribuci, obrázek 1

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

Komentáře

Vložit další komentář

Max avatar 3.2. 18:44 Max | skóre: 69 | blog: Max_Devaine
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Neznal jsem. Co v tom modeluješ?
Zdar Max
Měl jsem sen ... :(
pushkin avatar 3.2. 19:11 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Vesměs elektromotory, ale umí to mnohem víc - dají se v tom dělat obvody podobně jako v Simulinku, má to nějaký vysokofrekvenční moduly, umí to i antény a podobně. Klasickej ANSYS k tomu umí ještě mechaniku, teplo, proudění, nějaký chemický děje a to všechno propojovat a případně optimalizovat, ale to jde mimo mě.

Celkem fajn věc, akorát jak to má haldu funkcí tak je to taková věčná betaverze :)

Jendа avatar 3.2. 22:05 Jendа | skóre: 77 | blog: Jenda | JO70FB
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Naši kontraktoři dělají součástky pro radary v CST a WIPL-D, ale Ansys/HFSS se na tohle používá taky. Pak jsem v tom na nějakém videu viděl turbínu pro vodní elektrárnu.
Gréta avatar 3.2. 21:00 Gréta | skóre: 31 | blog: Grétin blogísek | Stockholm
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci

arternativa elemrfem zdarma nějaká hele

🚀 pozice české republiky v otázce obrany planety před asteroidy & kosmopolitní budoucnost lidstva hele 🚀
pushkin avatar 3.2. 23:14 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Ale jo, ono pár FEMů zdarma je, namátkou FEMM (na specifické 2D úlohy občas i rychlejší než ANSYS), kluci od nás přispívají do Agrose (ten je ale možná až moc komplexní) a kdysi jsem zkoušel něco, co se jmenovalo Salome, ale jelikož jsem lama, tak jsem tam neudělal ani model :)

Třeba proti Matlabu se ještě v omezený míře dá nasadit GNU/Octave, ale proti ANSYSu máloco :-(
Jendа avatar 3.2. 23:37 Jendа | skóre: 77 | blog: Jenda | JO70FB
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Ještě je OpenEMS, chvíli jsme na to koukali jestli by tím šla počítat anténa radaru, ale kvůli kombinaci ne příliš dodělaného SW a především naší neznalosti (není to „hurá spustíme solver a hotovo“, musí se dobře nastavit mřížka a vůbec) to nedáme a hodili jsme to na lidi s CST.
12.2. 13:59 JaSel | skóre: 17 | blog: kseles
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Prosím Tě, nevíš, jak je na tom samotný ANSYS? Provozuju ho* asi 10 let na Slackwaru a zatím nebyl problém, resp. nebyl problém, který bych nevyřešil pomocí ldd. Tak jestli mám při upgradu čekat nějaké potíže.

* - resp. používám ho jenom jako preprocesor k LS-DYNA, ale tu ANSYS cca před rokem stejně koupil.
pushkin avatar 15.2. 07:49 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Se samotným ANSYSem vetšinou problém nebyl, ale momentálně jsem ho nezkoušel. Uvidíme, jestli se k tomu dostanu, mohl bych ho zkusit zítra.
15.2. 13:03 JaSel | skóre: 17 | blog: kseles
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Zase kvůli mně to zkoušet nemusíš, já se k tomu časem dostanu. Myslel jsem spíše, kdybys to z nějakého důvodu dělal, tak dej vědět, jak to šlo. Dík.
pushkin avatar 24.2. 14:20 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Hele, tak to nevypadá vůbec dobře:
pushkin@pushkin-workntb:/opt/ansys_inc/v211/Framework/bin/Linux64$ bash runwb2 

Unhandled exception caught :

System.DllNotFoundException: Ans.QT.dll
  at Ansys.UI.Toolkit.QT.Application.SetPluginDirectory () [0x000f2] in <e7c7446121f840669624fa95f993ad23>:0 
  at Ansys.UI.Toolkit.QT.Application..ctor () [0x00006] in <e7c7446121f840669624fa95f993ad23>:0 
  at Ansys.UI.Toolkit.QT.UIFactory.newApplication () [0x00000] in <e7c7446121f840669624fa95f993ad23>:0 
  at Ansys.UI.Toolkit.UIFactory.newApplication () [0x0000f] in <10126af23bce40849ad4266af89c19d0>:0 
  at Ansys.UI.Toolkit.Application.InstantiateIApplication () [0x00000] in <10126af23bce40849ad4266af89c19d0>:0 
  at Ansys.UI.Toolkit.Application..cctor () [0x0000a] in <10126af23bce40849ad4266af89c19d0>:0 
--- System.TypeInitializationException: The type initializer for 'Ansys.UI.Toolkit.Application' threw an exception.
  at Ansys.UI.UIManager..ctor () [0x00060] in <ae858717b3ff416bbc7818997e97838b>:0 
  at Ansys.UI.UIManager.get_Instance () [0x00029] in <ae858717b3ff416bbc7818997e97838b>:0 
  at Ans.Program.Runtime.InitializeSplashScreen () [0x00060] in <cf1e21c8e81e4bdba692baf9de1b41d1>:0 
  at Ans.Program.Runtime.Initialize (Ans.Program.RuntimeSettings settings) [0x00237] in <cf1e21c8e81e4bdba692baf9de1b41d1>:0 
  at Ans.Program.ExecutableBase.Run (Ans.Program.CommandLineParse parser) [0x0000d] in <f93613d2cf72432192ab9d28923ae59b>:0 
  at Ans.Program.ExecutableBase.DoMain (System.String[] args) [0x000cf] in <f93613d2cf72432192ab9d28923ae59b>:0 
Jestli si s tím poradíš, tak dej vědět jaký je řešení, občas by mi Workbench taky bodnul :-(
2.3. 12:39 JaSel | skóre: 17 | blog: kseles
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
No, to mám radost...

Workbench nepoužívám, tak snad to nějak půjde. Poslední dobou i ten ANSYS používám jenom dávkově - v podstatě jenom pro základní geometrický model a síť. A moje modely jsou hodně geometricky jednoduché, takže si vystačím s APDL skriptem. Pak to uložím to texťáku a upravuju to napřímo (ty lsdynovské věci se stejně dělají v ansysu blbě). Lsdyna je taky řádková, tak je to celé takové jednodušší. Postprocessing dělám v LS-Prepost, to je ke stažení přímo u zdroje (LSTC). Dá se v tom dělat i preprocessing, to bych pak ten Ansys mohl vynechat úplně.

Každopádně jsem teď před pár dny ve Slackwareovském changelogu zahlíd zmínku o Slackware 15.0, tak s tím upgradem ještě chvíli vydržím.
pushkin avatar 24.2. 20:42 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Jo a taková perla - zrušili nám okrajové podmínky Master a Slave :-D Nyní jsou nově Binding a Bound :-D
2.3. 12:42 JaSel | skóre: 17 | blog: kseles
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
Asi bychom měli být rádi, že zůstal zachovaný počet. Představa, že někdo snaživě aplikuje genderovou teorii a budeme mít 56, nebo kolik, typů, je dost děsivá.
pushkin avatar 3.3. 10:18 pushkin | skóre: 42 | blog: FluxBlog
Rozbalit Rozbalit vše Re: ANSYS Electronics Desktop 2021R1 na nepodporované distribuci
:) Nerad bych definoval 57 okrajových podmínek :) Jinak koukal jsem, že další na řadě jsou šachy :-D

Založit nové vláknoNahoru

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.