abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 03:44 | IT novinky

    Společnost Fairphone stojící za stejnojmennými mobilními telefony představila (pdf) bezdrátová špuntová sluchátka Fairbuds 2. Opravitelná, s vyměnitelnými bateriemi a tříletou zárukou. Cena 119 eur.

    Ladislav Hagara | Komentářů: 0
    dnes 03:33 | Pozvánky

    O víkendu 17. a 18. října lze na brněnském výstavišti navštívit s jednou vstupenkou dvě akce: Maker Faire Brno, festival inovací, kreativity a kutilství, a GameDev Connect, akci určenou pro všechny současné a hlavně budoucí herní vývojáře.

    Ladislav Hagara | Komentářů: 0
    včera 20:33 | Nová verze

    Canonical vydal (email) Ubuntu 26.10 Stonking Stingray. Přehled novinek v poznámkách k vydání. Jedná se o průběžné vydání s podporou 9 měsíců, tj. do července 2027.

    Ladislav Hagara | Komentářů: 2
    včera 16:44 | IT novinky

    České Radiokomunikace (CRA) ve čtvrtek odstřelily rozhlasový vysílač Liblice B, dosud nejvyšší stavbu v Česku. O demolici dvou 355 metrů vysokých stožárů rozhodly z důvodu jejich nevyužívání, už v úterý přitom zhasly a demontovaly jejich osvětlení.

    Ladislav Hagara | Komentářů: 11
    včera 02:44 | IT novinky

    Microsoft Defender nově podporuje linuxové desktopy.

    Ladislav Hagara | Komentářů: 6
    14.10. 21:00 | Komunita

    Oficiální Epic Games Launcher je v nové preview verzi poprvé dostupný i pro Linux (FAQ). Pracuje se na novém Easy Anti-Cheatu pro Linux (EAC Linux v2) a podpoře hry Fortnite na Linuxu.

    Ladislav Hagara | Komentářů: 6
    14.10. 13:44 | Nová verze

    Desktopové prostředí KDE Plasma bylo vydáno ve verzi 6.8. Novinky zahrnují lepší podporu vzdálené plochy, sdílení a nahrávání obrazovky a řadu drobností napříč uživatelským rozhraním (úplný seznam změn, shrnutí ve wiki).

    ʚĭɞ 🍉 | Komentářů: 32
    14.10. 10:55 | IT novinky

    Apple představil 7palcový displej Apple HomeView s podporou Apple Intelligence a Siri AI pro ovládání chytré domácnosti, novou řadu vybavení chytré domácnosti Apple Home Collection, další generaci HomePodu mini a novou Apple TV 4K. Apple HomeView není v Evropské unii v prodeji, jelikož umělá inteligence Siri v rámci systému iOS v EU momentálně není k dispozici. Apple spolupracuje s EU a snaží se najít cestu, jak situaci vyřešit.

    Ladislav Hagara | Komentářů: 6
    14.10. 03:55 | Komunita

    KDE slaví 30 let. Přesně před 30 lety, 14. října 1996, poslal Matthias Ettrich do diskusní skupiny comp.os.linux.misc zprávu, která započala historii projektu KDE. Důležité milníky jsou zobrazeny na časové ose.

    Ladislav Hagara | Komentářů: 3
    14.10. 03:22 | Nová verze

    Byl vydán Mozilla Firefox 158.0. Stejně jako Chrome 155 s podporou JPEG XL (test). Přehled novinek v poznámkách k vydání a poznámkách k vydání pro vývojáře. Řešeny jsou rovněž bezpečnostní chyby. Nový Firefox 158 bude brzy k dispozici také na Flathubu a Snapcraftu.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2850 hlasů
     Komentářů: 32, poslední 11.10. 17:02
    Rozcestník

    Kauza html emaily

    13.2.2009 11:57 | Přečteno: 2312× | poslední úprava: 13.2.2009 11:57

    To som sa zase nas*al.

    Moja polovicka ma upozornila, ze niektore informacne maily od roznych firiem, co prijimaju su permamentne oznacovane ako spam. Tak som zapocal skumanie, ktore skoncilo ocakavanym vysledkom - prekvapenie - mail neobsahoval plaintext cast. Bol to len nejaky html bordel.

    Kedze to riesim s periodou opakovania cca 1 tyzden, nasiel som si cas spachat email nasledovneho znenia a odoslal ho na [postmaster,info]@[2_posledne_takto_dorucene_emaily(alza, stormware)]:

    ... blablabla ...
    Bohuzial, Vami odoslane emaily nesplnaju nalezitosti, ktore musia splnat, aby boli prijate nasim mailserverom bez problemov.
    
    Konkretne neobsahuje plain-text part, kvoli comu su mnohymi mailservrami ( 
    vratane nasho ) oznacovane ako podozrive. Mnoho emailovych klientov takisto  
    ma ( z objektivnych dovodov ) zakazane prijimat spravy v HTML. V pripade, ze 
    v sprave chyba textova cast, zakaznik nema moznost si tento email vobec 
    precitat.
    
    Poprosim Vas o napravu tohoto stavu, aby sme mohli tieto informativne email-y 
    od Vas prijimat bez zbytocnych problemov.
    
    Dakujem.
    ... blablabla ...
    


    Tento mail som odoslal na postmaster@ a info@ oboch domen. Ano, musim sa priznat, ocakaval som odpoved v style "plaintext by nam znemoznil supa-dupa formatovat a ofarbickovat kokotiny, ktore Vam posielame". Reakcia bola promptna, z oboch domen som dostal odpoved v desiatkach sekund. To som teda necakal! To je support !
    Za par sekund som schladol a nevedel som, ci sa mam smiat, alebo plakat. Posudte sami:
    From: postmaster@_domena_.cz
    
    Doručení těmto příjemcům nebo distribučním seznamům se nezdařilo:
    
    postmaster@_domena_.cz
    V e-mailovém systému příjemce nebyla nalezena adresa tohoto e-mailového příjemce.
    
    Server Microsoft Exchange se nebude pokoušet tuto zprávu znovu doručit. Zkontrolujte e-mailovou adresu příjemce a pokuste se tuto zprávu odeslat znovu nebo předejte správci systému tento diagnostický text.
    
    ________________________________
    Odesláno serverem Microsoft Exchange Server 2007
    
    
    Az na par pismen je obsah oboch mailov uplne identicky.

    Stracam idealy, zacinam vidiet svet pesimisticky. Dnes budem mat silne neproduktivny den...        

    Hodnocení: 100 %

            špatné • dobré        

    Anketa

    Co by ste robili odosielatelom ciste HTML mailov?
     (32 %)
     (52 %)
     (63 %)
     (70 %)
     (7 %)
    Celkem 97 hlasů

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    Komentáře

    Vložit další komentář

    13.2.2009 12:47 #Tom | skóre: 32 | blog: Inspirace, aneb co jsem kde vyhrabal
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Já bych HTML maily zrušil, kdo to smetí má furt mazat?
    stativ avatar 13.2.2009 13:39 stativ | skóre: 54 | blog: SlaNé roury
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Já ne, dobře se tak odhalují spamy…
    Ať sežeru elfa i s chlupama!!! ljirkovsky.wordpress.com stativ.tk
    13.2.2009 13:01 R
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Co by sa dalo cakat od firmy, ktora pouziva najnovsi Exchange? Usmevne to posobi hlavne v spojeni s faktom, ze najnovsi Outlook ma podporu HTML uplne rozdrbanu.
    Luk avatar 13.2.2009 13:17 Luk | skóre: 47 | blog: Kacířské myšlenky | Kutná Hora
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Co na to říct? Tohle. Postmasterovská adresa dnes nefunguje leckomu, včetně velkých firem působících v oblasti internetových služeb. To by ještě nebylo nejhorší - mnohem horší je, že jejich odesílátka mnohdy neskutečným způsobem prasí zprávy, které pak Spamassassin zcela logicky ocení nějakým bodovým přídělem, protože spammeři si s dodržováním pravidel ve většině případů vůbec nelámou hlavu.
    Šifrování je absolutní nutnost a pomáhá chránit před nekalými živly
    13.2.2009 14:12 Kvakor
    Rozbalit Rozbalit vše Re: Kauza html emaily
    On je totiz casto postmaster u mailu, co poskytuji webhostingy, nastaveny jako administracni ucet pro e-mailove ucty, takze i kdyz existuje a neni zablokovany, vetsinou se nevybira.
    Luk avatar 13.2.2009 14:56 Luk | skóre: 47 | blog: Kacířské myšlenky | Kutná Hora
    Rozbalit Rozbalit vše Re: Kauza html emaily
    To je samozřejmě chyba, zprávy z účtů tohoto typu by se rozhodně měly buď vybírat přímo nebo přesměrovávat někam, kde to někdo čte. Řeč je ale hlavně o firmách, jako je Seznam - tam se rozhodně nejedná o tuto situaci.
    Šifrování je absolutní nutnost a pomáhá chránit před nekalými živly
    13.2.2009 13:26 sssssssss | skóre: 15 | blog: cotoje
    Rozbalit Rozbalit vše Re: Kauza html emaily

     Nemam s tim problem a nechapu proc nekdo jo.

    hmm
    13.2.2009 13:30 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Bohuzial, Vami odoslane emaily nesplnaju nalezitosti, ktore musia splnat, aby boli prijate nasim mailserverom bez problemov.
    Jen tak dál. Čím víc správců si stanový nějaká interní (a nejlépe tajná) pravidla pro příjem e-mailů, tím dříve se stane e-mail pro takovýto druh komunikace nepoužitelný. Třeba pak všichni tihle odesílatelé a příjemci, kteří si stanovují vlastní pravidla, přestanou e-mail používat, a ti ostatní ho zase budou moci používat jako e-mail, se všemi pravidly dle RFC.
    msk avatar 13.2.2009 14:10 msk | skóre: 27 | blog: msk
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Jedna sa o defaultne nastavenie spamassasin v debian lenny. Tu je score:
    2.9 BAD_ENC_HEADER         Message has bad MIME encoding in the header
    0.0 HTML_MESSAGE           BODY: HTML included in message
    1.7 MIME_HTML_ONLY         BODY: Message only has text/html MIME parts
    0.9 MIME_HEADER_CTYPE_ONLY 'Content-Type' found without required MIME headers
    
    Ja za to, ze je niekto prasa, nemozem. Co sa tyka RFC, tak pokial sa bavime o 821, to pojednava len o transportnej vrstve. Takze kludne tade mozem poslat domace porno encodovane do base64 telnetom a pokial dodrzim tych par pravidiel, tak to v pohode odoslem. A to, ze to prijemca neprecita, je smtp uplne fuk.
    13.2.2009 15:04 pasmen | skóre: 45 | blog: glob | Praha
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Jedná se o RFC 2822, řekl bych.
    13.2.2009 15:04 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Kauza html emaily
    RFC 821 je už poněkud zastaralé, už pár let je nahrazeno RFC 2821. A pak také existuje RFC 2822 a RFC 2045 – 2049.

    Já jsem ale měl na mysli především váš údiv „já jsem si tu stanovil pravidla a oni si je nezjistí a klidně je ignorují“.
    13.2.2009 15:59 kavol | skóre: 28
    Rozbalit Rozbalit vše Re: Kauza html emaily
    ale "on" si ta pravidla nestanovil, ta pravidla jsou v RFCčkách, na která odkazuješ, to že je "on" nezná není až tak podstatné ;-)
    13.2.2009 16:39 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Kauza html emaily
    V kterém RFC je, že e-mail musí obsahovat i část Mime-Typem text/plain? Navíc autor píše pouze o nějakých pravidlech, která si sám stanovil – jak můžete vědět, že mezi těmi pravidly není třeba že odesílatel musí po celou dobu odesílání e-mailu poskakovat po jedné noze a bít se v prsa?
    Luk avatar 13.2.2009 15:07 Luk | skóre: 47 | blog: Kacířské myšlenky | Kutná Hora
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Co sa tyka RFC, tak pokial sa bavime o 821, to pojednava len o transportnej vrstve.
    Ale máme také například RFC 2822, kde jsou pravidla pro vlastní zprávy (ať už se přenášejí pomocí SMTP nebo jinak). Tam je kupříkladu napsáno:

    A date-time specification MUST be semantically valid. That is, the day-of-the-week (if included) MUST be the day implied by the date, the numeric day-of-month MUST be between 1 and the number of days allowed for the specified month (in the specified year), the time-of-day MUST be in the range 00:00:00 through 23:59:60 (the number of seconds allowing for a leap second; see [STD12]), and the zone MUST be within the range -9959 through +9959.

    Toto jsou zrovna pravidla, která bývají často porušována. Jinak se dá říct, že když se bavíme o zprávách a jejich vyhodnocování ve Spamassassinu, jde v první řadě o RFC 2822 (formát zpráv) a až následně o RFC 2821 (SMTP).
    Šifrování je absolutní nutnost a pomáhá chránit před nekalými živly
    13.2.2009 15:15 CET
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Che, to by me fakt zajimalo, jakou prasarnu do toho MIME a Content-type cpe:)
    Nicky726 avatar 13.2.2009 21:08 Nicky726 | skóre: 56 | blog: Nicky726
    Rozbalit Rozbalit vše Re: Kauza html emaily
    A co takhle být rád, že mi nemůžou obchody cpát reklamu horem, dolem i mailem?
    Enjoy the detours. There you’ll find the things more important than what you want. (Hunter x Hunter)
    13.2.2009 23:17 Mmurphy
    Rozbalit Rozbalit vše Re: Kauza html emaily

    Teď tedy úplně přesně nevím na co si autor článku stěžujě. Koukal jsem teď na zdroj jednoho informačního emailu právě z Alza a všechno je podle RFC v pořádku. V hlavičce je správně "MIME-Version: 1.0" a jsou tu dokonce i dvě části, jedna s "Content-Type: text/plain;" a druhá s "Content-Type: text/html;".

    To by si taky třeba mohl začít stěžovat, že jsem tenhle komentář nenapsal v ASCII.

    To že si někdo stanoví svá pravidla pro SPAM ještě neznamená, že zpráva je špatně.

    Luk avatar 14.2.2009 00:10 Luk | skóre: 47 | blog: Kacířské myšlenky | Kutná Hora
    Rozbalit Rozbalit vše Re: Kauza html emaily
    To že si někdo stanoví svá pravidla pro SPAM ještě neznamená, že zpráva je špatně.
    Jenže ony mnohdy ty zprávy špatně jsou. Například když mi chodily od Seznamu zprávy, na něž Amavis reagoval takto:
    X-Amavis-Alert: BAD HEADER Non-encoded 8-bit data (char F8 hex): Subject:
    	Zat\370\355zen\355 z\341pisu v ...
    a Spamassassin takto:
    X-Spam-Status: Yes, score=5.11 tagged_above=2 required=5
    	tests=[DNS_FROM_RFC_ABUSE=0.374, MSGID_FROM_MTA_ID=1.704,
    	NO_REAL_NAME=0.178, SUBJ_ILLEGAL_CHARS=2.854]
    Prostě naprasili osmibitové znaky do předmětu a více se tím netrápili. Ony byly navíc osmibitové znaky i v těle zprávy, aniž by tam byla hlavička Content-Transfer-Encoding: 8bit. To je další prasárna a současně porušení RFC 2822 ("If the body contains data in any bit-width other than 7-bit, the appropriate bit-width Content-Transfer-Encoding token must be used (e.g., "8bit" for unencoded 8 bit wide data).").
    Šifrování je absolutní nutnost a pomáhá chránit před nekalými živly
    14.2.2009 10:03 Karel
    Rozbalit Rozbalit vše Re: Kauza html emaily

    +1

    14.2.2009 10:56 Filip Jirsák | skóre: 67 | blog: Fa & Bi
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Škoda, že něco takového nenapsal autor původního příspěvku. Ten psal pouze o tom, že e-maily nesplňují nějaká jeho pravidla, přičemž jediné, o kterém jsme se dozvěděli, bylo to, že e-mail musí mít i text/plain část.
    msk avatar 16.2.2009 09:24 msk | skóre: 27 | blog: msk
    Rozbalit Rozbalit vše Re: Kauza html emaily
    Ja som na zaciatku diskusie pastol body z assasinu, kde to je presne vidiet. Pravdu mate v tom, ze nebyt tych 2.9 bodov za encoding, tak by to SA neoznacil ako spam. Co ale nic nemeni na veci, ze by som ten mail napriek tomu nebol schopny precitat.

    Založit nové vlákno • Nahoru

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.